RECORDING

Live Score/Note Recording

Setup

NOTE: If you don't have a MIDI keyboard controller you can also use your typing keyboard as a MIDI note keyboard. Simply select the Recording panel 'Typing keyboard to piano keyboard' option. Then follow the steps below:

Recording note data

While this may look like a lot of complicated steps, it covers all the note recording options. Once set, the next time you want to record notes it should be a case of steps 1, 6 and 8. Three mouse clicks.

  1. Select the Pattern - The note data will be recorded into the selected Pattern. You can only record into one pattern at a time. NOTE: You have the following two options as to how to record your MIDI data:
  2. Input quantizing - Use the Global Snap selector on the Recording panel to set input quantizing. Input quantizing will align notes to a precise timing, on beats or exact fractions of beats. Set to 'Line', 'Cell' or '(none)' if you don't want input quantizing.
  3. Turn on the Score recording filter - Right-click the Record button and make sure 'Score' is selected as a recording type (all data types with a tick will be recorded).
  4. Piano roll or Stepsequencer? - Usually you will want to record into a Piano roll. The MIDI settings option 'Record to step sequencer' should be off.
  5. Recording countdown - If you want a 'count in' select the Recording Countdown option on the Recording panel.
  6. Arm for recording - Select the Record button in the Transport panel. It will turn red to show it is ready to record.
  7. Select an Instrument Channel - Click on the Channel button of the instrument you want to record notes for. The selected Instrument Channel will also receive the note data and the instrument will respond to the controller keyboard.
  8. Press the Play button - FL Studio will play the project and record any note events received from your controller keyboard. When recording it's generally a good idea to turn on the Recording Countdown feature so that you have at least one bar lead-in metronome.

Where is my note data stored?

Generally note/score data is saved to a Piano roll. You may need to click on the channel and open the Piano roll to see your data. It is also possible to record the melody into the Step Sequencer (see the MIDI settings page, 'Record to Step Sequencer' option) associated with the instrument channel.

NOTE: If you are in song mode recorded patterns will automatically appear in the Playlist clip-tracks after pressing stop.

Score Logger

Always on: Never lose the perfect performance again. A three minute buffer records all note activity from external controllers and Typing Keyboard to Piano. This can be dumped to the Piano roll at any time with the Dump score log to selected pattern command on the Tools Menu. Perfect for retrieving those inspired improvised performances from the 4th dimension.

Automation

For recording mouse or external controller movements, see the section on Automation Recording.

Cancelling a recording session

You can cancel a recording session (so it does not apply the recorded notes and automation events) in two ways. The first one is to choose Cancel Current Recording command from Help menu, but note that you should do this while recording, BEFORE pressing the Stop button. If you press it, you can still undo the whole recording session by choosing Undo from the Edit Menu. If you had recorded mixer tracks during the last session, you will be prompted if you agree that the files are erased (i.e. undone). Be careful, because once you undo audio recording, the files can not be restored and you will have to record them again if needed.