• Adding plugins to the picker - Favorite the plugins as shown in the VST/AU section.
  • BROWSER

    Browser

    The File Browser provides access to projects, samples, preset libraries & VST/AU plugins. There are 3 tabs along the top that focus important sections including All, the Current Project and Plugin database.

    NOTE: The browser can be detached to a separate window or docked on the right side of the FL Studio desktop.

    Browser Controls

    Browser Menu - Options menu including search functions. The options here are discussed in more detail in the 'Browser Menu' section below.
    Collapse structure - Collapses all expanded folders in the Browser window.
    Refresh content - Rereads the contents of all folders in the Browser. Click this button to see any new files and folders that were created after FL Studio was started.
    Search (Ctrl+F) - Search all folders for files. Use (F3) to skip to the next matching item.

    Browser Snapshot - Remembers Browser state for quick recall. To save a Browser state click on the down-arrow select a slot to hold the configuration, open the Browser to state you want.
    • All, Current project, Plugin database - As shown below.
    • Snap 4 to 9 - Slots dynamically remember the last Browser state open while they were selected. You can rename these slots and add an icon in the same manner as default categories (All, Current project and Plugin database). Select a 'Snap slot' and click Rename / color from the bottom of the menu to enter a name and select an icon.
    • Auto (scroll) - Automatically opens the Browser based on the function/plugin/focus in FL Studio. Focusing the plugin opens its presets, focusing the mixer opens mixer presets, focusing the Playlist/Piano roll/Event Editor & switching patterns opens the project patterns, undoing/redoing opens the project history and linking a knob to a controller opens the project Remote control folder.
    • Rename - Renames the Snap 1 to 4 state slots.
    • Frozen - Freezes the currently selected slot and protects it from change. The slot will display a tick mark when frozen.
    Minimize - Reduces the Browser to the Caption bar. See also Menu > View > Auto hide browser.
    Close - Closes the Browser, as does (Alt+F8).
    All - Shows all content including the following two categories.
    Current project - Shows data associated only with the currently loaded project. The Remote control folder holds all Automation data created or recorded.
    Plugin database - Manage FL Studio and VST/AU plugins. You can right-click 'scan', 'favorite' and delete plugins.

    NOTES: The Divider - Left-click to drag the divider to change the width of the Browser. The divider can snap to a second position, move the divider to the desired location then Right-Click to swap between the new and/original location. Pop-out file-name view - File names obscured by the right edge of the Browser can be read by placing the mouse cursor over the item. Scroll bar - Click & drag or click to focus and scroll mouse-wheel. Quick Zoom - Hold Shift + Scroll -wheel.

    Working with content

    • Load files - Most items can be dragged from the Browser onto a compatible location in FL Studio (FL desktop, Plugin, Channel, Mixer, Edison, etc). Alternatively, Right-Click an item to 'send' it to a particular location. See below for details:
      • Drag and drop - Most items may be dragged from the Browser (Left-click, hold & drag) to the desired target in FL Studio and they will be loaded automatically. For example;
        • Instrument presets from folders or Instruments from the Plugin Picker can be dragged to Channels OR better, Mixer tracks to automatically set a routing to that track.
        • Effects to Mixer tracks or FX slots.
        • Samples to the Playlist to create Audio Clips or to Instruments that support samples (see note below).
        • Projects onto the FL Studio desktop to open them.
      • Send to selected Channel - Three good options are:
        • Right-Click menu - Right-Click the item in the Browser and select 'Send to selected channel' to load samples or instruments in the selected Channel.
        • Middle mouse button (often the mouse scroll-wheel is clickable) - Loads compatible content on the selected Channel.
      • Step through items in a folder - The (Shift + Up / Down Arrow) keys will step forward and backward through the items in the folder and send them to the selected channel or last touched window. This is particularly useful for trying out various samples in the Channel Sampler, more so if you have content sorted into folders of a particular type, e.g. Kicks, Snares etc. Swap samples while the Project is playing. Method:
        • 1. Select the Channel, plugin or click on the window.
        • 2. Click on the first item in the Browser list, then start stepping using the (Shift + Up / Down Arrow) keys.
    • Delete files - Right-Click the file and select 'Delete'.
    • Preview samples - Many items (.mp3, .ogg, .wav files) can be previewed in the Browser by Left-clicking on them. The Preview mixer track is set in the F10 > Audio Settings > Mixer preview track field (see note below).

      NOTE: Wav files may contain tempo and tempo-sync meta-data. This will be read by FL Studio if the General settings > 'Read sample tempo information' option is selected. If this information is used the preview will be time-stretched to match the tempo of the project and the sample may be similarly stretched when loaded into the Playlist. This can cause unexpected behavior if the tempo data saved in the sample is wrong. You can load any samples into Edison and open the File properties dialog to change the value of any incorrectly tagged samples.

    • Docking - The Browser can be docked to either the left or right side of the main window, by dragging it to either side of the screen. Click and drag on the word 'Browser' in the header bar. See video here
    • Can't see the Browser? - Turn it on using the Shortcut panel or press (Alt+F8).
    • Add folders - See how to add folders here.
    • Auto-open Browser folders - Auto open related folders as plugins are selected, select 'Browser Snapshot > Auto'.
    • Important project folder - The Current project folder will show all data associated with the currently loaded project. Useful for finding unwanted automation or initialized controls. The symptoms of (unexpected) initialized controls are controls that jump to some position every time play is pressed. You can delete these (see below).
    • Backup - The Backup settings are on the FILE tab on the System Settings dialog.
    • External file browser - Right-Click folders and select Open. See video here.

    More tutorial videos here - The Browser Video Tutorial Playlist.

    FL Studio project files

    FL Studio project files can be saved to one of two formats:

    FL Studio project file (*.flp) - To open Right-Click and select 'Open', middle-click the mouse-wheel or drag-n-drop on the FL Studio desk top. Project files contain the data that belongs to your project, including notes and sequencer data, patches and settings for all instruments, FX and channels, but does NOT include sample data (use .zip project files for that). Sample data locations are saved, and these will be scanned when the project is opened for the correct sample data. If the samples can't be found there FL Studio will search all custom folders added to the Browser. If you want to skip this extended search, press and hold ESC when you see the loading icon in the Hint bar.
    Zipped project file (*.zip) - To open Right-Click and select 'Open', middle-click the mouse-wheel or drag-n-drop on the FL Studio desktop. Zipped project files include all the data of the .flp file (see above), plus samples used by Audio Clips, Channel Samplers etc. It will not save VST/AU plugins themselves OR samples used by VST/AU plugins. The .zip format is the same compression standard as used by 3rd party applications. The file contains the .flp project plus sample data. When opening a .zip file, FL Studio will automatically decompress it, load the .flp project and any samples. Zipped files are a great way to archive an important projects or to share them with collaborators, even if the project uses non-FL Studio samples.

    NOTE: To export your project as an audio file (.wav, .mp3 or .ogg) use the File menu > Export option.

    Browser Menu

    The Browser menu contains the following options -

    • Search - Searches for files and folders using non-case sensitive searching. To cancel a search, press Esc.
      • Find (Alt+F) - Type in a search string after selecting this option. The exact phrase will be searched.
      • Smart find (Ctrl+F) - Allows the use of advanced search functions. Wildcards: 'sytr*' will find 'sytrus', 's*us' will find 'sytrus' or 'stylus'. TIPS: Use extensions ('searchword.flp' to search for flp's, etc). To include the 'Projects' folder in your search use the string 'projects' to your search as the project folder is not searched by default.
      • Smart find in the selected folder... (Shift+F) - As above but for the selected folder.
      • Find previous (F2) - Jumps to the previous item of the same search type.
      • Find next (F3) - Jumps to the next item of the same search type.
    • Navigation history
      • Previous (Backspace) - Return to the previous folder/item.
      • Next (Shift+Backspace) - Jump to the next folder/item.
    • Actions
      • Send previous to selected channel (Shift+Up Arrow) - Step up the list and send the file to the selected Channel.
      • Send next to selected channel (Shift+Down Arrow) - Step down the list and send the file to the selected Channel.
      • Send sample to Playlist (Ctrl+Middle-click)/(Ctrl+Enter) - Sends the sample to the Playlist as an Audio Clip.
    • View
      • Size - Changes the size of the font and spacing according to Compact, Normal, Large, Huge & Humorous options.
      • Autohide - The Browser will autohide and pop out when you move your mouse to the Browser location (usually left of the screen). To stop the FL Studio workspace moving you can click on the Browser header area and drag it to the right side of the screen. You can also use this method to undock the Browser and drop it anywhere on the screen.
      • Show only one folder content - Only one folder will be open at a time.
      • Show only opened folders - Allows the content of only open folders to be shown.
      • Show folder icons - Displays an icon for each folder in the Browser tree.
      • Show images - Shows the Plugin database plugin icons.
      • Show file extensions - Shows file extensions such as .wav, .mp3, etc.
      • Show unknown file types - Displays files not natively supported by FL Studio. You may be able to drag and drop these on VST/AU plugins for example.
      • Sort by - Name, Type, Date or Group.
        • Sort by Group - This option sorts folders or files according to the order specified by XYZ.nfo files in the ..\Program Files\Image-Line\FL Studio\Data\Patches\ directory, where XYZ = any folder or file name. Inside the .nfo file put the command SortGroup=1 to N. 1 will appear at the top while N is the last file to be sorted toward the top of the Browser. Unsorted files will appear below these as usual.
    • Structure
      • Collapse structure (Ctrl+Up) - Collapses all expanded folders in the Browser window.
      • Reread structure (Ctrl+R) - Rereads the contents of all folders in the Browser. Click this button to see any new files and folders that were created after FL Studio was started.
      • Current snapshot - Repeats Snap options (shown above).
    • Content
      • Configure extra folders - Opens the 'File Settings' Options (F10). Use this to specify folders outside the FL Studio Installation path that hold your plugins, samples, projects, etc. You can also drop any folder from an external File Browser onto the FL Studio Browser and it will be added to the list.
      • Refresh plugin list (fast scan) - Scans for newly installed plugins, see here for more details on installing VST/AU plugins.

    Browser Folders

    • Preview samples - If you Left-click on .wav, .mp3 or .ogg files they will be played. After clicking in a folder you can use the up/down arrow keys on your keyboard to step through the sounds in that directory.
    • Locate a known file - Dropping a file onto the Browser will open the folder where that file is located. This can be useful when you have a sample channel loaded and would like to try the others from the same folder.
    • Left-click a folder to expand/collapse it.
    • Right-Click and select Open to open a standard file browser.
    • Hover the mouse over the name of a folder for a short description in the hint-bar. The folders seen by default in the Browser window include:
      • Channel presets - Contains a collection of instrument/effects presets, scores, etc.
      • Projects - Contains a collection of sample projects (.flp files).

    Adding custom folders

    There are two ways to add your own custom folders to the Browser:

    • Drag and drop... - Open an external File Browser and then drag-and-drop the folder you want to add from the File Explorer onto the FL Studio Browser.
    • File options - Use the File options 'Browser extra search folders' list to add up to 30 custom folders. Custom folders appear in the Browser in green font.

    NOTE: Custom 'Extra search folders' and their sub-folders are scanned for samples and content when loading projects. So, it's not advisable to set the root of any drive as a search folder since it can make load-times for projects very long (while the whole drive is searched). On the other hand, this is a good trick for locating missing files you have moved somewhere and forgotten about.

    Current project

    The Current project folder contains information and data associated with the currently loaded project, such as a list of patterns, automated controls, instruments and an undo history list.

    NOTE: For direct access to MIDI CC parameters for Automation purposes, open the Effects or Generators folder (see below). Although the Tools menu > Last Tweaked automation linking process is usually faster.

    History - Contains the set of possible undo steps ('undo history'). The last action you performed is at the bottom of the list.

    Patterns - Contains a list of Patterns, Initialized controls & Automation. The item sub-folders contain the automated controls themselves.
    • Clicking on Patterns - Opens folders to show any Piano roll or Event Automation data. Clicking on sub-level items will open the target Piano roll or Event editor.
    • Right-Clicking - Displays a menu to expand, collapse or search for items/data. 'Delete item' 'will show where available.
    • Initialized controls - All recorded automation and initialized controls are listed here. Initialized controls - Set the value of a control at the song start. Initialization can be done manually, at any time, OR can happen automatically when an Automation Clip is created for a control.
      • To initialize a control - Right-Click and select 'Init song with this position'. Creating an Automation Clip will automatically initialize the target control, so the control can return to its original value, if the Clip is deleted. Initialization associated with Automation Clips can cause issues where you don't want the song to start with the initialized value. In this case you can manually delete the value for the control here OR disable auto-initialization under General Settings > Advanced > Don't initialize controls automatically
      • To remove an initialization - Right-Click the Browser entry and select Delete event.
    Effects - The Effects folder lists all effects used in the project. For direct access to MIDI CC parameters, for Automation purposes, open the Effects folder where each effect is listed as a folder containing all automatable controls for the plugin.
    • Tweak parameter - Left-click and hold to open a quick-access parameter control.
    • Automate a parameter - Right-Click the target parameter and select Create automation clip or Edit events to draw automation.
    • Link to controller - Right-Click and select Link to controller or Override generic link. See here for more detail on these two methods.
    • Make plugin thumbnail - To create a thumbnail image of the plugins used in your project use the Wrapper > Plugin menu to select 'Make editor thumbnail' for each plugin. The thumbnail will appear in the Generators sub-directory. NOTE: The Browser view must be larger than 'Compact' for the thumbnail image to display.
    Generators - The Generators (instruments) folder lists all generators (instruments) used in the project. It does not include the Channel Sampler, 3x OSC or Layer. For direct access to MIDI CC parameters, for Automation purposes, open the Generators folder where each Instrument is listed as a folder containing all automatable controls for the plugin.
    • Tweak parameter - Left-click and hold to open a quick-access parameter control.
    • Automate a parameter - Right-Click the target parameter and select Create automation clip or Edit events to draw automation.
    • Link to controller - Right-Click and select Link to controller or Override generic link. See here for more detail on these two methods.
    • Make plugin thumbnail - To create a thumbnail image of the plugins used in your project use the Wrapper > Plugin menu to select 'Make editor thumbnail' for each plugin. The thumbnail will appear in the Generators sub-directory. NOTE: The Browser view must be larger than 'Compact' for the thumbnail image to display.
    Remote control (Automation) - Contains the list of controls that are linked to external (MIDI) or internal controllers. NOTE: When controls are automated they are usually initialized (see Patterns > Initialized controls for more information).

    Plugin Database

    The Browser Plugin Database is one place to manage your plugins and to create favorite lists, another is to use the Plugin Manager that interacts with this database filling categories. About the folders:

    The Plugin database > Effects / Generators folders are your 'favorites' list. This is the data used to generate the Plugin Picker (F8) pop-up and various 'add plugins' menus in FL Studio.

    The Plugin database > Installed > Effects / Generators folders show ALL VST/AU plugins you have installed.

    See the video tutorial here

    Managing the Plugin Database

    • Adding favorite plugins to the Plugin database with thumbnail image. These images will show on the Browser and Plugin Picker ( video tutorial here).
      1. Open the plugin from the 'Installed' sub-folder.
      2. Open 'Plugin database > Effects' or 'Plugin database > Generators' AND sub-folder if required (Shift+F8) to the category where you want to 'favorite' the plugin. NOTE: Plugins may be saved to more than one location in the database, just repeat the method with a new location open.
      3. Save the plugin to the database by selecting the Plugin Wrapper menu option 'Add to plugin database (flag as favorite)'.

      4. Click OK to the popup and a thumbnail screenshot will be saved to the database at the currently opened location.

    • Adding favorite plugins to the Plugin database for use in menus including the Channel Rack > Menu > Add one option, Channel Rack + button and Main menu > Add option, FX slot menu etc.
      1. Open the plugin from the 'Installed' sub-folder that you want to add to the database.
      2. Right-Click the plugin - Select 'Add to plugin database (flag as favorite)'.
      3. Click OK to the popup and a thumbnail screenshot will be saved to the database at the currently opened location.

      NOTE: You can also 'favorite' plugins from a list using the FL Studio Plugin Manager tool if you are not interested in creating plugin thumbnails.

    • Remove plugins from the Plugin database - Right-Click the item in the Plugin database > Effect or Generators folder/s where it exits and select Delete file... NOTE: This does not delete the plugin from your system. To do that you will need to uninstall the plugin as per the developers instructions.

    • All that's for babies, I want to hack your code! - Advanced users can manually edit the plugin database, it is located in the FL Studio installation folder at "..\Data\Patches\Plugin database":
      1. Right-Click on the Plugin Database category - to see the context menu.
      2. Select 'Open' - This will open a standard external file browser.
      3. Edit stuff - Notice the file structure matches what you can see in the Browser, amaze at that for a while. Then notice that there are three files for each item (or two if you didn't save a thumbnail). Plugin name.bmp (the thumbnail image, 8 bit RGB color bitmaps), Plugin name.fst (the default preset plugins open with) and Plugin name.nfo (information for FL Studio, you can open this in any text editor).
      4. Backing up your database - If you have extensively customized the list you may want to make an external backup copy of this directory as a precaution against loss of data during future FL Studio installations.
      5. +1 up your file management skills - Check this page.

    Plugin Picker

    The Plugin Picker (F8) displays the plugins in the database as an array (generators left, effects right, as shown below). To use the Plugin Picker, click, hold & drag the icon of the plugin you want to use. The picker interface will close leaving you holding the plugin ready to drop on the desired location inside FL Studio. Alternatively double-clicking a plugin will load it into a new channel or double-clicking an effect will load it into the currently selected mixer track.

    TIP: Start typing the name of plugins to concentrate the Picker panel options.

    • To open the Plugin picker

      Press (F8), use the Shortcut Toolbar, (Middle-click) on the FL Studio Desktop or from the Add menu. There is also a related Project picker (Ctrl+F8).