CHANNEL RACK

Channel Rack & Step Sequencer

The Channel Rack holds instruments that create sound and internal generators that control automation. Every pattern has access to all instruments in the rack. In other words, all patterns play from the same set of instruments. Patterns are not limited to a single instrument as they are in most other sequencers. Music data can come in the form of Step sequences and Piano roll scores.

There is one Channel button per instrument. The audio from each Channel is sent to one of the Mixer Tracks for effects processing and level mixing. When Instrument Channels are added or removed from the project the height of the Channel Rack will change dynamically. The Channel buttons also access Instrument Channel Settings (where a Mixer track is set) or the associated Piano roll. The Step Sequencer, ( Video Here) is a pattern-based grid sequencer ideal for creating drum loops and simple melodies.

The note and automation data visible across all Channels is known as a 'pattern'. Patterns include Piano roll, Step Sequencer and Automation data. Switch between patterns using the Pattern selector (15) shown below. As the pattern number is changed, note how the pattern data visible in the Channel Rack also changes, reflecting the selected pattern. Patterns are designed to be arranged in the Playlist as Pattern Clips to create a song.

Overview

Each row of controls in the Channel Rack belongs to a single Channel instrument. From left to right are: Mute, Pan, Volume, Mixer Track destination, Channel button (click this to open the instrument interface), Channel Selector (outer border) / Activity indicator (inner region) and Step Sequencer buttons or Piano roll preview (top row below), depending on how the Channel has been configured.

NOTE: When Options > General settings > Auto select linked modules is:

1. Channel Options Menu

NOTE: The Channel Options Menu swapped places with the Pattern Menu at FL Studio 12.

2. Channel Filter Groups

As projects grow in size and the number of Channels increases, finding the right Channel can become a tedious process. To optimize workflow, combine several Channels in a group and set the Step Sequencer to display only that specific group of Channels (for example percussion group or lead synth group). Use the Channel Display Filter control (2) to choose which Channels should be visible. Left-click to open the Channel filter menu. Selecting 'All' will show all Channels at once, regardless of whether they are part of a group or are unassigned. Selecting 'Unsorted' displays only the unassigned Channels. If you have made any Channel groups, you can select them for display from this menu.

Channel Display Filter (Page Down for next group; Page Up for previous group) - Allows you to set the group of Channels to show in the Step Sequencer (see the Channel Filter Groups section below for more information)

Other Channel filter group actions include:

3. Global Swing

Swing - Slide to the right to add a 'swing' rhythm to Steps. In the case of the Step-sequencer, swing affects the length of odd vs even steps. If 4 beats per bar are set, 'swing' holds odd 16th notes (1,3,5,7,9,11,13,15) at the expense of even 16th notes (2,4,6,8,10,12 and 16) in the bar. The control determines the amount of swing. NOTE: Each Channel has a Swing Multipler knob under the 'Time' section. This allows you to set per-channel swing relative to the global setting.

4. Step/Piano roll View

The Stepsequencer overlays the Piano roll and so switching to this mode allows you to edit stepsequences in Piano roll mode, so long as you respect the note length (zero length) and positioning (on beat) layout. NOTE: The Channel Rack Menu > Mute removed steps option will preserve note event data (volume, pan etc) associated with steps so settings are not lost when experimenting with different step-patterns. Deactivated steps will show in the Piano roll as muted notes. When deselected the event data is discarded and no muted notes preserved in the Piano roll.

If you would like to convert a Piano roll to Step mode again, you need notes of zero length. Select all notes, set Snap to 'none' and Discard note lengths (Shift+D).

5 & 6. Pan & Volume

These knobs control the Pan and Volume of the Channel pre-mixer and so can be used as Pre Fader Level (PFL) controls. You can choose to adjust Pan and Volume here AND OR in the Mixer. What you do depends on the workflow that suits you best and how the plugin responds to these controls. NOTE: The Pan and Volume controls are sent directly to the plugin, rather than acting on the output audio, so how they are interpreted will depend on the plugin, as discussed below:

7. Channel Button

The Channel Button - Displays the Channel name (usually the name of the instrument). Left and Right-clicking provides the following functions:

8. Channel Selector

Channel Selector - When lit, the Channel is selected (used in cut, copy, etc. operations - see Edit menu). The selected Channel also receives MIDI/Controller input.

9. Piano roll Preview

This mini-note-preview replaces the steps when a Piano roll is active on the Channel. The preview allows you to see the notes in the Piano roll without opening it. You can't edit notes in the mini-preview. Left-click the preview to show/hide the Piano roll window. Right-click to open the Piano roll centered on the notes clicked. NOTES: 1. The lighter and darker blocks in the preview indicate the number of bars contained in the Piano roll sequence (each block is a bar). 2. To add a Piano roll Right-click the Channel button and select 'Piano roll' from the pop-up menu.

10. Mute Control

Track Mute / Solo - Turning this LED off will mute the Channel. Clicking it again will unmute it. You can also quickly solo a Channel by Right-clicking the LED and, from the popup menu, select Solo. Repeat this action to unsolo the Channel (unmute all). NOTE: Live MIDI input to the Channel will continue to play regardless of the switch mode as mute/solo applies only to Step Sequencer and Piano roll playback.

11. Stepsequencer

Using the Stepsequencer:

12. Mixer Track Routing

The Mixer Track Routing controls are optionally shown (Alt+M). Click and drag vertically to change the Mixer Track the Channel is routed to. By default, all new instrument Channels are routed to the Master Mixer track (the display shows "---"). This control doesn't appear for Channels that hold generators that don't output audio, icons will be shown instead. The Mixer Track Routing control is also replicated on the Channel Settings.

13. Add Plugin Channels

Add a plugin - This is a shortcut to open the Channel Options Menu > Add one menu. To lean more ways to add both instrument and effect plugins to projects click here.

14. Pattern Length

Pattern Length (Number of Beats) can be set by dragging the bottom-right of the Channel Rack to set the number of beats. You can also set the default pattern length from the global value on the Project Settings. Note: There are a maximum of 64 steps in the Step Sequencer. If you need more then use the Piano roll.

15. Pattern Selector

The Pattern selector is located in the FL Studio Tool Bar and also the Pattern Menu from the Main Menu. For more on working with Patterns, and how they are used, see the Arranging Workflow section.

Select (left side) and name, copy & work with patterns (right side) from this drop-down menu.

Red Channel buttons

If you open a project and some, or all, Channel buttons are red, this means the samples or instruments nominated for those Channels can't be found. The likely causes are -

  1. The samples or directories have been renamed, moved to another location or deleted.
  2. The format of the sample has been changed (FL Studio only loads .wav, .mp3 and .ogg files).
  3. The Browser extra search folders have been deleted from the search list.
  4. The VST plugins extra search directory has been deleted from the search list or the plugin directory moved.

FL Studio searches its own installation directory for samples and the extra search folders as described above. If you have no idea where the samples are, one method is to put your root drive (usually C:) as one of the extra search directories, then reload the project. FL Studio will now search you entire hard-drive. Once you locate the samples it's a good idea to remove the root from the extra search folders as is can make future searches very slow. See the section on missing VSTs or files for more information.

Linking Controllers to Play Instrument Channels

Use a keyboard or other controller to play selected Instrument Channels. By default FL Studio listens to all MIDI Channels, so any enabled controller will play the selected Channel. However, if you want to lock a controller to play a specific Instrument Channel, there are two options:

Lock Controller Notes to Instrument Channels

This method locks Instrument Channels to the note output from the specified controller. You can lock multiple Instrument Channels to a single controller to record layers OR even lock several controllers to a single Instrument Channel.

Video Playlist Here.

How to set a Channel to receive notes from a MIDI Controller:

  1. To set a specific MIDI Input Port (optional) - Pre-set an Input Port from the MIDI Settings > Input > Port options. Otherwise choose 'No input port set (click to auto assign)' at the next step.
  2. Right-click the Channel Button - Select 'Receive notes from > [choose a controller] > No input port set (click to auto assign)'.
  3. To set a specific MIDI Channel - After choosing the controller (Step 2), repeat the process and select a MIDI Channel. Normally choose 'All MIDI channels'. If you choose a specific MIDI Channel, the instrument will only respond to controller notes received from that controller and MIDI Channel.

    TIP: If your controller can transmit on different MIDI Channels across the keyboard/pad range, you can play different Instruments Channels with the left and right hands, or a drum kit consisting of up to 16 Sampler Channels.

IMPORTANT: Only the note information is locked to the Channel. To assign knobs and sliders (MIDI CC) to specific plugin targets, use Per-Project Links.

Features of locked Channels:

Floating Assignment of Controller Notes to Instrument Channels

This method is less rigid than the 'Receive notes from', above and is how FL Studio worked prior to FL Studio version 12.3. Selected instrument Channels are assigned to controllers based on their MIDI Channel number. For this method to work you must set each controller to transmit on a unique MIDI Channel (i.e. 1 to 16). The lowest MIDI Channel will control the top-most selected Instrument Channel and the highest MIDI Channel the bottom-most selected Instrument Channel (see the image below).

  1. Set MIDI Channels - Set each controller to transmit on a different MIDI channel number (1 to 16, see the documentation that came with the controller on setting MIDI send/transmit channels). This is to avoid controller CC conflicts (where more than one controller tries to adjust the same software control on the same MIDI channel). See the documentation that came with the controller on setting MIDI send/transmit channels. By default, FL Studio listens to MIDI data in OMNI mode (all channels 1 - 16 simultaneously).
  2. Select Instrument Channels - Right-click Channel Selectors for as many Channels in the Channel Rack as you have active controllers. The controller transmitting on the lowest MIDI channel number will be assigned to the top-most selected Instrument Channel. Selected instrument channels below are assigned by ascending MIDI channel number (i.e. lowest MIDI channel = top selected instrument channel, highest MIDI channel = bottom selected instrument channel). When only one channel is selected then all controllers will play that instrument channel. When more instrument channels are selected than there are active MIDI controllers, then top most instrument channels will be assigned.
  3. Changing controller to plugin relationships - The simplest method is to move the target Instrument Channel up/down in the Channel Rack stack (select the target instrument channel, hold the Alt key and press the up/down arrows on your keyboard OR Shift+Mouse-wheel with your cursor over the Channel button). Remember that instrument channels are assigned to controller MIDI numbers, from top to bottom in the stack.

    NOTE: When Options > General settings > Auto select linked modules is: