New Features in FL Studio 12.9 BETA

This is a list of notable new features and changes in FL Studio 12.9 BETA. For the complete list (including bug fixes) please check the 'WhatsNew.rtf' in the FL Studio installation folder: '..\Program Files\Image-Line\FL Studio\WhatsNew.rtf'. FL Studio 12 YouTube playlist.

FL Studio includes Lifetime Free Updates, there may be a new version with more features, check online here.

FL Studio 12.9.3 BETA

What's New Beta 4

  • Updated Toolbar - New Toolbar design and editable layout.
  • View > 'Test' - Options menu to run predefined tests for development and techsupport.
  • Mixer/Channel rack - Renamed the '(none)' preset used to delete generator and effect plugins to '(delete)' to help reduce confusion.
  • Channel Settings - Renamed Sampler Settings option 'Load ACID markers' to 'Load slice markers'.
  • Harmor - Visual feedback panel scaling oct/Hz scaling saved with the plugin settings.
  • ZGameEditor Visualizer - New effects from Youlean: 'Blur', 'Motion blur', 'Bloom' and 'Color correction'.

Key Features:

  • Mac support - FL Studio is now available as a 64 Bit native macOS Application. Includes Audio Unit (AU) and VST plugin support. AU plugins will scan, along with VST plugins, using the Plugin Manager.
  • Time signatures - See the sections for the Playlist & Piano roll. The default Time Signature is set in the Project General Settings and Time Signature changes with Time Markers. Right-Click Time Markers and select 'Time signature'. Use (Shift+Alt+T) to set time-signatures from the playhead position or over the selected time-range. Use the on Pattern Clip Menu 'Use current time signature' to set a Time Signature based on Playlist position.
  • Consolidate Clips (~ Freezing) - Bounce selected Audio and Pattern Clips to a single Audio Clip via:
  • Playlist Arrangements - An 'Arrangement' is the layout of Audio, Automation and Pattern Clips in the Playlist as you added them. Use the drop-down Arrangements menu to manage multiple Playlist versions of the project (working ideas, sound design, versions etc).
  • Plugin Delay Compensation - Automatic PDC now work for all normal use-cases including for Mixer sends. Manual and Auto-PDC can now co-exist. Manual PDC is applied as an offset to Auto PDC. Updates include:
    • Audio recording - New audio input delay control on the INPUT menu, to fix latency issues with individual audio inputs.
    • Icon colors - Automatic (Orange), Manual (Blue) or not set (gray).
    • Mixer menu - Plugin Delay Compensation > Reset manual latency on all tracks - Option to reset all manually set latency values to zero.
    • Metronome - Now latency compensated.
    • Mixer FX Slots - Latency compensated Wet/Dry mix knob. Processing delay is now compensated when mixing the Wet/Dry signals from an effect for each FX slot.
    • Continuous adjustment - Roll the mouse wheel over the time icon or latency display (Mouse Wheel) = 10 ms steps, (Ctrl+Mouse Wheel) = 1 ms steps, (Ctrl+Alt+Mouse Wheel) = 1 sample steps. Mouse Wheel works in three places: Track Input latency icon (FX panel), Track Output latency selector (FX panel), Track Output latency icon (Mixer Tracks).
    • Wrapper Offset - The latency shown in the Wrapper Info can be set and saved per plugin. Use to compensate plugins that consistently report an incorrect latency.

Classic Features Return:


  • Playlist Tracks - Increased to 500 from 199.
  • Audio recording - Realtime display of audio data as it is captured. Multiple takes are grouped when recording.
  • Playlist menu - View > Resize all tracks. Choose from 33% to 200%.
  • Time Markers - Punch in/out Time Markers so you can start/stop recording using Time Markers.
  • Hide grouped tracks - New option 'Playlist Menu > View > Hide collapsed grouped tracks'. When used a small arrow on the right-side of the Track header can be
  • Playlist preview - 'Playlist Menu > View > Mini playlist preview' is selected by default.
  • Playlist Right-Click header-menu - Right-Click options to 'Mute all clips' and 'Unmute all clips', to make undo of consolidated tracks faster.
  • Playlist - Improved visibility of Clip borders in Solid view mode.


  • Edison (update) - 24 Bit file export option.
  • Fruity Reeverb 2 (Update) - Modulated reverb using Modulation (amount) and Speed options to break up 'ringing' or 'metallic' sounds.
  • VFX Level Scaler (New) - Scale Note Properties as received from the Piano roll. The graph shows input-output mapping for Note - Velocity, Release, Pitch (fine), Pan, Mod X and Mod Y values.
  • DirectWave (Update) - A Zone's loop type can now be set for all selected Zones at once. New 'Copy to selected zones' option for some Zone parameters.
  • Fruity Convolver (Update) - Added a PDC control (), just above the Editor window, to set an impulse's latency so PDC is correctly applied. Related, there are two new Linear Phase EQ presets, 'Linear phase EQ (Long compensated) and (Short compensated)' that make use of this feature.
  • Fruity Reeverb (Update) - Is now a 64 Bit FL plugin.
  • ZGameEditor Visualizer (Update) - Layers can be collapsed. Buffered layers are more obvious. New 'SplinePeaks' effect. Text position and size can now be specified in decimals. Copy/paste layer to and from clipboard. New project 'Wizard' presets. Increased responsiveness to 'Linear' peak effect. Color button on HTML tab to paste color to test.
  • Patcher (Update) - Reduced memory usage.
  • Updated plugins (general bug fixes) - BassDrum, Drumaxx, Drumpad, Effector, GMS, Hardcore, MiniSynth, Morphine, PoiZone, Sakura, Sawer and Toxic Biohazard.


  • Mixer - Increased to 125 Mixer tracks from 104.
  • Mixer (Layout Menu) - Two new layout options (Compact Alt, Wide Alt), showing track names at bottom.
  • Reset mixer tracks - Right-Click option for selected Mixer tracks 'Reset selected track(s) to default'.


  • Sampler Channels - >New 'Start offset' (automatable), 'Sample start' (precomputed), and 'Length' (precomputed) controls.
  • General settings - 'Hide plugin toolbars by default' is now on by default.
  • General settings - 'High visibility' option that makes switches and selected icons more obvious. Shows the hover rectangles around (most) switch buttons/icons. Scrollbars show hover color (white). Useful for those with color/vision deficiencies.
  • Render dialog - New options to 'Save loop' and 'Playlist markers'. Renamed 'Save Acidized' to 'Save tempo information'. Renamed 'Save slice markers' to 'Save note markers'.
  • Piano roll - The root note is more visible with keyboard 'scale highlighting' set.
  • Browser - The Drag-and-drop location of samples previews when dragging from the Browser to the Playlist.
  • Help - FL now uses the online version of the manual.
  • In-App Purchases - When saving using projects with demo plugins, or FL Studio upgrade features, it's now possible to buy plugins & upgrades from within FL Studio.
  • Installation - Option to unlock with a FLRegkey.Reg file from the 'Help > About' window
  • Tap tempo - Sync option for tempo tap is now off by default.
  • Toolbar - All tool panels 1-unit high to allow for a more streamlined tool-bar for those who want it. Transport Panel - Has now been divided into 2 1-unit high panels. Transport and Recording Options panels. More later...
  • Unicode Text - Most FL plugins now support unicode characters when exchanging filenames and other text with FL Studio
  • User data changes - Projects and Backup folders are now saved to a 'FL Studio' subfolder in the system shared data folders. Win: '..\Documents\Image-Line\Data\FL Studio\Projects' folder. macOS: ..\Documents\Image-Line\Data\FL Studio\Projects. An 'Old projects' points to the legacy location. We recommend moving your projects to the new location.
  • Channel Rack - Menu > Channel name alignment. Names can now be left justified or centered.
  • About Panel - Option to show password while typing (no more mistakes!).
  • Score logger - Tools menu > Dump score log to selected pattern. Additional time options - 2, 5, 10, 20 or 30 min.