PANELS

Toolbar Panels & Icons

FL Studio Toolbar, by default, is located at the top of the screen and provides quick access to many commands and options. Many of these commands are also available, contextually, in FL Studio menus and windows.

NOTES: Click on the above image for help on that panel. Dragging content over the main window buttons (Playlist, Channel Rack, Piano roll) will bring these windows to the front if they are not already visible. To see how to edit the Toolbar click here.

Toolbar Controls

Toolbar Panels

Menu Bar

The Menu bar provides access to the main menus of FL Studio. Click the menu image to access help for that item:

Title & Hint Bar

  • Title Bar (Upper) - Shows the name of the project currently open in FL Studio.
  • Hint Bar (lower) - If you place your cursor over any control a short description of it will appear here. The hint bar will also display the value of a wheel or slider during adjustment. There is an additional Extended Hint Panel, that displays the same information in a larger format. To select it, use the View Menu > Toolbars > Hint bar option.

    The Hint Bar is particularly useful. Position your cursor over any control and a short description will appear. If you click on a control, the value will be displayed (Right-Click and copy any value from a control if desired). Similarly 'hovering' your cursor over most peak meters will show the value at the pointer position. On the right you will find different icons explaining what the hovered item is capable of:

    Icon display - From time to time you will see various icons:

      Recording - The parameter can be automated, recorded, respond to an envelope controller.
      MIDI plug - The parameter can be linked to anything (a MIDI control, an internal controller etc)
      Right mouse button - Whenever you see this, it means that you can Right-Click the control in order to access a popup or other feature. However, the lack of this icon doesn't necessarily mean that there is no Right-Click feature. Always try clicking a control with every mouse button.
      Happy face - Shown when things went fine (such as a successful search in the Browser).
      Sad face - Shown when things went wrong. Rarely seen.
      Attention/warning - Shown when the hint is important and you shouldn't miss it.
      Clock - Shown for some lengthy operations. Rarely used, as the hourglass mouse cursor is used instead.
      Fast forward - Shown when holding a fast-forward key (Playlist, Edison)
      rewind - Shown when rewinding/scrubbing (Playlist, Edison etc)
      Arrow to the left - To be honest we can't remember where we used this one, or if it was *ever* used. Tell us if you see it, and what you were doing, we want to know! :)
      Group - Shown for 2 events that are linked (grouped) together.

      NOTE: There is an optional, larger, floating Hint panel revealed by the View > Toolbars > Hint bar setting.

    • Sync indicator - Used to indicate various controller and MIDI activity. MIDI Activity colors: The control blinks when MIDI data is received from a controller/MIDI input device (see Linking Controllers). Colors:
      • Orange - MIDI input handled. Input was received and was assigned to a Project volatile link target.
      • Blue - MIDI input received and was assigned to a Global permanent link target.
      • Green - MIDI input unhandled. MIDI input received but was not used by anything (the futility!).
      • Grey - Nothing detected.
    • MIDI Sync - Blinks at the beginning of each beat and signals blue at the beginning of each bar. Note: The Sync LED works only when the Enable MIDI Output option in Options menu is checked.

Extended Hint Panel

The extended Hint Panel appears in the lower-left corner of the FL Studio desktop. It relays the same information shown in the Main Hint Bar including knob/slider values as the targets are manipulated and help-hints for objects when the mouse cursor is placed over them. The extended Hint Panel is transparent to mouse clicks so that objects beneath it can be manipulated.

Controls

  • Information - If you place your cursor over any control, a short description will appear in hint area. When a control is moved its value will be displayed.
  • To open/close the Hint bar, select the View Menu > Toolbars > Hint bar option.
  • To move - First make sure to select View > Toolbars and uncheck 'Lock'. Then move the mouse cursor to the center of the progress circle (the hit bar will fade slightly when you move over it and a cross cursor should appear). Next, click hold and drag the Extended hint bar to a new location. On larger displays the empty tool-bar area along the top has proven popular.

Transport & Recording Controls

The Transport Panel contains controls for playing, recording and setting song tempo:

  • Pat/Song mode (L) - Switch between pattern and song mode. In Pattern Mode, only the current pattern is played. In Song Mode the whole Playlist arrangement is played. Right-Clicking this control toggles the Playlist window. For more on working with Patterns and how they are used, see the section in the Channel Rack about managing patterns and Arranging Workflow.
Play/Pause (Ctrl + Space) - Press the button once to play, again to pause. To Play/Stop use (Space). When the record button is armed, pressing Play starts the recording process. NOTE: There are also play buttons on the top bar of the Piano roll, Channel Rack / Step Sequencer and Playlist to aid workflow.
Stop (Space) - Stops playback or recording. To pause playback use (Ctrl + Space). Right-Click the Stop button to show the start location option:

  • Remember seek time - After pressing stop or (Space), Play will start from the selected position (click on the Playlist time-line to select).

Record (R) - Switches between record and play mode. You can automate the button with Start/Stop recording Time Markers. Right-Click the Record button to show the Recording Filter options (all items with a tick will be recorded, Left-click to select items):

  • Automation - Record movements of knobs, sliders and switches by the mouse or from controllers. Turn this off if you want to adjust mixer track volumes, generator settings, etc. while recording external audio and you don't want those movements recorded.
  • Notes - Record note data from keyboards and drum-pads, etc. Turn this off if you want to accompany a vocalist, for example, but don't want to record your keyboard performance.
  • Audio - Record audio.
  • Clips - Record Playlist Clips as triggered when in Performance Mode. These will be saved after the 'Start' Time Marker.
  • Recording starts playback - Pressing the record button will start the project playing.
  • Disarm on stop - Deselects the master record switch when the project is stopped.
  • Enable recording markers - Enables the function of Timeline Markers of type Punch in/out. Punch in/out recording allows you to automate the main Record button to record for only a section of the Playlist. To set a Time Marker (Right-click) it and choose Punch in or Punch out.
  • Quantize options - See the page on Note Recording for details.
    • Note start time - Note start time is quantized when one of the Global Snap settings that quantizes input is used.
    • Note end time - Note end time is quantized when one of the Global Snap settings that quantizes input is used.
    • Leave note duration - Leaves note duration as played. Logic dictates this option is not compatible with all other quantize combinations.

  • Tempo (larger digits) - Shows/sets song tempo (10 - 522 BPM). To change the tempo of individual patterns, edit the Piano roll data and or number of Stepsequencer steps for that Pattern so the new tempo is achieved. To set the Time signature use the Project General Settings.

    • Tempo automation - Right-Click the Tempo Display and select 'Create automaton clip'. To set exact values on the Clip, Right-Click it and add Control Points at the start and end location for the Tempo change. Next, Right-Click the tempo display and select 'Type in value...' and enter in desired tempo. Right-Click the display again and choose 'Copy value'. Finally, Right-Click the Automation Clip control point you want to set to that value and select 'Paste value'. NOTE: By default, Tempo Automation Clips Min/Max range are set to produce Tempos between 60 to 180 BPM.
  • Tempo fine tune (smaller digits) - This control lets you fine tune the tempo of the current project in units of 1/1000 BPM. The value set here will be added to the base tempo. Note that it's not recommended to use that setting when starting a new song (it is better to use a whole number for your tempo). However, it can be used to match the exact speed of another song to be mixed in a FL Studio project (for making using existing sampled loops, 'cover songs', etc).

    Right-Click the LCD screen for some tempo presets & commands:

    • Automation and linking - The usual automation controls such as Edit events, Create automation clip, Copy and Paste value etc.

    • Tap - The project can be playing when you launch the tap tool. Click the tap icon repeatedly with the desired tempo in mind. The tempo will start to adjust after the second click with a bar indicator showing the ideal number of taps.

      • +/- nudge - Hold the buttons to temporarily speed or slow the project tempo to sync with some other live source. On release the tempo returns to the set speed OR with the Tap Tempo open pitch bend from your MIDI controller will act as a smooth nudge. Nudge is most useful where you know the tempo of the other audio source but the beats are out of sync or phase. Simply nudge to sync/phase.
      • Sync - With 'Sync' on each tap will reset the downbeat and repitch Audio Clips to align their time with the BPM. A single tap can be used to realign FL playback to external audio for example. This only works if your Audio Clips are already synced/locked to the grid before using this option. Turn off 'Sync' in the Tap window if you don't want it to alter the playback of whats currently in the playlist. For example you can drop an unsynced Audio Clip onto the Playlist and tap along to find its tempo. Sync off is the most common use case.
      • Mute - For use with Performance Mode, the project will be muted when tapping starts then automatically fade in over the next few taps when (presumably) the tempo is more stable and at the desired speed. The fade-in allows you to clearly hear the other live source to get your tapping in sync and avoids the worst case out-of-sync live playback.
      • Now - Mute now, for a few bars.
    • 80bpm-160bpm - Some commonly used tempo presets.
    • Half speed - Play the song at half the current BPM setting. The value shown in the Tempo field does not change when 'Half speed' is set. This is a temporary state to make it easier to record difficult note/event performances, making it easier to switch back to the original tempo was after you are done.

Song Position

  • Song position - Shows/sets the playhead position in the Playlist or Piano roll, depending on the Song/Pat selector. Click and drag to move.

Window Control Icons

Window control icons - Minimize, Restore (over task bar), Close controls for FL Studio's window:

Windows (left): Minimize, Restore, Close. Mac (Right): Close, Minimize, Restore

  • Minimize - Minimizes FL Studio to the Windows Task-bar or Dock. Click the icon there to restore the window.
  • Restore - Right-Click (Alt+Enter) to Show/hide the Windows task bar / Dock.
    • Multi-monitor mode - Click the center control then click on the right-most edge of the FL Studio desktop and drag across the screens you want to occupy. Alternatively, a number of FL Studio windows can be detached from the desktop and moved to a different monitor. See the menus associated with the main FL Studio windows (e.g. Playlist, Piano roll, Mixer, etc.) and look for the 'Detached' option.
  • Close (Alt+F4) - Closes FL Studio. Right-Click menu:
    • Stop playback
    • Restore - Restores FL Studio to the maximized state.
    • Minimize - Minimizes FL Studio to the task bar / Dock.
    • Maximize - Maximizes FL Studio to fit the current monitor.
    • Maximize for all monitors - Spreads FL Studio across all monitor screens.
    • Exit - Exit FL Studio.

Main Volume & Pitch Panels

For your convenience:

  • Main Volume - Main output volume from FL Studio. The main volume control provides quick level adjustments while listening to projects. However, when rendering projects, the main volume should be set at the default level (Right-Click and select 'reset' to restore to the default value). See the help section on Levels and Mixing to learn how to set mixing levels in FL Studio.

  • Main Pitch - Sets the main pitch of instruments & Audio Clips. NOTE: You must select 'Enable main pitch' on Channel Settings for this to work on a per-channel basis. When pitch-shifting Audio Clips, 'Stretch' mode is probably best. The control is snapped to 100 cent pitch units, to override snapping hold (Shift).

Global Snap Panel

The Snap Panel sets the global snap options.

Global Snap Selector - Selects the Snap value applied to the Piano roll, Playlist and Event Editor when the local Snap (found on each of these windows) is set to 'Main'. Right-Click the selector to select the default note length from the popup menu. Input quantizing - The settings on the Global snap determine MIDI input quantizing. That is notes played on a controller keyboard will snap to the value selected here during a MIDI recording. NOTE: The snap options (none), Line & Cell are not input quantized. The snap options are:

  • Line - Events snap to the nearest grid-line, notice that the grid changes resolution as the Piano roll, Playlist or Event Editor are Zoomed horizontally.
  • Cell - Events snap to the start of the grid-cell they fall in.
  • (none) - No snapping. Movement is limited only by the Project Timebase (PPQ) setting (F11). NOTE: Snapping can be temporarily disabled by holding the Alt key when dragging events.
  • Steps 1/6 to 1 (step) - Absolute grid values equal to the nominated fraction of a step.
  • Beats 1/6 to 1 (beat) - Absolute beats values equal to the nominated fraction of a beat.
  • Bar - 1 bar.

Converting from Steps/Beats to note values:

Snap SettingNotation
1/4 Step 64th notes
1/2 Step 32nd notes
1/4 Beat 16th notes
1/3 Beat Triplets
1/2 Beat 8th notes
1 Beat Quarter notes
Bar Whole note

Add Panel

See ADD menu.

Multi-link controllers Panel

  • Multi-link controllers (Ctrl+J) - This allows you to link multiple interface controls to MIDI hardware or internal controllers: 1. Select the Multilink-controllers icon to start the multi-link process. 2. Tweak some software controls. 3. Tweak the same number of hardware knobs/sliders/buttons on your controller and they will link in the same order the software controls were tweaked. Controller movements can then be recorded.
    • Permanent links - Multi-links can be permanently remembered by FL Studio using the 'Override generic links' option (see below).
    • Browser linking - When 'Multilink' is checked, selecting plugin parameters in the Current project browser adds them to the multilink.
    • The Right-Click menu provides the following multi-target options:
      • Edit events - Opens an Event Editor for each interface control tweaked. Turn on the switch, tweak controls then select this option.
      • Init song with these positions - When play is pressed each tweaked control will adopt the value it was set to. Turn on the switch, tweak controls, then select this option.
      • Create automation clips - Creates Automation Clips for each tweaked controller. Turn on the switch, tweak controls, then select this option.
      • Link to controllers - Starts the linking process.
      • Override generic links - Creates permanent global links between your controller, FL Studio and plugins. Established links will become active only when the window or plugin hosting the software control is focused (click anywhere on the window / plugin to focus the interface).

        NOTES:

        • Formulas & smoothing: Generic links do not support mapping formulas & smoothing.
        • Temporary links have higher priority and will replace the generic links for the current session/project.
        • Controller type: Links made with the multilink function will only work as expected from a controller of the same type. Selecting a new controller may result in unexpected links between the controller, FL Studio & plugins.
        • MIDI channels: Up to 16 separate MIDI controllers can be used simultaneously. To link multiple controllers select unique MIDI channels for each controller prior to initiating the multilink process (don't forget to enable each controller in the MIDI settings). The multilink process remembers both the MIDI CC and MIDI channel of the link.
      • Randomize - Randomizes the values of any tweaked controls. Turn on the switch, tweak controls, then select this option.
      • Humanize - Adds a small random variation to any tweaked controls. Turn on the switch, tweak controls, then select this option.
      • Cancel - Stop the linking process and forget all links.
  • Last tweaked - Right-Click to lock open. This is a large pop-up control showing the last-tweaked parameter. You can add a button to open this control from the Toolbar Shortcuts, designed primarily for touch. Use the 'Control options' menu, as noted above, to choose:
    • Knob
    • Horizontal fader
    • Vertical fader

Time Panel

The Time panel displays the song time in bars or real-time.

Options

  • Mode
    • Bar : Beat/Step : Tick - Time is displayed in Bar format. NOTE: The number of beats-per-bar, steps per beat and PPQ (tick length) is set in the Song Settings.
      • Step/Beat switch (S/B) - Choose what the center digits display. This option applies to bar display mode only.
    • Minute : Second : Centisecond - Time format. Note: Centiseconds are 1/100th of a second.

Pattern Panel

Manage Patterns. Note that the functions of the Pattern Panel are conveniently replicated in the Picker Panel, attached to the Playlist.

Controls

  • Pattern options select from:
    • Find first empty (Shift + F4) - Find the first unused pattern the list.
    • Find next empty (F4) - Find the next unused pattern the list. The (F4) is a good workflow habit when making new patterns.
    • Rename / recolor (F2) - Opens the Pattern naming window. Press (F2) again to cycle Pattern colors. The selector can be opened by clicking the square on the end of the rename window. NOTE To Gradient Color Channels make a selection by left-clicking and dragging down on the Channel Selectors (8) and select from the Channel Menu Channels > Color selected > Gradient
    • Open in project browser (Shift+Ctrl+P) - Open in Project Browser. Opens the Browser Project Folder to show the current pattern.
    • Insert one (Shift+Ctrl+Ins) - Inserts a new empty Pattern before the selected pattern.
    • Clone (Alt+C) - Makes a copy of the selected pattern after it.
    • Delete (Del) - Deletes the selected pattern.
    • Move up (Shift+Ctrl+Up arrow) - Moves the selected pattern up one number in the Pattern selector list.
    • Move down (Shift+Ctrl+Down) - Moves the selected pattern down one number in the Pattern selector list.
    • Split by channel - Creates a new pattern for each active Channel in the selected pattern. Patterns will be named according to the split Channel. To undo a split by channel - 1. Stack the Pattern Clips in an empty area of the Playlist making sure they are correctly aligned. 2. Select all patterns in the stack. 3. Use the 'Playlist Menu > Edit > Merge selected clips' 4. Delete the merged clip from the Playlist.
    • Quick render as audio clip - Renders the selected Pattern/s to an Audio Clip (.WAV only) using the current Render Settings. Pay attention to the Miscellaneous section > Insert and Master FX options, depending on how you plan to use the Audio Clip. Song start, or selection, is used to set the automation values that will be fixed for the duration of the Pattern/s (see Bouncing Patterns to Audio for more details). If you want to bounce a Pattern Clip to audio, with in-situ Automation, use inline Playlist bouncing.
    • Render as audio clip - Renders the selected Pattern/s to an Audio Clip (.WAV only) allowing you to set Render Settings. Pay attention to the Miscellaneous section > Insert and Master FX options, depending on how you plan to use the Audio Clip. Song start, or selection, is used to set the automation values that will be fixed for the duration of the Pattern/s (see Bouncing Patterns to Audio for more details). If you want to bounce a Pattern Clip to audio, with in-situ Automation, use inline Playlist bouncing.
  • Pattern name - Left-click to open the Playlist with the pattern selected for editing. Right-Click to show all pattern in the project for choosing.
  • Pattern selector (+ /for next pattern/; - /for previous pattern/) - Shows/sets the current pattern. Right-Click to show a pop-up menu of all patterns in the project. A maximum of 999 individual patterns can be created.

Output Panel

The Output monitoring panel contains controls for monitoring the audio output of FL Studio.

NOTE: For more visualization options see Wave Candy.

Options

Right-Click the Oscilloscope area to set the following options:

  • Oscilloscope - Shows the waveform output from FL Studio.
    • Stereo - Stereo or Single line display.
    • Long - Stationary or scrolling oscilloscope.
  • Spectrograph - Shows the frequency spectrum output from FL Studio. Low frequencies left, high frequencies to the right. NOTE: The output is scaled so that Pink noise produces a flat spectrum. Pink noise has equal power for each octave. Mixing to this principle is considered to create a 'balanced' mix.
  • Peak Meter - Monitors the final output of FL Studio (place your mouse over the peak meter to read the values in the Hint Bar). If the bars turn red your project is clipping, not good. To learn more about clipping and setting levels in FL Studio see the section on Levels and Mixing.

CPU & Memory Panel

The CPU & Memory Panel displays the CPU, polyphony & memory usage for the project. See the CPU Panel videos here.

Controls

  • CPU Meter - When this meter nears 100%, FL Studio's audio output will glitch or crackle, this is known as an underrun. The meter shows the percentage of time required to fill each audio buffer, compared to the buffers length. For example, 20% means FL Studio required only 20% of the buffers total duration to fill it with audio. 90% means FL Studio required 90% of the buffers duration to fill it with audio. Close to running out of time. Once FL Studio needs the same, or more time than is available, there will be gaps in the audio (glitches, stuttering etc). For tips on reducing CPU usage see the Optimization section. To learn why the FL Studio CPU meter is not the same as the Operating System CPU meter see the section below on Multi-core CPU Processing.

    Right-Click to access the following options:

    • Refresh - Slow, Medium or Fast update rate for the information displayed.
    • View voice count - Show Voice count in place of FPS.
    • View FPS (Frames Per Second) - Show FL Studio user interface screen refresh rate in place of 'Voice count'.
    • Misc - 'Handles', 'Threads' and 'Fonts'. Techsupport may ask to see this when troubleshooting. You don't cause trouble do you?
  • Memory Meter - The options for this meter depend on which version of FL Studio you are using. NOTE: See the section 'RAM vs Address Space' below, it's important stuff! Memory address space is not RAM.
  • CPU Graph - Shows the CPU usage as a running graph, so that you can track changes and observe spikes. Right-Click to change the update speed. NOTE: See the section 'multi-core CPUs' below.
  • Polyphony - Shows number of voices (independent sounds) being mixed at the same time. The Miscellaneous Channel Settings have some per-channel controls to set maximum polyphony.

RAM vs Memory Address Space

The values shown in the CPU panel are not your RAM, they are memory address space. The amount of physical RAM your PC has does not restrict how much memory programs can use. Adding more RAM to your PC does not give FL Studio more memory to work with. Each program is allocated working memory address space by the operating system, where data can be stored. 32 Bit programs max out at 4 GB per program. 64 Bit programs can access up to 8 TB per program. If there are 4 programs running, there could be 32 TB of memory allocated between them. As noted, the amount of RAM your PC has nothing to do with this number. But there is a catch:

Why we need RAM - If there is not enough RAM to hold the data in working memory data, the Operating System shares the available RAM among the active programs and makes up for any shortfall by putting the remaining data in a file, on your operating system disk/SSD drive as an extension to RAM. The more physical RAM you have, the more likely it is FL Studio will always win the RAM allocation 'lottery' and have all working data stored in RAM. As physical RAM is much faster than the hard-drive, FL Studio will be less likely to experience buffer underruns as audio data is read (slowly) off the SSD/disk. See a video on this topic here.

Why show 'available' memory for FL Studio 32 Bit and not FL Studio 64 Bit - As 32 Bit programs have access to 4 GB of memory, it's quite possible you will exceed that amount. In this case, available memory would drop to 0. If this happens FL Studio will probably crash or start behaving unpredictably, so it matters. FL Studio 64 Bit has access to 8000 GB. You will never use that much memory. It's not useful to know that you have 7936 GB available. So we show how much memory is used, so you can compare that to how much RAM you have. For the reasons discussed above, it'd best to see a memory figure less than your total RAM.

CPU Meters & Multi-core CPU Processing

If you open the Windows Task Manager or macOS Activity Monitor, and examine the number of cores used and their relative percentages, you may wonder why you sometimes experience audio glitches when the CPU is nowhere near 100%. Let's look at the FL Studio CPU meter vs the Operating System CPU meter in some more detail by considering Metrics, time and logic:

  1. Different metrics - The FL Studio CPU meter measures how quickly each audio-buffer is filled (Time taken to fill the buffer / Buffer length). A 50% reading means the audio for the buffer was calculated in 1/2 the time available. On the other hand, the Operating System CPU meter measures overall CPU and core 'utilization'. Utilization is the portion of processing-slots on the CPU in use (Processing-slots filled / Processing-slots available). A 50% reading means half the processing units were in use. So, utilization more about how close to maximum capacity the CPU is, not how quickly it is processing a given task, such as the FL Studio audio processing. Put simply, FL Studio's meter measures time (processing speed), the Operating System measures space (processing slots filled). So, the two measures are not the same, even if they are both reported in percent! But wait, there's more: time and logic.
  2. Time-scales - The FL Studio CPU meter is relative to the audio buffer size ~ 10 ms. The operating system CPU utilization meter works on a fixed ~ 1000 ms interval. The difference in time-scales around 100x. While the operating system CPU meter may show 30% utilization, over the last 1000 ms, there may have been multiple occasions during that period where real-time audio processing experienced interruptions. Why? If real-time audio 'Mixer streams', have to wait on other streams to finish, because they can't be multi-threaded (processed at the same time), FL Studio may experience audio underruns, or at least very high FL Studio CPU meter readings. At the same time, Operating System may report low overall and or individual CPU utilization. The CPU had lots of free slots, it's just the ones that were in use, were not able to keep up with realtime output. It's common for audio processing, that the CPU must wait for program and system related tasks to complete before it can continue, and so, may struggle to keep up with realtime audio output. Generating ~ 44100 samples per second, on an ongoing basis, without an interruption of a single sample, 0.02 ms. Just why the CPU must 'wait' is all to do with logic:
  3. The logic of audio processing - There is a long list of tasks that must be processed in sequence, and this means logically can't be processed in parallel (multithreaded). For example: Plugins must wait for instructions from the Piano roll and Playlist before they make sound. Effects must wait for the audio from upstream instruments and FX before they can process it. Further, it's not possible to parallel-process (multithread) instruments and FX that are on the same Mixer channel (where their audio is mixed together), or even in the same Mixer routing pipe-line (when one Mixer track is linked to another and another). Even FX processing has an order from top to bottom in the FX stack). Then, the Master Mixer track must wait for every instrument > Mixer track > effect to be processed before it can process the audio through the Master effects. So logically, there is a lot of waiting that's a natural and unavoidable fact of audio processing. Think of a production line. This means the CPU may not be particularly busy, using all its cores and processing slots, yet it runs out of time to fill that tiny 5 ms audio-buffer because there was a lot of waiting for things that needed to be processed in sequence. It should be clear that fast processing is very important and this is not the same thing as multi-core processing. The best CPU is one that has enough cores to spread the work around AND can do the most work on a single core during each buffer time-slice. Which leads to our TIP: When comparing CPUs, look for the fastest single-core performance scores in a package with at least 4 physical cores. Most CPU benchmarks list single core performance. For example, the CPU Benchmark website lists the single core scores.

So what can you do to minimize 'CPU waiting' and improve multi-core performance?

  1. First, make sure you are updated to the latest version of FL Studio. From FL Studio 20.0.4 we made significant improvements to CPU usage, particularly where sub-mixes are used. This is a breakthrough improvement, don't ignore it!
  2. Make sure that your highest CPU using plugins are routed to independent Mixer Tracks without shared 'Send' Channels. Each Mixer Track represents an 'opportunity' to create these independent, parallel, processing paths. In summary, here is how multi-threading works:
    • Generators will be processed in multiple threads (if 'Allow threaded processing' is activated and the plugins allow it).
    • Any Mixer tracks that don't depend on one another for audio input, can be processed at the same time, i.e. in multiple threads (if 'Allow threaded processing' is activated).
    • Mixer tracks that depend on the output of other mixer tracks will be processed after those other mixer tracks and probably on the same core.

Testing - If you are testing and comparing CPU loads it is the number of plugins and/or effects that can be processed without buffer underruns. Don't obsess about how cores are used, particularly at low CPU levels, since the Scheduler will try to reduce power consumption by parking (switching off) cores at low CPU load, then turn cores on and even out this distribution as CPU load approaches 100%. See some more information here.

See the tutorial video here.

FL Studio 64 Bit Memory Management

To use the 64 Bit version of FL Studio, run the ..\FL Studio\FL64.exe executable file. We recommend using the 64 Bit version of FL Studio if you have made the switch to a 64 Bit VST library and or you have projects using more than 4 GB.

  • Memory - You can use up to 512 GB depending on your version of 64 Bit Windows without any bridging or other work-arounds as used in the 32 Bit version of FL Studio (shown in the section above).
  • Audio file size - This release will not allow you to record or load a single audio file (nor will Edison) that exceeds 2 GB.
  • 32 Bit bridge - FL Studio 64 Bit will automatically 'bridge' 32 Bit plugins. Bridging loads the 32 Bit plugin in a special 'wrapper' that translates between the 32 Bit and 64 Bit memory standard of the plugin and host (FL Studio).

    NOTE: - Ideally you should restrict use of 32 Bit plugins to FL Studio 32 Bit and 64 Bit plugins to FL Studio 64 Bit. In practice we know this isn't always possible, but keep in mind that bridging adds a small CPU load and the bridge can be another point of failure where a plugin can crash. If you have trouble with a 32 Bit bridged plugin, please report it to Tech Support and try to use the 64 Bit version if one is available.

NOTE: You must be using Windows 64 Bit to run FL64.exe. The 64 Bit executable is installed to '..\Program Files (x86)\Image-Line\FL Studio\FL64.exe' rather than '..\Program Files\Image-Line\FL Studio\FL64.exe' as is usually the case for 64 Bit programs.

FL Studio 32 Bit Memory Management

If you are using the 32 Bit version of FL Studio, the options below will allow you to use more than 4 GB of memory, according to your Windows version:

1. Remove samples & instruments from FL Studios memory allocation

'Keep on disk' and 'Bridged mode' will significantly lower the memory required by FL Studio. Together they will allow you to run projects to the limits of your PC's capability and operating system (32 or 64 Bit).

  • Keep on disk - Open large Audio Clips and/or Sampler Channels and select 'Keep on disk' located on the 'SMP' tab. To automatically 'Keep on disk' select 'Auto keep long audio on disk' on the F10 General Options, save then re-load your project. NOTE: The sample data must be 16 or 32 Bit format for the 'Keep on disk' option to be available. When selected the maximum memory available to each Audio Clip / Sampler Channel will be 2 GB.
  • Bridged mode for VSTs - Open the Wrapper PROCESSING tab and select the 'Bridged' option. Bridging moves the plugin, along with its memory requirements, to a separate process from FL Studio. The maximum memory available to the plugin will be at least 2 GB for 32 Bit Windows and up to 8 TB depending on your version of 64 Bit Windows. This mode is most beneficial for samplers and/or ROMpler plugins that consume large amounts of memory loading their sample-banks.

    NOTE: Ideally you should restrict use of 32 Bit plugins to FL Studio 32 Bit and 64 Bit plugins to FL Studio 64 Bit. In practice we know this isn't always possible, but keep in mind that bridging adds a small CPU load and the bridge can be another point of failure where a plugin can crash. If you have trouble with a 64 Bit bridged plugin, please report it to Tech Support and use the 32 Bit version if one is available.

2. Increase FL Studios working memory allocation (a Windows setting)

Increasing FL Studio working memory allocation - There is an 'FL.exe' file in the FL Studio installation directory. Using this to start FL Studio after making the following changes to your Windows operating system will give FL Studio access to 3 GB or 4 GB (up from 2 GB) depending on your OS:

  • Windows 10, 8, 7 & Vista - 64 Bit: FL Studio will automatically have access to 4 GB of RAM when the '..\Program Files (x86)\Image-Line\FL Studio\FL.exe' is used to start FL Studio.
      • 1. Make a Windows Desktop shortcut to the extended memory FL Studio executable '..\Program Files (x86)\Image-Line\FL Studio\FL.exe' and use that to start FL Studio in future.
  • Windows 10, 8, 7 & Vista - 32 Bit - Use the 3 GB switch to access 3 GB of RAM.
    • Enable the 3 GB switch:
      • 1. From Windows Start browse to Programs > Accessories and Right-Click the Command Prompt file. Click 'Run as Administrator'.
      • 2. In the Command prompt window, type bcdedit /set IncreaseUserVa 3072 and press enter on your keyboard. Allow the change to be made when security windows appear.
      • 3. Restart the computer.
      • 4. Make a Windows Desktop shortcut to the extended memory FL Studio executable '..\Program Files\Image-Line\FL Studio\FL.exe' and use that to start FL Studio in future.
    • Disable the 3 GB switch:
      • 1. From Windows Start browse to Programs > Accessories and Right-Click the Command Prompt file. Click 'Run as Administrator'.
      • 2. In the Command prompt window, enter bcdedit /deletevalue IncreaseUserVa and press enter on your keyboard. Allow the change to be made when security windows appear.
      • 3. Restart the computer.
      • 4. Remember to use the original FL Studio executable '..\Program Files\Image-Line\FL Studio\FL.exe' in future.
  • Windows XP 32 Bit - Use the 3 GB switch in XP to access 3 GB of RAM.

NOTE: From FL Studio 11 onward the 'FL (extended memory).exe' has been renamed 'FL.exe' and is the default executable after installation.

3. Use the FL Studio 64 Bit version

Open the ..\FL Studio\FL64.exe executable file and load your project. The 64 Bit version of FL Studio has no memory limitations, apart from those that apply to 64 Bit Windows. 32 Bit plugins will be automatically bridged to 64 Bit, although we recommend using 64 Bit versions of plugins in the 64 Bit version of FL Studio, where possible. NOTE: If you are using Windows 32 Bit then FL Studio 64 Bit won't run on your computer.

Online Panel

Controls

The Online panel has two functions:
  • Online news-feed - The panel will display news and announcements from Image-Line but will not activate until it is clicked for the first time. Windows / macOS may warn you that a program is trying to access the internet. This is normal as the News Panel works by displaying an Image-Line managed RSS (internet) feed inside FL Studio. Keep an eye on the News Panel for updates and new content. The News Panel will not communicate with the RSS feed when the panel is hidden or disabled (see below). Of course, you need an active internet connection to use this function.
    • To open the panel - Left-click the panel menu to display the drop-down menu of news and announcements from Image-Line. The newest item is displayed at the top of the list and is visible in the panel when the menu is closed.
    • To select an item - Left-click it.
    • To activate/deactivate the panel - click the 'Enable online news' option at the bottom of the list.
  • Content Library - Open the Content Library by clicking the icon as shown above. For more information see the dedicated Content Library help.

Toolbar Shortcut Icons

Each icon below can be added or removed as suits your workflow and space.

NOTE: Dragging content over the main window buttons (Playlist, Channel Rack, Piano roll) will bring these windows to the front if they are not already visible.

Options

Right-Click panels to select options. NOTE: Some buttons also have Right-Click alternative actions these are indicated after the /.

Add menu - Opens the Add Menu to add Channels, Effects etc.

Alt key (Alt) - Alt key function. Useful for touch.

Arrange - Opens the View > Layout > Arrange windows options.

Auto Scroll - Auto-advances the Event Editor, Piano roll, Playlist and Step Sequencer when the play position marker nears the edge of the window. The Auto Scroll switch is linked to the (Scroll Lock) key on your keyboard and will reset to the 'on' condition each time FL Studio starts (unless the keyboard Scroll Lock is on).
  • Continuous scrolling (Right-Click) - The window continuously scrolls, click on the Editor background to reposition the Playhead/scroll center for the window.

Control key (Ctrl) - Ctrl key function. Useful for touch.

Cut (Ctrl+X) - Activates the cut function for the selected editor window, Piano roll or Playlist.

Grouping Notes & Clips - Enables / Disables Piano roll note and Playlist pattern grouping. TIP: Disable this Global option to make changes to members of Clip or Note Groups, then re-enable it to return the edited member to the original Group. Use the Piano roll & Playlist 'Group' options to group/ungroup selected notes/patterns.

Help (F1) - Opens the Help (you are reading it right now). Right-Click to see FL Studio's 'About panel'.

Last Tweaked control - Opens a large control designed for use with touch. This will be automatically linked to the last tweaked (moved) UI control.

Open Audio Editor - Left-click to open the Edison audio editor, Right-Click to open a new instance of Edison. Dragging and dropping an audio file (from the Browser onto this button will open the file in a new instance of Edison.

Open Plugin picker (F8)/ Project picker (Ctrl+F8) - Open the Plugin Picker. Right-Click to open the Project Picker.

Open Project picker (Ctrl+F8) / Plugin Picker (F8) - Project picker explained. Right-Click to open the Plugin Picker.

Paste (Ctrl+V)/ Duplicate (Ctrl+B) - Activates the Paste or Right-Click Duplicate function for the selected editor window, Piano roll or Playlist.

Metronome ( Ctrl+M) - When selected, a short 'metronome' sound will play at the beginning of each beat, accented at the beginning of each bar. This feature is especially useful when you need to keep performers 'synced' with the song tempo.
  • Change metronome sound - Right-Click the switch and select from the menu.
  • Customize metronome - Replace [FL Studio install folder]\FL Studio\Data\System\Metronome.wav, Metronome2.wav and/or Metronome3.wav with your own samples. If you do, make sure to back up the originals since you are likely to suck at making good metronome sounds, unlike us of course. NOTE: This folder is normally hidden, so you will need to display hidden folders to access it.
  • Set Metronome Mixer channel - The metronome is routed to the 'Preview mixer track', set in the Audio Settings. The default preview mixer track is the Master (--). Re-routing the Metronome sound can be useful to adjust the metronome volume or send a separate click-track to performers via a Mixer track external mixer output (requires ASIO).

Recording Blend (overdub) (Ctrl+B) - Recorded notes will blend with existing notes, otherwise recorded notes will overwrite the old ones. For audio recording, in the Playlist, 'Blend recording' works in conjunction with 'Loop record' below. In this case sound-on-sound style recording is possible, with each previous recording playing live as the project loops. When deselected, previous recordings will be muted on each loop.

Recording Count-in (Ctrl+P) - The metronome will ticks before the start of a recording session. Right-Click to select the number of bars to countdown.

Recording Loop - Enable this option to loop-record a Pattern, Piano roll (or Piano roll time selection), Playlist (or Playlist time selection) indefinitely until the stop button is clicked. Overdub MIDI/Note or Audio data on each loop. For detailed instructions on audio overdubs see Loop Recording

Recording One-click - Opens the external audio recording 'wizard' to help you record audio from your audio device inputs. NOTE: Don't record through the Master Mixer track otherwise all project audio is mixed with your external audio input.

Render as Audio File (Ctrl+R) - Opens the render options for saving the project to an audio file (WAV or MP3). Right-Click - Render to MP3

Save As (Ctrl+Shift+S) - Shortcut for the Save As command in File menu. Flashing? The button flashes as a 'save reminder' after 5 minutes, then at 10 min and every 30 sec after 10 min, be afraid, very afraid!...or just save more often. Using the keyboard shortcut (Ctrl+N) will save a 'new' version of your project, even better.

Shift key (Shift) - Shift key function. Useful for touch.

Step Editing (Ctrl+E) - Switches step entry allows you to step-wise enter notes into the Piano roll. See the link for details.

Typing keyboard to Piano keyboard (Ctrl+T) - When selected, your typing keyboard will function as a musical (MIDI) keyboard. Right-Click options:
  • Octave - Base octave for mapping the keyboard keys. NOTE: If you are using multi-sample based instruments make sure the Channel Settings option 'Add to key' is selected.
  • Standard keyboard layouts - Piano or others such as Janko. The first image below shows the standard 'Piano' layout. If you have a Razer Chroma keyboard use the Razer Chroma FX plugin (Typing Piano mode) to illuminate the Piano keys.

    This is the Performance Mode layout used to trigger Clips, tracks refer to Playlist tracks.

  • Special key maps - Other settings such as 'Blues', 'Major...', 'Minor...' etc. set the Typing keyboard to play in the given Key and/or Chords. 'FPC (C4)' and 'Slicex (C4)' are designed to work with the respective plugins.

Key changes - Use the Channel Settings > Misc > Root note options. If you are using samples you may also want to use the Add to key option.

Undo (Ctrl+Z)/ History - Undo the last command. Right-Click the button to open the History in the Browser.

View Browser (Alt+F8) / Plugin picker (F8) - Shows/hides the Browser window. Right-Click to open the Plugin Picker.

View Channel Rack / Step Sequencer (F6) - Shows/hides the Channel Rack / Step Sequencer window.

View Mixer (F9) - Shows/hides the Mixer window.

View Piano roll (F7) - Shows/hides the Piano roll window. Right-Click to maximize Piano roll.

View Playlist (F5) - Shows/hides the Playlist window. Right-Click to maximize Playlist.

View Project Info (F11) - Open the Project Info, where you can enter details about the name, author, etc.

View Tap Tempo - Open the Tempo Tapper.

View Touch Controllers (Alt+F7) - Open the Touch Keyboard / Pads.

Wait for Input (Ctrl+I) - When selected, pressing the play button will set FL Studio in waiting mode. Playing/recording begins at the moment input data is received (e.g. when a key is pressed on a MIDI keyboard). Right-Click the LED to select whether you want this option active when playing or recording only.