INSTRUMENTS / GENERATORS

DirectWave Sampler

Player version: DirectWave installs as a 'player' version, free for all users. DirectWave (player) channels will be saved along with the projects as normal. The DirectWave Player limitations are: Only DirectWave's own formats (*.dwp & *.dwb) can be loaded, VST sampling is disabled, external samples can not be added to patches nor can new patches be created.

To unlock the extra functions including: Editing patches, adding samples, recording, sampling VST instruments, loading 3rd party formats then DirectWave full version needs to be purchased separately.

NOTE: For near audio-rate modulations, select High Quality Rendering on the Options tab.


DirectWave is a powerful and versatile sampler featuring a fully programmable synthesis section and features such as inbuilt FX, velocity & randomization layering, looping, automatic sampling of VSTi plugins and the ability to 'sample' (record sound) when loaded into the mixer audio chain, in an effects slot.

Visit the DirectWave Image-Line forum for more patches and programming tips.

Overview

The programming functions are divided into an upper and lower interface as follows:

  • Upper interface - The upper part contains the Program Window that allows samples to be spread across the keyboard and layered according velocity. The Library Window shows the programs that are available from your DirectWave library.
  • Lower interface - Each sample layer can be programmed using the Sample (sample start/end points, looping, etc.), Zone (pitch, filtering, ADSR, synthesis, etc.) and Program (FX, portamento, etc.) tabs. For more detail see the sections above.

Download Samples

Use the 'Online Content' button to access the Content Library to download soundbanks directly from the Image-Line DirectWave Content Page. There are free selections for most products, to test.

Loading Programs and Samples

Disk Operations Menu

The Disk operations menu on the top left of the interface has the following options:

  • Open program/bank - DirectWave can hold up to 16 Program Channels. Each Channel can consist of any number of samples assigned across the keyboard. A collection of Programs is known as a Bank.
  • Create program from samples - You can load samples and create a program. A program is the set of samples that makes up a single Program Channel.
    • Pitch analysis after sample load - Analyses pitch of loaded samples. Useful when creating banks from scratch.
    • Auto normalize samples - Maximizes the volume of samples so that the maximum peak hits 100% volume.
    • Extract root key from filename - Sets the sample root key from the end of the file name, e.g. 'Strings_C4.wav' or 'Strings - C4.wav' (note the spaces either side of the dash) will set the Root Key to C4. So, C4_Strings.wav and Strings-C4.wav won't work.

      There are additional functions available when used in conjunction with the Open > Create program from samples option. Use the file name/s with on an _ (underscore) or - separating the last characters. Everything after the _ or - will be interpreted according to these rules:

      • Multiple Commands - You can use multiple sample program settings using the +character to separate commands.
      • Root notes - A through G is a root key: C#5, D2, ...
      • Key range - K, it's a key range, min and max separated by a " - ". Example: 'KC3-B3' for the entire octave 3.
      • Velocity range - V, it's a velocity range (between 0 and 127). Example: 'V64-127'
      • Trigger group - T, it's a trigger group. There are four subtypes: TG = group index (0..99), TY = type (0, 1, 2 or 3 for normal, cycle, random and avoid previous respectively), TF = frequency (0..100 for the percentage), TO = overlap (0..100 for the percentage)

      For example: samplename_C4+KA3-F#4+V64-95+TG1+TY3+TF100+TO15.wav sets root key = C4, key range = A3 to F#4, velocity range = 64 to 95, trigger group = #1, trigger type = avoid previous, trigger frequency = 100%, trigger overlap = 15%.

  • Program - Each Program Channel can consist of any number of samples assigned across the keyboard. This format contains a single instrument channel. NOTE: Wave data is not stored in the .dwp, it is usually located in a sub-folder where the .dwp is located and with the same name as the .dwp.
    • Save - Save to .dwp (DirectWave Preset) format.
    • Save as - Save to .dwp format with renaming.
    • Save as variation - Save currently selected program to another name without a new set of samples (just a new .dwp).
    • Save for FL Studio Mobile... - Save to .dwp (Monolithic mode) format. You can also use the normal save-to .dwp. Both are compatible with FL Studio Mobile's DirectWave sampler.
  • Bank - The collection of (up to 16) Program Channels is known as a Bank. This allows Banks to contain up to 16 separate instruments. NOTE: When Monolithic mode is enabled, samples will be stored in the .dwb file. Otherwise samples are located in folders where the .dwb is located.
    • Save - Save to .dwb (DirectWave Bank) format.
    • Save as - Save to .dwb format with renaming.
  • Program - Programs are the synthesis settings that control how a the Program > Samples will play.
    • Flush - Flushes the currently selected program.
    • Flush all - Flushes all programs. Start from a blank slate.

Working with content

  • To load programs - Use the Load folder icon to the right of the main DirectWave logo. OR Use the Library browser on the Program Window. NOTE: The default directory for browsing programs is set by the Content Library setting in the Options window. Alternatively drag .dwp program files from the Browser to DirectWave.
  • To load samples - Either drag compatible files from the FL Studio Browser to the Zone Window or double click on a sample in the DW Browser, if the DW Browser is not visible it can be opened using the 'Show/Hide Browser' control noted in the image above.
  • Note on importing SoundFonts: If the SoundFont has more than one program bank a dialog will appear enabling you to load one or more program banks into DirectWave. Use Windows file selections - Left-click, Shift+Left-click and Ctrl+Left-click to select one, groups or selected banks respectively. After loading, SoundFont banks will be available as standard DirectWave banks. Limitations: Only basic SoundFont parameters such as key/velocity range, loop points, etc. are imported, filter cutoff, chorus, reverb, are not. This may result in SoundFont presets that vary ignored parameters to sound the same.

Sample format support

DirectWave currently supports the following formats:

  • Samples
    • WAV (all types)
    • ACM decoder support (ogg).
  • Programs

    To open the importer Right-click on the Open icon to the left of the 'Select Preset' control (along the top of the interface) or Right-click on the Program Window.

    • AKAI AKP (S5/6K,Z4,Z8)
    • Battery (Version 1, 2 & 3 banks)
    • DWP (DirectWave Program, native format)
    • EXS24
    • Giga
    • Kontakt / Kontakt 2
    • Kurzweil (off DOS disk)
    • MPC (off DOS disk, not 1000/2500/500 series)
    • Reason NN-XT (any association with a Refill can't be loaded)
    • Recycle
    • SoundFont2
    • SFZ

WARNING: DirectWave will not import the above formats if they have been encrypted/protected. Encryption is sometimes used by vendors to prevent non-native import of program files (they want you to buy their sampler) so check with the vendor they are not encrypted/locked to a given sampler if you are planning to purchase any of these formats for use with DirectWave.

Program Window

The Program Window allows you to assign samples over the keyboard for pitch (horizontal) and velocity (vertical) 'Zones'. A simple way to load samples is to drag them from a Browser and drop them on the Zone Window. This will create a new Zone for the sample. To assign Key and Velocity ranges drag the Zone Control Points, as noted below.

NOTE: To expand this window for easier editing

Diagram

  1. Sample List - Contains the samples loaded in the current patch. Click on a row to activate its controls. Drag samples from the FL Browser and drop here to build a patch.
  2. Zone Mapper - Allows the user to map samples in both pitch and velocity space. NOTE: To set the loop type for multiple Zones, select the zones for which you want to change the loop type, then change it.
  3. Sample List Scrollbar - Appears when more samples are in use than can fit in the Sample List window.
  4. Active Sample - Edited zones will be highlighted in blue.
  5. Zone Control Points - The upper and lower points allow you to define the velocity and pitch range by dragging the Zone Control Points in both pitch (horizontal) and velocity (vertical). Left-click, hold and drag to move a control point.
  6. Root Key - Shows the MIDI key at which the sample will play back without changing from its recorded pitch. Right-click on the keyboard to change the MIDI note.
  7. Vertical expand - Click to maximize the height of the Program Window. To extend the width, drag on the right-side of the DirectWave window.

Loading Samples

To load samples, either drag the sample from the FL Studio Browser onto the Zone Window or double click on a sample in the DW Browser. See also the Disk operations menu.

Parameters

1. Columns (upper section)

NOTE: You can drag and drop samples from the FL Studio Browser directly onto the Sample List.

  • Zone - This is a numerical label for the sample.
  • Zone Name - By default will show the name of the sample loaded based on the file name. To change Left-click in the cell.
  • Sample Size (S.SIZE) - The total number of samples in the recording.
  • Sample Rate (S.RATE)- Shows the sample rate of the file loaded. DirectWave can play back any sample rate.
  • Mute - Exclusive mute group. Triggering samples with mute group above 0 will release playing samples of that same mute group. I.e: closed and open hihat samples.
  • Root - The MIDI note number of the root key (that is the key the sample should play back at the sampled pitch/speed).
  • Transpose in Semitones (SEMI) - Transpose sample (+/- 36 semitones).
  • Fine tune (FINE) - Transpose sample (+/- 50 cents).
  • Keyboard Track (KTRK) - Determines how the playback pitch tracks the MIDI keyboard (+100 to -100 is possible). 100 = 100 cents per semitone, 0 = no pitch tracking.
  • Ticks - Length of the sample in ticks. 4 Ticks equals 1 musical beat. This parameter affects the way 'Sync' mode works.
  • Beat Sync (SY) - When activated (check mark), playing the sample at root key will adjust pitch to match the playback rate of the voice according host tempo.
  • Tick Slice (SL) - Plays a slice of the sample based on the note (relative to the root key of the sample).
  • Low Key (LKEY) - Lower MIDI note playback range.
  • High Key (HKEY) - Upper MIDI note playback range.
  • Low velocity (LVEL) - Lowest velocity at which the sample will be played.
  • High velocity (HVEL) - Highest velocity at which the sample will be played.
  • Lock (LK) - Locks the zone parameters.
  • Voice Count (V) - Displays the number of voices played based on that sample.

2. Zone Mapper (lower section)

Provides 'drag & drop' setting of the Zone key-ranges (horizontal) and velocity ranges (vertical).

  • Change playback range of the selected sample - Left-click the small squares at the upper left and lower right of the selected sample and drag the bounding box left and right respectively.
  • Change velocity range - Left-click the Upper left and lower right marker squares and drag the box up and down.
  • Shift box while leaving dimensions fixed - Left-click inside the selected sample region and drag the box up/down or left/right.
  • Change root key - Right-click the desired key on the preview keyboard below the zone mapper. The set root key shows orange.

Context Menu (Right-click anywhere inside the Zone window)

  • New Zone - Creates a new zone.
  • Delete Zone - Deletes the currently selected zone.
  • Delete all Zones - Deletes all zones - be careful with this one!
  • Duplicate Zone - Creates a copy of the currently selected zone.
  • Add Sample/s - Adds samples to those existing.
  • Replace Sample/s - Replaces samples with new ones.
  • Automap Zone/s - Automatically maps samples if the .wav files have embedded key-range and loop data.
  • Remap Zones/s as Drumkit - Remaps existing zones into consecutive semitones, useful to map drum kit samples across the keyboard, for example.
  • Lock all Zone/s - Prevents zones from further editing.
  • Unlock all Zone/s - Allows editing of previously locked zones.
  • Find pitch root - Pitch detection will estimate the pitch of the selected sample.

Library Window

The Library Window shows the DirectWave programs that are available from your library.

Controls

  • Library location (Home icon) - The path to the Library is set on the FOLDERS tab, to the right of the LIBRARY tab. Click the Home icon to set. DirectWave will then scan the set folder and all subfolders for DirectWave programs (.dwp).
  • Parent - Moves up a level in the folder structure.
  • Refresh (icon) - Refreshes the content in the folder to show any files since it was last scanned.
  • To load a program - Double Left-click from the list available. Once loaded, the active program can be changed by using the controls to next to the LIBRARY tab.

    Importer - To open the importer Right-click on the PROGRAM tab and select Open program. DirectWave will import the following formats -

    • AKAI AKP (S5/6K,Z4,Z8)
    • Battery
    • DWP (DirectWave Program, native format)
    • EXS24
    • Giga
    • Kontakt / Kontakt 2 / Battery 3
    • Kurzweil (off DOS disk)
    • MPC (off DOS disk, not 1000/2500/500 series)
    • Reason NN-XT (any association with a Refill can't be loaded)
    • Recycle
    • SoundFont2
    • SFZ

WARNING: DirectWave will not import the above formats if they have been encrypted/protected. Encryption is sometimes used by vendors to prevent non-native import of program files (they want you to buy their sampler) so check with the vendor they are not encrypted/locked to a given sampler if you are planning to purchase any of these formats for use with DirectWave.

Multi-Bank Window (Select 'Multitimbral mode' in Options)

The Multi-Bank Window allows you to load, up to, 16 separate programs as banks and control them from the 16 MIDI Note Colors or 16 MIDI Out Channels and/or route them to 16 separate Mixer Channels for separate FX processing.

NOTE: For OLDER projects made prior to FL Studio 11, deactivate 'Multitimbral Mode' in the Options.

Controls

Left-clicking on a line - Ch. 1 to 16 in the MULTI window (or the 1 to 16 buttons along the top of the plugin) will select the corresponding PROGRAM window, program number.

  • Load a program - 1. Open the MULTI window (click on the tab) and select the MIDI Channel (Ch) you want to load the DirectWave program in, by clicking on the corresponding line. 2. Open the LIBRARY tab and double-click a soundbank to be loaded. The bank will be loaded into the MIDI channel slot selected on the MULTI tab.
  • Sequencing & Live playing - Instruments will respond to notes on the same MIDI channel as their Multi tab channel (Ch.). In FL Studio you can use the note colors (show below) to play the different MIDI channels from a single Piano roll. Alternatively with the VST version you can use several Piano rolls feeding MIDI Out plugins set to the same Input Port number as DirectWave and the MIDI Channels of the intended instruments. You can also use MIDI Controller set to different MIDI Channels.

Parameters

  • Ch. - MIDI Channel. To change the MIDI channel for a sound bank you must load it into the desired MIDI channel slot.
  • Index - If you load more than one program into DW select them with the arrows at the top left on the PROGRAM window.
  • Name - Program name as labeled. You can double-click on the name field to edit it. This does not change the name of the loaded program, just the name displayed in DirectWave.
  • Output - Output offset number from DirectWave's own output channel. Double-click on the Output number and type in the desired offset. Use this to output sound banks to separate mixer channels for separate FX processing.
  • PB Rng - Pitch Bend Range (cents). To set, double-click the field and enter a new number.
  • Pitch Bend - Pitch Bend. Click the bar and drag horizontally to set.
  • Mod Wheel - Mod wheel. Click the bar and drag horizontally to set.
  • Volume - Volume. Click the bar and drag horizontally to set.
  • Panning - Panning. Click the bar and drag horizontally to set.
  • Expression - MIDI expression, acts as a multiplier to volume. Click the bar and drag vertically to set.
  • Mute - Solo / Mute switches. Useful to hear a particular instrument in multi-bank arrangements.

Sample Tab

The Sample Tab contains Sample Start, Looping options and Input/Recording controls.

Sample Window Mouse-Control

Apart from the horizontal and vertical zoom buttons, as shown in the image above, several actions are available through mouse movement, as described below.

  • Zoom - Left-click on the edge of the sample scroll/path bar (below the sample window) and drag left/right.
  • Scroll - Left-click the scroll/path bar and move left/right.
  • Select region - Left-click inside the sample window and drag to select the desired region.
  • Set Start / Loop Marker - Left-click on the marker tabs and drag the marker.
  • Right-click menu - Right-click on the sample window to open the sample editing functions.

Sample

  • Start - Moving the knob changes the sample start position (red marker). To gain finer control, zoom the waveform as described above.

Loop

Looping samples is the process of setting a region in the sample that will be repeated. Although termed Loop Start and Loop End DW allows you to move the End point in front of the Start (useful when automating points), so they are really just 'Loop point A and B'.

  • Loop Start - One end of the looped region (black marker). The loop start can be moved to become the loop end.
  • Loop End - The other end of the looped region (black marker). The loop end can be moved to become the loop start.
  • Loop Type - There are several looping schemes available.
    • Disabled - No looping. Loop start/end markers will not be visible.
    • Forward - The sample is repeated jumping back to the Loop Start once.
    • One Shot- The sample play from start to end regardless of note duration (useful for percussion samples).
    • Sustained - The looped region will play while a key is held. The region beyond the Loop End will play on key release. Remember that you need to increase the ADSR - Release value (Zone Tab) for this to work.
    • Bounce - The sample loops backward and forward.

NOTE: Looping instrument samples is an art. It is very easy to make loops that click, warble, pop or just sound plain awful (nothing is broken). Clicks are caused by the sample amplitude at the loop start and end points differing (try to select zero-crossing points and the same phases of the waveform, that is moving in the same direction). Another source of loop disasters are slow changes in timbre, phase or frequency content. Normally these happen slowly and naturally and add motion to the sound, however when a loop jumps back to a distant point, the abrupt change sounds like a glitch. In these cases the 'Bounce' loop can be a solution. In conclusion, there is a reason why professional sample libraries are expensive, someone (or team) had to sit down and craft hundreds/thousands of loops, often involving serious post-processing (layering, cross-fading, etc). If we haven't scared you off by now, experiment with the loop types and start/end positions and remember some sounds just don't loop smoothly...on second thoughts perhaps we should only allow trained professionals access to these controls?

TIP: Use 'Tune Loop' command from sample editor popup menu (Right-click on sample editor wave display, select 'Tools > Tune loop') to assist in finding good loop points. This jumps the loop-start/end markers between zero-crossings. Don't forget to zoom the wave-display if you need finer control.

Input / Sampling

To record you must load the DW VST version into a mixer channel Effects slot (DW VST version can be downloaded from www.imageline.com). DW VST only records sound from the mixer track and FX slot where it is loaded. This means any FX in slots preceding DW will be heard (and recorded) while those after it will be heard (but not recorded).

  • Monitor - Allows you to hear the mixer track that DW is loaded into. Unless this is selected you will not hear anything on the track.
  • 440 Hz - This is a 440 Hz test-tone (Note A4) to aid in tuning of melodic samples.
  • Record - When selected the mixer track (and FX slot position) DW is loaded into will be recorded into DirectWave. The recording will start when audio input is received.
NOTE: DirectWave can also auto-sample VST plugins, see the Options > VST Sampler tab.

Wave Viewer Editor Options / Context Menu (Right-click)

Click the Editor Options button or Right-click on the sample view window. If the selected command acts on sample data, only the selected region will be affected. To select sample data, Left-click and drag on the region you desire to process or edit.

  • File
    • Save sampleLoad sample - Save the current sample.
    • Save sample as (Ctrl+S) - Opens a file browser dialog in 'save' mode. The pop-up dialog has two options under the 'Save as type' field.
      • Microsoft wave file (*.wav) - Standard lossless .wav file at the bit-depth and sample rate set in the Sample Properties dialog.
      • Microsoft compressed wave file (*.wav) - Lossy compression formats. After initiating the save a second dialog opens to save the sample in one of many compressed formats. MS compressed wave files simply wrap the selected compression type in a *.wav file, and put information in the wave header as to what decompression method the opening program should use (not all programs read this information). FL Studio will load and decompress MS compressed wave files automatically as long as you have the appropriate codec installed.
      • WavPack (*.wv) - Lossless or lossy, depending on settings, open-source compression (see the WavPack website for more details). After initiating save in this format you will be prompted for a bit-depth (lossless is the default, other settings are lossy compression modes). In 'lossless' mode expect between 30-70% reduction in file sizes, useful for archiving purposes. FL Studio will load and decompress WavPack files automatically.
      • MPEG 3 audio file (*.mp3) - Mp3 is a Lossy compression format. It has gained world-wide popularity because it was one of the first on the market that provided good quality lossy compression. After initiating a save a second dialog opens to select the quality (bit-rate), this controls the tradeoff between audio quality and file size. Good listening quality on portable devices starts at about 160 kbps, use 224 kbps or 320 (max) if you want something probably indistinguishable from CD quality.
      • Ogg Vorbis (*.ogg) - Lossy, open source compression format, similar in concept to mp3 (see the Vorbis or Ogg Wikipedia website for more details). After initiating a save a second dialog opens to select the quality (bit-rate), this controls the tradeoff between audio quality and file size. Use a setting of 0.50 or more if you want good quality. FL Studio will load and decompress *.ogg files automatically.
      • FLAC audio file (*.flac) - FLAC (Free Lossless Audio Codec) is similar to WAV format in retaining all audio information in the encoded waveform. However, FLAC is useful as it also compresses (reduces) the file size significantly. Usually between 10 and 20% the size of the equivalent WAV file. This is not audio-level compression, it's file-size compression, similar to .zip etc.

      NOTE: Do not use any of the lossy formats (Microsoft compressed wave file, MPEG 3 or Ogg Vorbis) to archive project samples or loops. Use Microsoft wave files or WavPack in lossless compression mode if you want to save space. Hard disk space is cheap, samples may be irreplaceable.

    • Leave unedited audio data on disk - Where sample data has not been manipulated/edited, leave it on disk, rather than loading into memory.
  • Format - Sample properties. You can also press (F2) to open the Sample Properties dialog where you can set the file properties.
    • Precision
      • 16-Bit int - Sets the file to 16-Bit integer format. This is CD audio standard.
      • 32-Bit float - Sets the file to 32-Bit floating point format. This is the native format for FL Studio audio processing.
    • Channels
      • Mono - Sets the file to Mono.
      • Stereo - Sets the file to Stereo. Mono files will be saved with L and R channels containing the same data.
  • Edit - Many of the actions in this menu work on a selected region. To select a region, Left-click in the sample window and drag horizontally. To move the start point, Left-click near the start of the region and drag to a new point. To move the end point, Left-click near the end of the region and drag to a new point. At any time you can zoom the window using the mouse-wheel.

    • Undo select (Ctrl+Z) - The first item in this menu indicates the last action performed.
    • Undo history - Displays the last 10 actions.
    • Undo using mix (envelope) - Uses the All-Purpose envelope to guide the undo process. A number of options will be shown based on the actions recently made.
    • Undo using mix (spectral) - Uses the All-Purpose envelope to apply the EQ curve set in the EQ tool. Apply an EQ, tweak the all-purpose envelope, use the 'Undo mix envelope' option.
    • Disable undo for large samples - Turns off the undo feature for samples larger than 16 MB. This is useful for saving memory and CPU when working on very large samples.
    • Cut (Ctrl+X) - Cuts the selected region.
    • Copy (Ctrl+C) - Copies the selected region.
    • Paste insert (Ctrl+V) - Inserts the copied sample at the start of the selected region.
    • Paste replace (Alt+V) - Replaces the selected region with the copied sample. The duration of the copied sample determines how much of the region will be replaced.
    • Paste mix (Shift+V) - Mixes the copied sample with the selected region. The duration of the copied sample determines how much of the region will be mixed.
    • Paste mix (envelope) (Shift+Ctrl+V) - Uses the All-Purpose envelope to decide how the sample in the clipboard buffer is mixed with the sample in the editor. The envelope controls the mix level (0 to 100%). The duration of the copied sample determines how much of the region will be mixed.
    • Paste mix (spectral) (Ctrl+Alt+V) - Paste-mixes the sample from the clipboard into the edit window according to the EQ curve set in the EQ tool. Apply an EQ, use the 'Paste mix (spectral) option.
    • Paste stretch (Shift+Ctrl+T) - Pastes the copied sample via the Time Stretch / Pitch Shift Tool.
    • Paste replace (drum) (Shift+T) - Opens the Paste replace drum tool. This tool reconstructs the decay portions of drum beats that may have been cropped during the slicing process and replaces the selection to the original location.
    • Clear (Shift+Del) - Clears the selected region, leaving the rest of the sample unchanged. Consider this a mute function.
    • Delete (Del) - Deletes the selected region. This function will change the overall length of the sample.
    • Trim (Ctrl+Del) - Deletes the region outside the selection.
    • Delete part after loop (Alt+Del) - Deletes sample data after the loop end point.
    • Insert silence (Ins) - Inserts silence from the region start point of a length equal to the selected region.
    • Click-free (smooth) editing (C) - Switch, prevents audio clicks/pops in samples caused by edit functions. This option avoids the clicks caused by discontinuities in the sample amplitude at cut/splice points by fading, or crossfading, edit points by a few samples.
  • Tools - Sample manipulation tools.
    • Amp
      • Amp (Alt+A) - Opens the Amplitude Tool that allows you to modify L/R channel volume, Panning and Stereo Separation.
      • Reverse polarity - Inverts the phase of the waveform.
      • Normalize (Ctrl+N) - increases the amplitude of the waveform so that the loudest sample is at 100% maximum possible level. The process works by determining the multiplication factor that will make the loudest sample reach 100%, then multiplies all samples by this value, rescaling them.
      • Lossy normalize - Similar to the standard Normalize, the amplitude of the waveform is increased so that the loudest sample is at 100% maximum possible level. There is an additional manipulation of the waveform phase that can sometimes tease out a few more dB gain. The process is considered 'lossy' as it changes the waveform phase, although it should sound identical to the standard Normalization.
      • Fade in (Ctrl+F) - Ramps up the volume from 0% to 100% using a logarithmic curve. If a region is selected the fade function will apply to that, if not, the entire sample will fade in.
      • Fade out (Alt+F) - Ramps down the volume from 100% to 0% using a logarithmic curve. If a region is selected the fade function will apply to that, if not, the entire sample will fade out.
      • Declick in - Smooths clicks at the beginning of a selection.
      • Declick out - Smooths clicks at the end of a selection.
    • Waveform
      • Center - Removes DC offset. The average amplitude of the waveform is shifted to be at the zero crossing.
    • Time
      • Reverse (Alt+Left) - Reverses the entire wave or selection.
      • Time stretch / pitch shift (Alt+T) - Opens the Time Stretch / Pitch Shift Tool to independently manipulate pitch, time and formants.
      • Drum(loop) stretch (Ctrl+T) - Opens the Drum (loop) stretch tool, which restores decay portions of drum beats that may have been cropped during the slicing process.
      • Claw machine (Alt+W) - Opens the Claw machine tool, that works on a tempo-sliced sample, removing beats, adding beats and/or shifting beats to create interesting new rhythms. NOTE: The sample must have a tempo set (or beatmarkers set) for the option to be available.
      • Scratch (envelope) - Uses the All-Purpose Envelope to apply 'scratching' effects to the sample, i.e. automate the playback direction and speed.
    • Channels
      • Swap channels - Swaps the left and right channels.
      • Convert left channel to mono - Converts the sample to a mono file based on the left channel.
      • Convert right channel to mono - Converts the sample to a mono file based on the right channel.
      • Convert mono signal to mono format - Converts the file to a mono format if both left and right channels are equal.
    • Synthesis
      • Generate noise - Generates white noise in the selected region or whole sample if a region is not selected.
    • Scripting
      • Run script - Opens a menu containing the list of available scripts. You can write your own scripts using Visual Basic or Pascal, which will be compiled by the paxCompiler and run when you select the script from the menu. The paxCompiler is a true Pascal compiler that allows you to write code to perform complex DSP on your samples. Save scripts - as .pas files in the FL Studio installation directory under ..\Plugins\Fruity\Effects\Edison\Data\Scripts. Files saved here will be visible the next time you use the 'run script' command. Dialogs - Note that while some of the demo scripts show a dialog, it isn't necessary to use them. Errors - If a script hasan error, a dialog is shown explaining the error with options to 'edit' the script or 'run' it again. Writing scripts - Examine the contents of the existing scripts and read the Reference.txt file in the script directory to learn more about writing them and the functions available. You can learn more about Pascal HERE.
      • Run last script - Repeats the last script run.
    • Noise gating
      • Acquire noise threshold (Alt+N) - Uses the peak of the selection as the noise/gate threshold. To use: select a region of the sample containing only noise and click this button.
      • Gate noise - Forces the sections of the sample below the noise threshold (shown in green) to silence.
      • Trim side noise - Trims any parts of the sample that are below the threshold volume. Set gate threshold - Left-click the peak meter and move the mouse up/down to change the threshold. A green band will display (as shown in the Edison screen shot above) in the sample view window.
      • Trim all noise & slice up - Trims any parts of the sample that are below the threshold volume and slices the regions defined by the resulting gaps. Set gate threshold - Left-click the peak meter and move the mouse up/down to change the threshold. A green band will display (as shown in the Edison screen shot above) in the sample view window.
    • Spectral
    • Regions
      • Tune loop (Ctrl+L)- Opens the Tune Loop Tool dialog that allows you access to the main loop controls for a region.
  • View - Waveform display properties.
    • Audio
      • Spectrum (S) - Selects spectrum view. This display mode shows time on the horizontal axis and frequency on the vertical axis. Brighter or more saturated colors (depending on the spectrum gradient options) represent louder frequencies.
      • Dual view - Shows both the spectrum and waveform views superimposed.
      • Display settings - Change the appearance of the spectrum display mode.
        • Fancy mode - Smoothed waveform view.
        • Waveform channels - Note that in stereo mode L and R channels are superimposed with slightly different colors (zoom to view more clearly).
          • Mono - Display a single (L/R averaged) waveform.
          • Multichannel - Display all channels (superimposed).
          • Left - Display Left channel.
          • Right - Display Right channel.
        • Spectrum precision - 32, to 8192 bands. This is the number of vertical slices the frequency domain is divided into, higher numbers provide more detailed analysis. Resize Edison to obtain an overall larger view.
        • Natural scale - Sets the vertical scale to reflect the musical 'octave' relationship of frequencies (a logarithmic scale). This will stretch the lower frequencies to occupy a greater area and so is particularly useful when working with frequencies below 500 Hz.
        • Natural weighting - Sets the color intensity gradient to better represent the way we hear frequencies. Specifically, it changes the brightness weighting from white noise, a linear relationship between frequency and display brightness to pink noise. Pink noise decreases the intensity by 3dB/Octave, making it more suitable for musical uses as the higher frequencies no longer dominate the spectral display brightness, which is closer to how we hear those same frequencies.
        • Enhanced Frequency/Time - These options improve the visibility of details particularly at lower frequencies. These options work well with a spectrum precision of 1024.
        • Draft - Less visibility of details in favor of quicker graphics responsiveness.
        • Spectrum gradient - 12 dB steps, Charcoal, Furnace, Deeper furnace, Glacier, Temperature, The Matrix. Choose the theme that reveals the most detail in the sound or that appeals to you.
    • Regions
      • Regions - Turns region markers on/off.
      • Loop - Turns loop markers on/off.
    • Time
      • Time format - Displays the time-base in samples, ms, beats. This information is displayed in the Hint Bar.
    • Misc
      • Scroller above - Places the Zoom / Scroll bar X above the sample.
      • Background gradient - Applies a 3D background effect to the sample edit window.
      • Invert grid - Inverts the shading of the time-grid.
  • Snap - Control how the cursor and markers snap to displayed elements.
    • Snap to grid (1) - Envelope points and selections snap to the background grid.
    • Snap to regions (2) - Envelope points and selections snap to the region markers.
    • Snap to samples (3) - Envelope points and selections snap to samples.
    • Snap to zero-crossing (4) - Envelope points and selections snap to zero crossings. This is the point where the waveform crosses the 0 amplitude line and is useful to avoid clicks.
    • Snap to pitch period (5) - Envelope points and selections snap to the period of any pitch detected at the selection point.
  • Select
    • Deselect (Up arrow) - Deselects the current selection.
    • Select before current selection - Selects the area before the current selection.
    • Select after current selection - Selects the area after the current selection.
    • Select zoomed part (Ctrl+A) - Selects the region defined by the visible sample.
    • Select previous region (Left arrow) - Selects the previous region.
    • Select next region (Right arrow) - Selects the next region.
  • Zoom
    • Zoom in 2x (PgUp) - Zooms in 2 times.
    • Zoom out 2x (PgDn) - Zooms out 2 times.
    • Zoom out full (Home) - Displays the full sample.
    • Zoom on selection (End) - Zooms the selection to fill the Sample Edit Window.
    • Zoom on left of selection (Ctrl+Left) - Centers the Sample Edit Window on the right edge of the selection at maximum zoom.
    • Zoom on right of selection (Ctrl+Right) - Centers the Sample Edit Window on the left edge of the selection at maximum zoom.

Zone Tab

Zone Tab Properties

The Zone Tab contains filters, envelopes, effects and the modulation matrix. It is possible for every sample loaded into DW to have a unique set of Zone Tab controls, a single set applied to all samples or some combination of the two.

NOTE: Make sure the 'EDIT/AUTOMATION' (Current Selection or Global) control is set to 'Current Selection' if you want changes to affect only the currently selected Zone (sample) or 'Global' for all Zones (samples).

Main

These options control the main sample (Zone) playback settings.

  • Pitch Tune - Adjusts the pitch.
  • Gain - Allows the user to map samples in both pitch and velocity space.
  • Panning - Pans the sample left (-50) or right (+50).
  • Post Gain - Volume control for the individual sample.

Time Stretch

These options control sample time-stretching and pitch-shifting playback functions. When the Time (Timestretching) mode is engaged the sample will be pitch-shifted using a granualization method. This maintains the samples temporal properties as pitch is changed, as opposed to changing speed with the standard method. The Timestretching algorithm can only be pushed so far before artifacts are audible.

  • Time (switch) - When selected, the Zone will be played using time stretching system.
  • Sync (switch) - When selected, the time stretching time will be expressed in ticks (1/4 beat).
  • Amount (Amt) - Time stretching length expressed in % of the original sample length or in number of ticks (1/4 beat, with sync enabled).
  • Grain - Length of each time stretching grain.
  • Smooth 'smoothing window' - Amount of smoothing between each time stretching grain.
  • Type - Reserved, not yet used.

Trigger

Trigger controls allow sample (Zone) playback randomization. The primary purpose is to recreate natural sounding instruments by using multiple sample Zones for a specific velocity range, assigning them to a 'Trigger Group' and randomly triggering Zones from Trigger Groups according to the following settings.

  • Group - Zone Trigger Group. Samples in the same Trigger Group will be randomized. Up to 99 trigger groups can be set. Randomization will be according to the Type control.

    To assign more than one Trigger Group -

    • 1. Select 'Current Selection' from the EDIT/AUTOMATION control (lower right on the Zone Tab)
    • 2. Select the Zone to be assigned from the Zone Window above the Zone Tab by clicking on it.
    • 3. Set the Trigger Group using the Group control.
  • Type - Randomization type. Type is not available if no Group is selected.
    • Normal - No velocity layer randomization.
    • Cycle - Each Layer in the velocity group will be played, in turn.
    • Random - Layers are played at random from the velocity group.
    • Avoid previous - Layers are played at random from the velocity group, with the restriction that the same Layer will never be played twice in a row. Random selection can sometimes cause a singe Layer to be played repeatedly, defeating the purpose. This random option can help to avoid obvious identical hits with repeated fast playing of a key.
  • Frequency - Randomization frequency controls how often a Zone from a Trigger Group is played. Settings vary from 100% (always) to 0% (never). In other words, 'Frequency' allows you to determine the probability that a Zone (sample) from the selected Trigger Group will play. A useful application of this control is to add in key-clacking, string buzzes and other incidental mechanical noises that instruments make, at random to selected velocity ranges. This control is not available if there are no velocity groups.
  • Overlap - Amount of velocity overlap required for Zones to Group-randomize. At 0%, touching Zones will randomize with no need to overlap. This control is not available if there are no velocity groups.

Filter 1 & Filter 2

There are two variable state filters that can be configured in parallel () or series ().

  • Frequency - Sets the cut-off frequency for the lowpass/bandpass/highpass filters.
  • Emphasis - Boosts a frequency band near the cut-off level to create a sound "sharpening" effect.
  • Shape - Applies hardclip limiting (distortion) on the filter output.
  • Type - Selects the filter type.
    • Off - The filter is bypassed with no effect.
    • Lowpass - Frequencies below the 'Frequency cut-off' are passed.
    • Highpass - Frequencies above the 'Frequency cut-off' are passed.
    • Bandpass- Allows a narrow band of frequencies to pass.
    • Notch - Subtracts a small band of frequencies.
    • Allpass - Alters the phase of the signal.
    • MiniSynth - See MiniSynth > Filter for details.
    • Vox - Vocal formant style filter.

AMP, ENV1 & ENV2 Envelopes

There is one dedicated Amplitude envelope and two freely assignable Envelopes.

  • Attack (A) - Sets the envelope Attack speed (down is fast, up is slow).
  • Decay (D) - Sets the envelope Decay speed (down is fast, up is slow).
  • Sustain /s - Sets the envelope Sustain time (down is short, up is long).
  • Release (R) - Sets the envelope Release speed (down is fast, up is slow).

LFO1 & LFO2

  • Rate - Low Frequency Oscillator speed.
  • Sync - Syncs the sample LFO start to the note-on event.
  • Attack - Sets the attack length of the LFO modulation (from instant through to 10 seconds delay).
  • Phase - Changes the phase of the waveform (Free Run appears when the knob is fully clockwise and allows the LFO to run independently of note start events).
  • Waveform - LFO wave shape, 8 are available.
    • Sine - Sine wave.
    • Abs Sine - Positive sine wave.
    • Triangle - Triangle wave.
    • Square - Square wave.
    • Saw - Saw wave.
    • Inv Saw - Inverted Saw wave.
    • Random - Random wave (noise).
    • LP Random - Low Pass Random.

Modulation Matrix 1 to 4

There are 4 banks of 4 modulation pairings, the first bank is defaulted to set the basic note control parameters, banks 2 - 4 are empty. The Mod Matrix allows the user to freely assign one variable to modulate another (LFO 1 modulating filter cut-off frequency for example).

  • To set a modulation mapping - select the Modulation Source in the top field, the Modulation Target in the lower field and the Modulation Amount with the knob to the right (-100% fully left to +100% fully right).
  • Special modulation sources:
    • Mod Amt - Allows linking of the matrix to itself. Route a source to the modulation amount of the desired modulation pairing. This will then act as an additional multiplier to the original pairings value.
    • Mod Val - Allows external modulation sources to be linked to targets in the matrix. Automate these parameters from the Plugin Menu > Browse Parameters option.

Effects

There are 4 effects and 3 sends from where FX may be added to the samples. Each has a switch to the right of the label that activates it. Ringmod, Decimator, Quantizer and Phaser, are able to be applied with unique instances on a sample-by-sample basis, while Delay, Chorus and Reverb are shared amongst all voices.

Ring Modulation

  • Rate - Full Left = stopped, Full right = 100% fast modulation.
  • Mix - Full Left = 0%, Full right = 100% Chorus FX mix.

Decimator

  • Step - Full Left = Minimum decimation, Full right = Maximum decimation.
  • Mix - Full Left = 0%, Full right = 100% full FX mix.

Quantizer

  • Bits - Full Left = More bits, Full right = less bits.
  • Mix - Full Left = 0%, Full right = 100% Chorus FX mix.

Phaser

  • Frequency - Phaser frequency.
  • Mix - Full Left = 0%, Full right = 100% Chorus FX mix.

Send

The Delay, Chorus and Reverb FX settings reside on the Program Tab, they are disabled by default. The default level for the sends is 50% (-12 dB). The reason some FX are on the Zone tab and some on the Program tab, is that Delay, Chorus and Reverb are CPU hungry FX and can't be applied on a voice-by-voice basis so are considered global FX, shared among all voices. To adjust the relative dry/wet mix, use dry = Post Gain, Wet = Sends (below).

  • Delay - Full Left = 0%, Full right = 100% Delay FX mix.
  • Chorus - Full Left = 0%, Full right = 100% Chorus FX mix.
  • Reverb - Full Left = 0%, Full right = 100% reverb FX mix.

Edit/Automation

Use this switch to decide if the changes on the Zone Tab affect only the currently selected sample (Zone) OR all samples.

  • Current - Applies the settings only to the currently selected Zone.
  • Global - Applies settings to all Zones. Careful! this will overwrite 'current' settings previously entered for any Zones.

Program Tab

Master

Use these controls to change the playback polyphony and overall volume.

  • Play Mode.
    • Poly - Polyphonic playback (more than one note).
    • Mono - Monophonic playback (one note at a time).
    • Legato - Monophonic with portamento.
  • Volume - It's a volume knob, what more can we say.

Glide (Portamento)

This control slurs the attack between notes, the controls change the dynamics of the slur (slide).

  • Time - Time taken to slide from one note to the next (0.001 to 10 seconds).
  • Fixed - Portamento takes place regardless of the playing style.
  • Auto - Legato notes (overlapping end of one to the start of another) will be portamento.

FX Drive A & B

  • Amount (%) - Controls the amount of overdrive for the distortion FX.

LFO 1 & LFO 2

There are two user-definable Low Frequency Oscillators. These are used as modulation sources for various parameters in the modulation matrix.

  • Rate - Frequency of the LFO.
  • Sync - LFO start to the note-on event.
  • Attack - Rate at which the LFO is introduced.
  • Phase - Starting phase of the LFO waveform.
  • Waveform - Selects the LFO waveform shape.
      • Sine - Sine wave.
      • Abs Sine - Absolute Sine (positive Sine Wave)
      • Triangle - Triangle wave.
      • Square - Square wave.
      • Saw - Saw wave.
      • Inv Saw - Inverted Saw wave.
      • Random - Random wave (noise).
      • LP Random - Low Pass Random.

FX - Delay, Reverb and Chorus

The Delay, reverb and Chorus are global FX, there are individual send-levels from each sample loaded in the Zone Tab.

Delay

  • Delay - Timing of the echoes.
  • Feedback - The amount of signal fed back into the delay loop.
  • Low Cut - The cutoff frequency below which frequencies are filtered.
  • High Cut - The cutoff frequency above which frequencies are filtered.
  • Bounce - Stereo echoes, bouncing between the L and R channels.
  • Normal - Mono echoes.

Reverb

  • Room (size) - Use this to set the size of the virtual room where the reverb is created. The Room Size should be adjusted according to the decay time. Small rooms sound better with a short decay time, large rooms sound better with longer reverb times.
  • High Frequency Damping (Damp) - This parameter allows you to adjust damping of the high frequencies in the reverb signal over time. Damping refers to the high frequencies being attenuated and dying out. This causes the sound to become gradually muffled and warm like it is being absorbed in the room. Setting this parameter to the maximum value will bypass the High Damping, displaying OFF in the value field.
  • Diffusion - Controls the density of the reflections bouncing off the walls of the virtual room. A low diffusion setting makes the reflections sound more distinct, like closely spaced echoes. A high diffusion setting creates reflections so close they sound more like noise, where no echoes can be distinguished.
  • Decay - Controls the decay time of the reverb, the time it takes for the signal to decay to -60dB (1/1000 of the maximum amplitude). Use low decay times for small rooms or boxes, and long decay times for large rooms, halls or churches. You should also make sure that the Room Size parameter has an appropriate value.

Chorus

  • Delay - Sets the minimal delay of the delay-line inside the flanger. The flanger delay will be swept between delay and delay+depth. Range: 0 to 20 milliseconds. For 'deep' flanger effect, set this parameter to low values.
  • Depth - Controls the range of the flanger action. The flanger delay will be swept between delay and delay+depth. If you set this value to zero, the flanger will remain 'static' as the delay will stay constant. Range: 0 to 20 milliseconds. Setting this parameter to a higher value will create special effects and heavy modulation.
  • Rate - Sets chorus modulation speed.
  • Feedback - Determines how much of the signal is sent back into the chorus.

Options

To open the Options Window - Left-click on the 'Options' button above the peak-meter. The options dialog allows you to select the Browser directories and rendering quality, and set up an automated sample VST session.

Directories

  • Content Library - Click on the folder icon to link DirectWave to your sample library. The directory set here will also be the default used when saving DWP files and sample data.

Global

  • Import content to library - Copy imported .dwp and contained samples to the content library folder on opening.
  • Multitimbral Mode - Allows DirectWave to respond independently on all 16 MIDI channels (see the Multi-Bank Window to load multiple banks).
  • Use tablet PC or digitizing stylus - Switch on when using a stylus based interface.
  • Switch program channel - Select the MIDI channel DirectWave responds to program changes on. The default '---' is off.

Bank

  • 16-Point sinc interpolation - When deselected 64 point sinc is used. 16 point sinc uses less CPU but may produce more aliasing for transposed samples.
  • Monolithic mode - There are two effects of using this option:
    1. When saving DirectWave Banks (.dwb) - Bundles all sample/wave data into a single .dwb preset. DirectWave Presets (.dwp) do not respond to this option.
    2. When saving FL Studio projects (.flp) - Bundles all sample/wave data into the .flp. This will create large project files, but projects using it will be portable to other users/machines without the need for separate sample data. It's also a good archive format for your DirectWave projects.
  • Show note names in host - Informs the host what name a note has (based on the zone name) when the host requests this information.
  • High Quality Rendering - Increases temporal resolution of all automatable parameters on DirectWave to (near) audio-rate frequencies. This uses more CPU but allows for complex and fast modulation of parameters without artifacts (think FM and AM modulation). It's particularly useful with filter modulation.

Samples

  • Pitch analysis after sample load - Analyses pitch of loaded samples. Useful when creating banks from scratch.
  • Auto normalize samples - Maximizes the volume of samples so that the maximum peak hits 100% volume.
  • Extract root key from filename - Sets the sample root key from the end of the file name, e.g. 'Strings_C4.wav' or 'Strings - C4.wav' (note the spaces either side of the dash) will set the Root Key to C4. So, C4_Strings.wav and Strings-C4.wav won't work.
  • Show load progress - An indicator shows sample load progress.

Compatibility

  • Compatible velocity - Backward compatibility for velocity handling, should be left off for new banks.
  • Clip volume - Try this with old banks/songs that have 'volume' issues' (too loud), should be left off for new songs/banks.

DirectWave Channel Sampler

To open - Right-click the Channel (Button) you want to sample in FL Studio and select 'Create DirectWave instrument'. The DirectWave Channel Sampler is a sampling-robot that will create DirectWave patches from plugins loaded in the Channel Rack. This works for both native and VST format plugins. With or without Mixer FX applied.

Settings

Sets the automated sampling options. Please be aware that long sample settings combined with multiple velocity layers and small key-steps will result in very large programs.

Sampling options:

  • Low note - Lowest key to sample.
  • High note - Highest key to sample.
  • Key zones - Width of the sample-zones. A single sample can be played across several keys to create a 'sample zone'. Zone-width is shown by the alternating grey and white sections on the preview keyboard.
  • Max velocity - Maximum velocity to sample. If Velocity layers is set to 1, this is the value will be used for all samples.
  • Velocity layers - Number of velocity layers to sample. NOTE: Experiment to see how velocity affects the source Channels sound, before using more than one step. Each velocity step represents a full multiplication of the patch size. You can click up and down on the Preview Keyboard keys to experiment with velocity.
  • Root offset - Number of notes above the first note in each Key zone range the sample will be taken from. The Root note is shown on the Preview Keyboard in blue (see above).
  • Link velocity to gain - Sets DirectWave to change velocity to gain (volume). This does not affect the source sample data.
  • Cycle layers - Makes repeated sample layers with the same settings for 'round-robin' style sample effects. That is, when the source changes its timbre or sound on repeated notes, use this feature to capture those variations. NOTE: Experiment to see if the sound changes dramatically on each repeated note before using this feature. Each Cycle layer represents a full multiplication of the patch size. Tap use the preview keyboard to test.
  • Stop on - The condition on which sampling is terminated.
    • Max length - Sampling stops abruptly at the length sent.
    • Silence - Sampling stops when the sound has faded to silence (-96 dB). In this case, sampling can stop before the Max length is reached, but never after it. Max length always takes priority on the maximum length.
  • Max length - Total sample duration. Set in Seconds, Bars or Beats.
  • Release after - Time the key are held while sampling. Set in Seconds, Bars or Beats.

Quality:

  • Resampling - Choose resampling quality. This can avoid aliasing in Channel Samplers.
  • Bit depth - Choose 16 or 32 Bit float.
  • Stereo mode - Choose Stereo, Mono Left Channel, Mono Right Channel or Mono Merged.
  • HQ for all plugins - Sets high quality mode for any native FL Studio plugins (effects, instruments & sampler channels) used in the render. VST plugins may also render in HQ mode if the Wrapper setting Notify about rendering mode is selected.
  • Disable maximum polyphony - Ignores the max polyphony setting in Miscellaneous Channel Settings but does NOT ignore Monophonic option if selected.
  • Dithering - Applies 32 to 16-Bit dithering to 16-Bit .wav files. FL Studio uses a 'shaped' Dither algorithm that shifts most of the dithering 'hiss' above 10 kHz.
  • Trim PDC delay - Removes any Delay from the start of the sample caused by plugin Latency. As PDC can add a delay to Mixer Tracks, this option decides if the PDC delay is rendered, or not. When selected, any PDC that was added to the Master Mixer Track is removed from the start of the rendered .wav file. When deselected the PDC remains as a short period of silence equal to the PDC setting of the source Mixer Track.
  • Declick in / Declick out - Uses a 20 ms fade to prevent clicks from abrupt sample level changes when a sample start or end is not correctly captured.
  • Normalize - The amplitude of the waveform is increased so that the loudest sample is at 100% level. This can be useful when you are making a single velocity layer with 'Link velocity to gain' on.

Loop:

  • Enable - Enables the automated looping functions. Normally these are used to extend the key-held play-time for samples, while keeping the overall patch size small. The best loops are obtained when the sound being looped is at a steady volume over the looped part. If the sample is fading or changing timbre there will be an obvious glitch on the loops (or try Crossfade mode).
  • Start point - How far into the sample should the Loop-start is set. Choose Seconds, Beats or Bars.
  • Crossfade - Enables Cross-fade looping. This type of loop is great for smoothing out glitches in loops for samples where there are changes in volume or tone over the region to be looped. The end of the sample loop is crossfaded (blended) with the region just before the loop start so that the end of the loop blends smoothly with the beginning of the loop. Consequently, the loop start point will be adjusted automatically as the Crossfade value is changed, to bring in more or less of the pre-loop sample data into the loop. Related options are:
    • Length - Length of the crossfade.
    • Tension - Slope of the crossfade volume envelope. Set by ear.
    • Snap - The Crossfade uses pitch detection to minimize phase cancellation. Set by ear.

    NOTE: To learn more about how the Crossfade Looping works, try experimenting in real-time with Edison's Tune Loop Tool.

Miscellaneous:

  • Signal flow and FX - The signal path is Channel > Input Mixer Channel > Master Mixer Channel:
    • Enable master effects - Samples are made with (On) or without (Off) any effects loaded on the Master Mixer track.
    • Enable insert effects - Samples are made with (On) or without (Off) any effects loaded on the Insert Mixer track.
    • Monolithic file - All samples are saved in a DirectWave Bank (.dwb) preset, rather than in a separate sub-folder, along with a .dwp preset. Use this for convenient export of presets compatible with DirectWave and the FL Mobile DirectWave module.
  • Open in DirectWave - After sampling, load the patch in DirectWave for preview.

Plugin Credits: Dan, Reflex, Miro & Argu