FL STUDIO BASICS

FL Studio User Interfaces

This section covers the main control interfaces in FL Studio. A video tutorials are also available on the Image-Line YouTube page.

Controls & Interfaces

This section contains notes about the interface controls of FL Studio. Hold the mouse pointer over everything and look at the Hint Bar while you do. Different icons will explain what actions are possible with that icon.

Hint bar

The Hint Bar shows help tips for items as you move the mouse cursor over them. In the screen shot above 'Mix level' shows the object the mouse pointer is currently over, and the icons to the right what actions are possible. There is an optional, larger, floating Hint panel revealed by the View > Toolbars > Hint bar setting. There is no better way to discover features in FL Studio.

Knobs & sliders

LCDs

The value of the LCD control is normally set by dragging on the screen with your left mouse button up and down (just like a wheel). You can also increment or decrement the LCD value one step at a time: place your mouse pointer at the top edge of the LCD (to increment) or bottom edge (to decrement) the control - the pointer will change to show the increment or decrement cursor respectively (). Click to increment/decrement the LCD value.

Window menus

There are menu icons located in the top left corner of the Playlist, Channel Settings, Piano roll, Mixer and others. Left-clicking these will access the associated menu.

Menu items

Where you see the save drag icon [] associated with a Save item, you can click on the icon and drag the file to a compatible location in FL Studio (e.g. another Piano roll, the Browser, etc).

NOTE: To disable drag-animation effects set the General Settings > Animations to 'Keep it sober' or 'Don't distract me'.

Scroll & Horizontal Zoom bars

Some Scrollbars (Playlist and Piano roll) have 'two dimensional scrolling' - drag them with your right mouse button (instead of the left, as usual) to move the view simultaneously in the horizontal and vertical directions.

Zoom

The Playlist and Piano roll have zoomable areas. Where vertical zooming is possible you will notice a rectangular box. Click on this with your mouse and move up/down to change the zoom level.

Zoom resolution depends on the 'Timebase' (PPQ) settings in the General Project Options (F11). The higher the PPQ, the greater the resolution, although you will find the default setting of 96 PPQ to be adequate for most situations.

Presets

Right-click on the double arrows () in the top right corner of Instrument or FX wrappers to bring up the preset menu. Select a preset from the list to load it. Left-click on the right arrow to step forward and left arrow to step back through the preset list sequentially.

Wave displays

If you see a sample displayed in FL Studio, it can probably be Left-clicked and dragged to another location such as a sampler channel or a another plugin that uses .wav files.

NOTE: To disable drag-animation effects set the General Settings > Animations to 'Keep it sober' or 'Don't distract me'.

Multimedia Keyboards

If you have a multimedia keyboard you can use the Play/Pause button to Start/Pause FL Studio, the Stop button will stop FL Studio and return the song position marker to the beginning of the Playlist. The FF/RW buttons will jump between Playlist Time Markers if present.

Multi-Touch Support

Select Options > General Settings >Optimize for 'Multi-touch monitor'. Windows Touch enables several gestures that support single and multiple contacts.

Multi-touch features by window:

The following image illustrates the various gestures that are supported in Windows 7 and higher.

Favorite folders

All open/import and save/export dialogs in FL Studio have a Favorites function to quickly jump to frequently used folders.

  1. Favorites menu - Contains a list with shortcuts to all favorite folders you have set.
  2. Set As Favorite - Adds the current folder to the favorites. Browse to the folder you want to add as an item in the Favorites menu and click this button.
  3. Remove From Favorites - Removes the currently displayed folder in the combo box from the favorites list.

Multi-Screen Support

FL Studio allows the use of two (or more) monitors.

To use multiple monitors there are 2 options:

  1. Detached windows - From the window menu (top left corner, Piano roll, Playlist, Event editor, Plugin e.t.c,) set to 'Detached'. This works for most windows except for the Step Sequencer.
  2. Expand the desktop - Click the 'Maximize/Restore' button (between the minimize & close button) and stretch the work area over the multiple monitors.