PLAYLIST

The Playlist

The Playlist is the place where all the individual elements of a musical piece are arranged into a complete song. The Playlist window (15) is comprised of multi-purpose 'Clip Tracks', these can host Patterns Clips, Audio Clips and Automation Clips.

NOTE: Pattern Clips can hold two types of data, MIDI notes and/or controller movements (stored as 'event automation'). Video tutorials are available on the Image-Line YouTube Channel.

  1. Playlist Menu Button & Playlist Snap Selector.
  2. Tools - Draw / Pencil ( Shift+P); Paint / Brush ( Shift+B); Erase ( Shift+D); Mute (T); Slip ( Shift+S); Cut ( Alt + Right-Shift); Select ( Shift+E); Zoom to selection ( Shift+Z). Play selection ( Y).
  3. Clip Select Menu & Project Picker - Left-click - The menu at the top of the Playlist to open the menu of Clips ready to be placed in the Clip Tracks area (15). Right-click - to open the Project Picker. Once a Clip is selected it can be added to the Playlist by Left-clicking on an empty Clip Track space. Alternatively Right-click the Clip-type Focus tabs (10) to see menu-selections of Clips unique to each type.
  4. Play Position Marker - Displays the current playback position, can be ( Left-clicked & dragged).
  5. Song Loop - Right-click a Time Marker and select the option 'Song loop' See (11) for more information on adding Time Markers. The 'Song loop' marker (note the down facing arrow) defines the repeat point for a playing project, repeats are not played when a song is rendered although the marker can be used to define render length. TIP: The Repeat Marker is ignored during rendering except for the special case where the marker is set beyond the end of the last Playlist data. This will force the project to be rendered to the point set by the marker, useful for ensuring decaying effect sounds are captured. LIVE: The song markers can also be used to control live playback & performance.
  6. Timeline Selection - ( Ctrl+Left-click) & drag in the bar-count area to make a vertical selection across all tracks. (Shift+Left-click) & drag to copy-move selection. Timeline Selections will play in loop mode or render as a single section. Actually we cheated a bit with the screen shot, while only the selected portion of the Playlist will play, any portions of a Clip outside the selected area will also turn red (i.e. be selected), however these out-of-bounds clip-parts won't play. NOTE: See here to learn more about using the time-line selection to add or delete time from the Playlist.
  7. Horizontal Zoom (Timeline Zoom) - Click and drag on the left or right edge of the horizontal scroll handle. Alternatively place the mouse cursor over the location to zoom and ( Ctrl + mouse wheel). Maximum Zoom/Snap resolution may be increased by changing the Project Timebase (PPQ) setting (F11), in the General Project settings. The default PPQ should provide adequate zoom/resolution for most situations.
  8. Maximize Playlist - Maximizes/minimizes the Playlist.
  9. Vertical Zoom - Left-click & drag up/down to vertical-zoom the Clip-area. You can resize individual tracks by dragging on the dividers between tracks in the name area. Right-click on an empty Playlist track area to zoom to full view.
  10. Clip-type Focus & Options Selector - Left-click: each tab to determine the Clip type that will be selected (Audio, Automation or Pattern Clip) when Clips of these types are stacked in a Playlist Clip Track and selected with the mouse. Each tab also contains some options unique to each Clip type. Right-click: each tab to select Clips of that category to be added to the Playlist (this is an alternative to the Clip Select Menu (3)
  11. Time Markers - Add by selecting ( Alt+T) or ' Time markers > Add time marker' . Left-click, hold & drag a marker to reposition it. Once the first Time marker is added to a project, it can be Right-clicked to Add a new marker, Delete it or Rename. Time markers can also be used for selections & live jumping (see below).
  12. Track Options & Labels - Right-click to open Playlist track options including:

    NOTE: Drag an audio file (from the Browser, for example) and drop it on the Track label area to auto-create an Audio Clip and auto-name the Clip track to match the file.

  13. Track Mute - Mutes/solos a Playlist track. Left-click to mute/un-mute a track. Right-click to solo a track. ( Alt + Right-click) mute/solo the group.
  14. Clip Menus - The Clip menu can be found at the top-left corner of each Clip. Click to open. Options may vary depending on Clip type.
  15. Clip Tracks - There are three different Clip types: Audio Clips (holding audio recordings), Automation Clips (automation data) and Pattern Clips (note & event-automation data). To reorder Clip Tracks, hold ( Shift & mouse-wheel) over the Clip Track label area. NOTE: The three Clip-types can be visually layered in the same Clip-track, simply drag one on top of another.
  16. Track divider - Resize - Click and drag vertically to resize individual tracks. Group tracks - Drag upward (and keep going) until the track groups with the one above. Do the same thing to ungroup a track OR right-click the track header area and select 'Group with above track'.

Timeline & Time Markers

Time is displayed horizontally in the Playlist (in bars displayed along the top of the window). The grid resolution is determined by:

Playback can be controlled from the Main Transport controls or the Play button as indicated above.

Patterns, Audio Clips and Automation Clips

This section covers general editing and Playlist operations. For specific details on using Audio Clips, Automation Clips and Patterns Clips, please see the following pages:

NOTE: Audio, Automation and Pattern Clips can share the same Playlist tracks, as shown above and will overlap, with transparency, to aid with the grouping of related Clips.

Playlist Clip Focus

The Clip focus selector (10), is used to focus Clip types. This is particularly useful when Clips are stacked, the focused Clip is brought to the top for selection and editing. To select all clips in a layered stack, use ( Ctrl + Left-click), then they can be moved together.

Audio

Automation

Patterns (notes & events)

These control the color display for Pattern Clips.

Project Picker

The Project Picker ( Ctrl+Alt+F8) can also be opened by Right-clicking the Clip Selector (3) or Mouse X1 button on the Playlist, Piano roll or FL Studio background wallpaper. Plugin Picker video tutorial here .

Working with Clips

Take the time to learn the Playlist keyboard shortcuts associated with your most common Clip operations. In particular, the shortcuts that swap between editing tool modes (2) are great time savers.

Selection Methods (while in Draw or Paint mode)

Most commonly you will be in Draw () or Paint () mode, if so holding (Shift) will swap between Paint & Draw modes, although the cursor does not change in appearance. Further, holding the ( Ctrl) key will temporarily enable Select mode:

Universal Clip Editing Methods

Audio Clip Specific Features

Audio Clips have a few unique properties, as discussed on the Audio Clip page.

Automation Clip Specific Features

Automation Clips have a range of unique properties, as discussed on the Automation Clip page.

Pattern Clip Specific Features

Pattern Clips have a few unique properties, as discussed on the Pattern Clip page.

Clip Menus

Under the menu icons at the top left corner of each Clip you will find a menu with the following options, depending on the Clip type selected:

Playlist Menu

The Playlist menu button (1) displays many useful commands for managing the Playlist.

Edit

Tools

View

Snap

Snap determines how events will move relative to the Playlist grid and how quantization aligns events (NOTE: holding the Alt key temporarily sets snap to 'none'). The options are:

Select

Group

Zoom

Contains a submenu with a set of quick zooming levels: Far ( 1); Medium ( 2); Close ( 3); Best fit ( 4); On Selection ( 5).

On Selection zooms the time line to fit the selection (the command will be disabled if no time region is selected in the timeline).

Time markers

Markers can be used to label parts of your song (such as 'chorus' for example), define regions or to change live Playlist playback behavior. Playlist menu options are:

NOTE: Check the Playlist Menu option View > Time segments > Markers to see the Playlist grid shaded by marker region.

Working with Time Markers

Live song jumps

You can using a MIDI keyboard, typing keyboard shortcuts (see below) or FF/RW transport keys on a multimedia keyboard to jump between time markers to create innovative live performances. Video tutorial here.

To use a MIDI keyboard:

  1. Set the MIDI options 'Song marker jump MIDI channel' to the same MIDI channel as your controller. NOTE: To play plugin instruments just use different MIDI channel to the 'Song marker jump MIDI channel'.
  2. Turn OFF the Audio Option 'Reset Plugins on Transport'. This should give a faster and less glitchy response when jumping and moving the song position marker.
  3. Turn ON the Audio Option 'Play truncated notes'. This ensures any notes started before a jump point, and crossing it, still play.
  4. Select 'Live mode' from the Playlist menu. This changes the jump-to behavior so that jumps happen on bar divisions and also shows the jump-to points (as a gray position marker).

Once markers have been added and their type defined they will respond as follows:

NOTE: 1. Keyboard shortcuts apply to the Number Pad only.

Current Clip source

Shows the list of Clips available in the project. The currently selected Clip will be highlighted.

Performance mode ( Ctrl+P)

Performance mode is designed to trigger and loop individual Playlist tracks and clips to create live performances. Performance mode is explained in detail here.

Center ( 0)

Center (grid) centers the Playlist's grid so the play position marker is in the middle. Useful when you want to see the playing position in a long sequence.

Detached

Detached - Detaches the Playlist from the FL Studio workspace, allowing it to be dragged to another monitor.

Playlist keyboard shortcuts


Playlist action
B Paint tool
C Slice tool
D Delete tool
E Select tool
P Pencil tool
S Slip edit tool
T Mute tool
Y Playback tool
Z Zoom tool
Alt Bypass snap (very useful when combined with other modifiers)
Alt+G Ungroup selection
Alt+P Open the Piano roll or channel depending on what's selected in the Playlist
Alt+T Add Time marker
Alt+/* and Ctrl+Alt+/* Jump to Next/Previous song marker (if present)
Alt+ Right-click Audition the clip selected.
Alt+ Right-Shift Engage snap free 'Slice Mode', release Alt after clicking on the Clip to use snapping.
Ctrl+A Select All
Ctrl+B Duplicate selection (or all Clips in zoom range if nothing is selected) to the right.
Ctrl+C Copy selection
Ctrl+D Deselect selection
Ctrl+P Toggle Performance Mode
Ctrl+T Add Time Marker
Ctrl+V Paste selection
Ctrl+X Cut selection
Ctrl+Alt+G Grid Color
Ctrl+Alt+Home Toggle Resizing from Left
Ctrl+Ins Add space at the start of the timeline selection of equal length to the selection
Ctrl+Del Delete space according to the timeline selection
Ctrl+Enter Select time around selection
Ctrl+Left-Arrow/Right-Arrow Select time before/after selection equal to the selection length
Ctrl+Left-click Select
Ctrl+Shift+Left-click Add to selection
Ctrl+Shift+Right-click Zoom to selected Clip
Ctrl+Right-click Zoom on selection / Drag to make zoom selection (zoom on release)
Del Delete selected clip/pattern source data
Double Left-click on clip/pattern Open clip/pattern properties (e.g. Channel settings, Piano roll)
Home Move the playback marker to the start of the Playlist.
Insert Key Slice Clip at mouse cursor position
Left-Shift+Left-click (on Playlist) Add and resize clip/pattern (move mouse L/R after click and hold to resize). Must be in pencil mode.
Left-Shift+Right-click Pan view
Middle mouse button Pan view (hold & drag left/right)
PgUp / PgDown Zoom in / Zoom out
Pencil tool + Shift Swap to Brush
Right-click Delete selected clip/pattern
Right-Shift+Left-click Slice clip/pattern (click above/below clip/pattern & drag vertical)
Right-Alt+Right-Shift+Left-click Vertical Slice clip. Release alt to engage snap.
Right-Shift+Right-click Slice clip/pattern & delete smallest part (click above/below clip/pattern & drag vertical)
Right-Alt+Right-click Quantize selected
Right-Alt+Left-click Mute selected
Shift Temporarily swaps between Paint & Draw modes
Shift+C Select all Clips according to the currently selected Clip source
Shift+G Group selected Clips
Shift+I Invert selection
Shift+Q Quick quantize Clip start times
Shift+Left-Arrow/Right-Arrow Move selection Left/Right
Shift+Up-Arrow/Down-Arrow Move selection Up/Down
Shift+Left-click (on clip/pattern) Clone (drag while holding clip/pattern)
Shift+mouse-wheel (on Clips) Nudge Clip position
Shift+mouse-wheel (on Track label area) Re-order Clip Tracks
Shift + 0 (zero) Center Playlist to play-head position (numbers above typing keys)
Shift + 1 to 3 Horizontal Zoom levels 1 (zoom out) to 3 (zoom in), (numbers above typing keys)
Shift + 4 Horizontal Zoom, show all (numbers above typing keys)
Shift + 5 Zoom to selection (numbers above typing keys)
Shift + 6 Fit Performance Zone to Playlist (numbers above typing keys)