INSTRUMENTS / GENERATORS

DirectWave Sampler

Player version: DirectWave installs as a 'player' version, free for all users. DirectWave (player) channels will be saved along with the projects as normal. The DirectWave Player limitations are: Only DirectWave's own formats (*.dwp & *.dwb) can be loaded, VST sampling is disabled, external samples can not be added to patches nor can new patches be created.

To unlock the extra functions including: Editing patches, adding samples, recording, sampling VST instruments, loading 3rd party formats then DirectWave full version needs to be purchased separately.

NOTE: For near audio-rate modulations, select High Quality Rendering on the Options tab.


DirectWave is a powerful and versatile sampler featuring a fully programmable synthesis section and features such as inbuilt FX, velocity & randomization layering, looping, automatic sampling of VSTi plugins and the ability to 'sample' (record sound) when loaded into the mixer audio chain, in an effects slot.

Visit the DirectWave Image-Line forum for more patches and programming tips.

Overview

The programming functions are divided into an upper and lower interface as follows:

Download Samples

Use the 'Online Content' button to access the Content Library to download soundbanks directly from the Image-Line DirectWave Content Page. There are free selections for most products, to test.

Loading Programs and Samples

Disk Operations Menu

The Disk operations menu on the top left of the interface has the following options:

Working with content

Sample format support

DirectWave currently supports the following formats:

WARNING: DirectWave will not import the above formats if they have been encrypted/protected. Encryption is sometimes used by vendors to prevent non-native import of program files (they want you to buy their sampler) so check with the vendor they are not encrypted/locked to a given sampler if you are planning to purchase any of these formats for use with DirectWave.

Program Window

The Program Window allows you to assign samples over the keyboard for pitch (horizontal) and velocity (vertical) 'Zones'. A simple way to load samples is to drag them from a Browser and drop them on the Zone Window. This will create a new Zone for the sample. To assign Key and Velocity ranges drag the Zone Control Points, as noted below.

NOTE: To expand this window for easier editing

Diagram

  1. Sample List - Contains the samples loaded in the current patch. Click on a row to activate its controls. Drag samples from the FL Browser and drop here to build a patch.
  2. Zone Mapper - Allows the user to map samples in both pitch and velocity space.
  3. Sample List Scrollbar - Appears when more samples are in use than can fit in the Sample List window.
  4. Active Sample - Edited zones will be highlighted in blue.
  5. Zone Control Points - The upper and lower points allow you to define the velocity and pitch range by dragging the Zone Control Points in both pitch (horizontal) and velocity (vertical). Left-click, hold and drag to move a control point.
  6. Root Key - Shows the MIDI key at which the sample will play back without changing from its recorded pitch. Right-click on the keyboard to change the MIDI note.
  7. Vertical expand - Click to maximize the height of the Program Window. To extend the width, drag on the right-side of the DirectWave window.

Loading Samples

To load samples, either drag the sample from the FL Studio Browser onto the Zone Window or double click on a sample in the DW Browser. See also the Disk operations menu.

Parameters

1. Columns (upper section)

NOTE: You can drag and drop samples from the FL Browser directly onto the Sample List.

2. Zone Mapper (lower section)

Provides 'drag & drop' setting of the Zone key-ranges (horizontal) and velocity ranges (vertical).

Context Menu (Right-click anywhere inside the Zone window)

Library Window

The Library Window shows the DirectWave programs that are available from your library.

Controls

WARNING: DirectWave will not import the above formats if they have been encrypted/protected. Encryption is sometimes used by vendors to prevent non-native import of program files (they want you to buy their sampler) so check with the vendor they are not encrypted/locked to a given sampler if you are planning to purchase any of these formats for use with DirectWave.

Multi-Bank Window (Select 'Multitimbral mode' in Options)

The Multi-Bank Window allows you to load, up to, 16 separate programs as banks and control them from the 16 MIDI Note Colors or 16 MIDI Out Channels and/or route them to 16 separate Mixer Channels for separate FX processing.

NOTE: For OLDER projects made prior to FL Studio 11, deactivate 'Multitimbral Mode' in the Options.

Controls

Left-clicking on a line - Ch. 1 to 16 in the MULTI window (or the 1 to 16 buttons along the top of the plugin) will select the corresponding PROGRAM window, program number.

Parameters

Sample Tab

The Sample Tab contains Sample Start, Looping options and Input/Recording controls.

Sample Window Mouse-Control

Apart from the horizontal and vertical zoom buttons, as shown in the image above, several actions are available through mouse movement, as described below.

Sample

Loop

Looping samples is the process of setting a region in the sample that will be repeated. Although termed Loop Start and Loop End DW allows you to move the End point in front of the Start (useful when automating points), so they are really just 'Loop point A and B'.

NOTE: Looping instrument samples is an art. It is very easy to make loops that click, warble, pop or just sound plain awful (nothing is broken). Clicks are caused by the sample amplitude at the loop start and end points differing (try to select zero-crossing points and the same phases of the waveform, that is moving in the same direction). Another source of loop disasters are slow changes in timbre, phase or frequency content. Normally these happen slowly and naturally and add motion to the sound, however when a loop jumps back to a distant point, the abrupt change sounds like a glitch. In these cases the 'Bounce' loop can be a solution. In conclusion, there is a reason why professional sample libraries are expensive, someone (or team) had to sit down and craft hundreds/thousands of loops, often involving serious post-processing (layering, cross-fading, etc). If we haven't scared you off by now, experiment with the loop types and start/end positions and remember some sounds just don't loop smoothly...on second thoughts perhaps we should only allow trained professionals access to these controls?

TIP: Use 'Tune Loop' command from sample editor popup menu (Right-click on sample editor wave display, select 'Tools > Tune loop') to assist in finding good loop points. This jumps the loop-start/end markers between zero-crossings. Don't forget to zoom the wave-display if you need finer control.

Input / Sampling

To record you must load the DW VST version into a mixer channel Effects slot (DW VST version can be downloaded from www.imageline.com). DW VST only records sound from the mixer track and FX slot where it is loaded. This means any FX in slots preceding DW will be heard (and recorded) while those after it will be heard (but not recorded).

NOTE: DirectWave can also auto-sample VST plugins, see the Options > VST Sampler tab.

Wave Viewer Editor Options / Context Menu (Right-click)

Click the Editor Options button or Right-click on the sample view window. If the selected command acts on sample data, only the selected region will be affected. To select sample data, Left-click and drag on the region you desire to process or edit.

Zone Tab

Zone Tab Properties

The Zone Tab contains filters, envelopes, effects and the modulation matrix. It is possible for every sample loaded into DW to have a unique set of Zone Tab controls, a single set applied to all samples or some combination of the two.

NOTE: Make sure the 'EDIT/AUTOMATION' (Current Selection or Global) control is set to 'Current Selection' if you want changes to affect only the currently selected Zone (sample) or 'Global' for all Zones (samples).

Main

These options control the main sample (Zone) playback settings.

Time Stretch

These options control sample time-stretching and pitch-shifting playback functions. When the Time (Timestretching) mode is engaged the sample will be pitch-shifted using a granualization method. This maintains the samples temporal properties as pitch is changed, as opposed to changing speed with the standard method. The Timestretching algorithm can only be pushed so far before artifacts are audible.

Trigger

Trigger controls allow sample (Zone) playback randomization. The primary purpose is to recreate natural sounding instruments by using multiple sample Zones for a specific velocity range, assigning them to a 'Trigger Group' and randomly triggering Zones from Trigger Groups according to the following settings.

Filter 1 & Filter 2

There are two variable state filters that can be configured in parallel () or series ().

AMP, ENV1 & ENV2 Envelopes

There is one dedicated Amplitude envelope and two freely assignable Envelopes.

LFO1 & LFO2

Modulation Matrix 1 to 4

There are 4 banks of 4 modulation pairings, the first bank is defaulted to set the basic note control parameters, banks 2 - 4 are empty. The Mod Matrix allows the user to freely assign one variable to modulate another (LFO 1 modulating filter cut-off frequency for example).

Effects

There are 4 effects and 3 sends from where FX may be added to the samples. Each has a switch to the right of the label that activates it. Ringmod, Decimator, Quantizer and Phaser, are able to be applied with unique instances on a sample-by-sample basis, while Delay, Chorus and Reverb are shared amongst all voices.

Ring Modulation

Decimator

Quantizer

Phaser

Send

The Delay, Chorus and Reverb FX settings reside on the Program Tab, they are disabled by default. The default level for the sends is 50% (-12 dB). The reason some FX are on the Zone tab and some on the Program tab, is that Delay, Chorus and Reverb are CPU hungry FX and can't be applied on a voice-by-voice basis so are considered global FX, shared among all voices. To adjust the relative dry/wet mix, use dry = Post Gain, Wet = Sends (below).

Edit/Automation

Use this switch to decide if the changes on the Zone Tab affect only the currently selected sample (Zone) OR all samples.

Program Tab

Master

Use these controls to change the playback polyphony and overall volume.

Glide (Portamento)

This control slurs the attack between notes, the controls change the dynamics of the slur (slide).

FX Drive A & B

LFO 1 & LFO 2

There are two user-definable Low Frequency Oscillators. These are used as modulation sources for various parameters in the modulation matrix.

FX - Delay, Reverb and Chorus

The Delay, reverb and Chorus are global FX, there are individual send-levels from each sample loaded in the Zone Tab.

Delay

Reverb

Chorus

Options

To open the Options Window - Left-click on the 'Options' button above the peak-meter. The options dialog allows you to select the Browser directories and rendering quality, and set up an automated sample VST session.

Directories

Global

Bank

Samples

Compatibility

DirectWave Channel Sampler

To open - Right-click the Channel (Button) you want to sample in FL Studio and select 'Create DirectWave instrument'. The DirectWave Channel Sampler is a sampling-robot that will create DirectWave patches from plugins loaded in the Channel Rack. This works for both native and VST format plugins. With or without Mixer FX applied.

Settings

Sets the automated sampling options. Please be aware that long sample settings combined with multiple velocity layers and small key-steps will result in very large programs.

Sampling options:

Quality:

Loop:

Miscellaneous:


Plugin Credits: Dan, Reflex, Miro & Argu