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IMPORTANT: This guide is a general Getting Started manual for
all FL Studio editions. Some features are not available all
editions. For example: Fruity Edition does not include Audio
Clips. Please check our site http://flstudio.image-line.com for
upgrade options.
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THE FL STUDIO BOX DOES NOT CONTAIN INSTALLATION MEDIA

Start here http://install.flstudio.com …

1. Download FL Studio and install it using the default install-wizard settings.
2. Register your code – Account creation; Use your real name so we can identify you if you
ever lose your login info. Registration; Enter the 20 character code from your box when
prompted. Test you can login to your account before the next step.
3. Unlock FL Studio – Start FL Studio and select HELP > About. On the ‘Settings – About FL
Studio’ panel, agree to the ‘Terms of use’ and enter your Account email and password.
4. Click ‘Unlock with account’ – When you see ‘The registration succeeded’ click ‘Ok’ and FL
Studio will close. To unlock FL Studio without Internet access, use ‘Unlock with file’
method, next page.
5. Restart FL Studio – Your name and license code will show at the top of the HELP > About
panel.

NOTES: Next time you update FL Studio follow the procedure above. You may install FL Studio on
any computer/s that you exclusively control.
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HOW TO UNLOCK FL STUDIO WITHOUT INTERNET ACCESS
Download the latest FL Studio installer and FLRegkey file from any computer with internet access
and install it on one without it as follows …
1. Register – Follow steps 1 to 3 above, to register the code from your Box.
2. Download a FLRegkey file – From your Image-Line account left-menu, click UNLOCK
PRODUCTS, then the main ‘unlock image’ to download your ‘FLRegkey.reg’ file. Save it and
the FL Studio installer, to a portable storage device. If you need to email the ‘FLRegkey.Reg’
file to yourself, zip it first.
3. Install FL Studio - Copy the FL Studio installer and FLRegkey.reg to your computer and run
the installer. The install wizard will guide you through the steps. Normally, just accept the
default settings.
4. Unlock FL Studio - Open FL Studio and use the top-left menu to select HELP > About. On
the pop-up panel, select ‘Unlock with file’.
5. Use your key – Browse to your FLRegkey.reg file, select and click open. You must agree to
the Terms of Use to continue. When you see ‘The registration succeeded’ click ‘Ok’ and FL
Studio will close.
6. Restart FL Studio – Your name and license code will show at the top of the HELP > About
panel. The e-mail and password fields are blanked for security.
NOTES: Next time you update FL Studio follow the procedure above. You may install FL Studio on
any computer/s that you exclusively control.

NEED HELP OR HAVE QUESTIONS?

Registration or Account issues – Use http://support.image-line.com/ticketing.

What’s included? - See http://www.image-line.com/documents/editions.html
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WELCOME TO FL STUDIO
This guide is a general introduction to using FL Studio. Press F1 while running FL Studio to open
the on-line manual for detailed help on specific features or functions. The manual will open showing
the last thing you clicked in FL Studio (it’s context sensitive).
Lifetime FREE updates of the edition you own: Customers who bought FL Studio 2 (way back in
1999) have received every version up to 20 absolutely free! That’s about $2200 of free updates. If
you have the Boxed version, register online to activate your Lifetime Free Updates. If you bought
FL Studio via Internet download, then you’re already registered for Lifetime Free Updates.
Our philosophy is that you should pay only for what you use, and we never charge for bug-fixes,
like many of our competitors do. Visit http://www.image-line.com to see what we have on offer.

Here are just a few of the cool features in FL Studio:
-

Recording: Audio (microphones, guitars, synths), automation (knob / mouse movements)
and notes (polyphonic melodies) live, then edit the performance.

-

Easy hardware controller linking: Right-click on the FL interface control, select link and
tweak the hardware controller knob, done.

-

Piano Roll: The most advanced piano-roll in the industry. Per-note slides for native FL
Studio plugins. Complete suite of editing and creative composition tools.

-

Channel Rack: Fast and intuitive pattern-based sequencing, perfect for percussion.

-

Edison wave editor/recorder: Record, analyze, edit and transform audio. With beat slicing.

-

Performance mode: Trigger Audio, Automation and Pattern Clips on the fly to mix, re-remix
and perform your projects live.

-

Share: import/export .wav (wave), .mp3 (mpeg layer 3), .ogg (Ogg Vorbis), .mid (MIDI) files
and more.

-

Fast: Of course there is the legendary FL Studio workflow, the fastest path from your brain
to your speakers!

Lemon Boy is in the house: Hey Dudes! Having problems? Before you panic
and start spamming the FL Studio Tech Support, look for me. I'll pop up here
and there with answers to common problems that might save you some trouble.
Of course, don’t neglect to press F1 inside FL Studio to open the in-line help or
visit the on-line forums http://forum.image-line.com/
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FIRST RUN
OK, so you just finished the installation and started FL Studio. This section explains what you will
see. Don’t forget to check the extensive on-line help that comes with FL Studio (press F1) and
check our ‘Getting Started’ video tutorials:

http://support.image-line.com/redirect/flstudio-start
1.

The System Settings Screen. When you first run FL Studio, you should press F10 on your
PC keyboard to access it (or Options > Audio Settings). Use the select boxes to choose your
sound card and hardware controllers. For now, the most important one is the Audio section,
accessed as shown below.
1. Click Here
2. Then Here

2. Select FL Studio ASIO from the list in the pull-down menu. ASIO modes allow lower CPU
load and shorter buffer lengths (more on why that’s a good thing below) compared to the
Primary Sound Driver. You can always come back to this screen (by pressing F10) and
experiment with other options. If you don’t hear sound, open the FL Studio ASIO driver by
clicking ‘Show ASIO panel’ and select your audio playback device in the Output menu (where
it shows [Default output]).
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3. Buffer Length? You don’t need to worry about most of the settings here yet, but you definitely
should know what the Buffer Length does. The buffer stores audio data from FL Studio before
it's sent to your audio interface. This allows your computer to even out spikes in CPU load, that
can cause audio glitches and crackles. Longer buffers mean lower CPU load and reduced
audio glitching. However, longer buffers can also mean the delay between playing a MIDI
keyboard or tweaking a control in FL Studio and hearing can make FL Studio feel sluggish or
‘laggy’. The ideal buffer with ASIO drivers is between 10 to 20 ms (441 to 882 samples). Some
other things to check…
Is your CPU running at full speed? Do you have some wimpy energy saving/CPU throttling
mode engaged? If you are serious about your music production, then you’ll be prepared to melt
those polar ice caps. While we like Polar Bears as much as the next guy, we are sorry, those
icebergs are just going to have to melt, just a little, for the sake of art. Don't feel so bad, Polar
Bears would eat your head if they had the chance, which they will if the ice-caps move any
closer to the equator. Consider this 'insurance' against Polar Bear plagues sweeping down
from the north eating your loved ones. On Windows - See the Windows 'Start > Settings >
Control panel > System & maintenance** > Power Options'. ** Whether or not this submenu shows depends on your windows settings. Set your power management to 'High
performance mode'.
Smart Disable - Enable Smart disable on the Audio Settings and then run the Tools Menu
> Macros > Switch smart disable for all plugins. This will disable effects & instruments when
they are not making any sound and can significantly decrease CPU usage. NOTE: Smart
Disable is active only during live playback, it is temporarily disabled when rendering (exporting
audio).

The term 'Soundcard' can be confusing. It comes from the days when most
computers had a separate soundcard. These days most use a chip on the
motherboard, or it may be an external device connected by USB. A better
term is ‘Audio Interface’ - any device that makes the sound you hear from
your speakers. The Audio Driver is the software interface between the
operating system and the device. The driver tells FL Studio what
inputs/outputs and what sample-rates the Audio Interface can support.
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4. The FL Studio desktop has a number of windows, most of these are movable (with overlap),
resizable, zoomable and switchable, so if a window isn't visible open it with the Shortcut toolbar or
the function key noted in brackets. The main windows involved in FL Studio music creation are
- Channel Rack (F6), Piano roll (F7). Mixer (F9) and Playlist (F5). The Browser (Alt+F8) is
used to access audio files, plugins & presets (see the Options > File settings to add folders
elsewhere on your computer to the Browser). NOTE: If you ever need to reset the position of all
windows to their default use (Ctrl+Shift+H) or see the View menu options.

Video Tutorials! A picture is worth 1000 words, so a video must be
worth, like, BILLIONS…once you are registered pop over to the FL
website and watch hours of cool video tutorials, this is really useful, so
I’ll SHOUT –

http://www.youtube.com/user/imageline
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MAKE SOME NOISE
Press the Play Button (make sure the switch to the left is in
SONG mode) to Play a project. It’s definitely worth checking the
demo songs. Open the browser (F8) left-click on the ‘Projects’
folder and right-click on the NewStuff.flp, then select ‘Open’ from the menu. You can also drag
the FLP file onto the desktop to open it. FLP files are FL Studio Project files and save entire songs.
Press Play and try to work out how the project was made. Pay attention to the Channel Rack,
Playlist and Mixer panels. Try moving sliders and clicking switches to see what they do.
GETTING HELP
This guide is intended to get you up and running - it is not meant to be a reference manual for
everything FL Studio can do (that’s what the Help system is for, press the F1 key on your PC
keyboard). Let’s look at the main FL Studio components:
1. The Hint Panel. Located on the Main Window just under the Menu Bar (top left in the picture
on the previous page). When you hover your mouse over any of the controls in FL Studio, this
panel will display a short description of what that control does and when you move a control,
it’s value. The Hint Bar also shows you the Shortcut Key that will activate the same function.
This is displayed on the right. Pressing this shortcut key has the same effect as pressing the
corresponding button.

Hint Panel

2. On-line Help. FL Studio also comes with an extensive on-line help reference. Just use the
Help Menu and select Contents. This help also features context-sensitivity – select a window
and press F1 on your keyboard. The reference automatically displays the help you are looking
for. You will notice a SEARCH box on the upper left, try it!
3. The Website. FL Studio has a massive web site at http://flstudio.image-line.com. The site has
a support section that includes a FAQ Knowledge Base, User Forums, Online Tutorials,
Video Tutorials, Song Exchange and more. Check the discussion forums to see if your
questions have already been answered, or log in and post your own.
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HOW TO USE FL STUDIO
The following section will guide you through some of the basic, and not so basic, features you’ll
use to make music with FL studio. You should also spend some time with the in-line help file (press
F1 inside FL Studio) and at least work through the Introduction to FL Studio section. You may
have noticed we keep mentioning that, because no-one reads the manual, but you are reading this,
so we have hope for you 
HEY! Don't skip that step. This guide
will work a lot better if you start at one
end and work your way through to the
other.

THE CHANNEL RACK
The Channel Rack holds all the instruments that create sound and generators that
control automation (page 63). Every pattern has access to all instruments in the rack. In other
words, all patterns play from the same set of instruments. Patterns are not limited to a single
instrument as they are in most other sequencers. Music data can come in the form of Step
sequences and Piano roll scores (page 25).
There is one Channel button per instrument. The audio from each Channel is sent to one of
the Mixer Tracks (page 54) for effects processing and level mixing. When Instrument Channels
are added or removed from the project the height of the Channel Rack will change dynamically.
The Channel buttons also access Instrument Channel Settings (where a Mixer track is set, page
56) or the associated Piano roll. The Channel Rack is a pattern-based grid sequencer ideal for
creating drum loops and simple melodies.
The note and automation data visible across all Channels is known as a 'pattern'. Patterns include
Piano roll, Channel Rack and Automation data. Switch between patterns using the Pattern
selector (page 15). As the pattern number is changed, see how the pattern data in the Channel
Rack also changes. These are the patterns. Patterns are designed to be arranged in
the Playlist (page 30) as Pattern Clips to create your song.
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Open Channel Settings
Channel Settings

Select Channel
Open plugin

Channel Rack

1. What are Channels for? Each Channel is represented by a button (shown above) and
contains a single instrument plugin or sample. Click the button to open the instrument interface.
Channel buttons are usually followed by 16 Step Sequencer steps. If you're musically inclined,
these are 16th notes. If not, think of each group of four steps as one beat, so 16 steps are the
four beats of a basic 4x4 drum loop. You can click and drag on the lower-right corner of the
Channel Rack to show more steps if you need them.

A Channel
Steps, on
and off

Channel
name on
button

Drag here to
see more steps
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2. What are Steps for? Click a step to activate it, this tells FL Studio to trigger the instrument at
that point in the bar or loop. For instance, steps 1, 5, 9, and 13 in the 1st Kick Channel are
selected, telling FL Studio to play the kick drum sound four times during the loop. If you think
of each group of four steps as a single beat, FL Studio will play the sound at the start of each
beat. Try changing the pattern of steps in the Kick Channel. If you need to turn a step off,
right-click it. Once you've got the steps to light-up like the picture below, press the play switch
to hear what you've created.
A pattern
Selector
Mute, Pan &
Volume

When programming patterns use pattern
mode. FL Studio will then play the selected
pattern.
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3. How do you use patterns? While it’s cool to make a bunch of patterns, it’s not particularly
useful to play a single loop over and over. The idea is to place these patterns in the Playlist
(page 30). All the note & step data visible in the
Change pattern
Channel Rack is known as a 'pattern'. You can
switch to a new pattern with the Pattern selector
panel on the Tool Bar or use the Picker Panel.
When you do this, the data visible in the current
Pattern will change to show the selected
pattern. To hear only that pattern (rather than
the whole Playlist) make sure the switch at the front of the Transport Panel is in ‘Pattern’ mode
(lit). Once you have made a bunch of Patterns, select the pattern using the pattern selector (or
the Playlist Clip selector), then left click on a blank area of the Playlist (use the pencil ) to
place it in the Playlist as Pattern Clip. NOTE: Be aware Snap
controls how Clips can be
moved and placed, Line mode is usually best as it changes snap sensitivity with Zoom level.
4. Play with the Channel Controls. After you've set up the pattern, try playing with the Channel
Controls on the left. The two round knobs control the pan and volume of each Channel. Pan
moves the sound from left to right in the stereo field. The green box to the right of each button
switches the Channel on and off. To reset a knob to its default position, right-click it and select
‘reset’. If you move these controls while Record and Play are activated you can record their
movement, we call this ‘Automation’, more on page 63.
5. Make Your Own Beat. Don't like the beat above? Good, you have taste! It’s time to make your
own beat. In the following sections, we'll teach you how to load new samples, set up melodies,
and change the sound of each Channel (and even each step).
Learn what
‘Snap’ does

Use pencil or
brush mode

Play here

Arrangements are like
multiple Playlists

Select Patterns, Audio Clips
or Automation Clips
Click in the Picker Panel to select a Pattern OR drag-and-drop
to the Playlist
Left-click on the blank areas to
add the selected pattern
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HOW TO USE SAMPLER CHANNELS
In this section we'll show you how to modify the sound of the samples in each Sampler Channel.
FL Studio supports so much of this kind of tweaking that it's possible for two people to create totally
different sounds using exactly the same samples. Technically, each Channel contains an
Instrument, which could be a sample player or a synthesizer plugin. While there are dedicated
samplers like FPC (for percussion) & DirectWave (for instruments), the Channel Sampler is a
versatile and useful tool, so let’s look at that in more detail.
Wait! What's a "sample"? A sample is a recorded sound stored
in a file. Each Channel in FL Studio, by default, uses a single
sample, usually containing a single sound (like a snare drum), but
they can also contain entire beats (loops) or songs. Samples are
usually ".wav" format files but FL Studio supports ".mp3" and “.ogg”
sound format too.

1. Load a New Sample from the Browser. One way to load samples is to use the Browser.
This is usually on the left, although you can move it. To find a Kick sound, click on Packs >
Drums > Kicks. Left-clicking on a sample in the list will play it, right clicking will open it into the
selected Channel. You can also drag and drop samples onto the Channel Rack. Select a
Channel by clicking on the green Channel Selector light to the right of the Channel Button.

Click here
Here

Lost the Browser? No problem. The big
buttons on the tool bar shown below will
open and close various windows for you,
including the Browser & Step Sequencer.
(They will become clear in the fullness of
time…)

Here

Open Browser

Finally here
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2. Open the Channel Settings Window (left-click on a Channel button). OK, let's modify the
kick drum sample. Load a Kick sound (shown below) and open the Channel Settings. You
can also change samples using the Open file icon to the right of the Sample Name (as shown
below) or use the Show in browser icon to show the location of the kick drum samples. As
you click on them, FL Studio will automatically play the sounds. Try opening some of the other
samples and listening to the effect a new kick drum has on the sound of the loop.

Click
Here

Show in Browser

Channel
Selector

Open file

Can't hear the difference? If you press a button or turn a knob and
you can't hear any difference in the sound, try making the same change
on another Channel. For example, sometimes a change that doesn't
affect a kick drum much will make a huge difference to the sound of a
snare. If you still can't hear the difference, stop the loop from playing
and listen the sounds separately by clicking on the wave view window.
You might be able to hear the effect better without the other
instruments.
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3. Play with the Sampler Channel. It’s worth noting that FL Studio can add audio effects on
Mixer tracks (set by the FX selector), but this section is to show you the power of Channel
sampler effects. Ok, at this point the best advice is to start the pattern looping, then play with
the controls in the sample panel of the Channel Settings Dialog and listen to the difference in
sound. Here's a short description of what some of them do. For more info see the on-line help.
Open sampler options

Vol, Pan: These knobs that also appear
on the Channel Rack.
Track: This control sets the Mixer track
used by the Channel. Click TRACK to
auto-assign to a Mixer track where you
can add effects.

Wave View Window: Shows the shape of the
sound sample. Click here to hear the sample with
all the effects. Also, a drag and drop window for
loading samples. Right-click too!
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4. Play with the Instrument Settings. Let's take a quick look at the Instrument panel before
we move on. Click on the Instrument settings tab . Here you can adjust Envelopes and
LFO to your sample for the Volume, Pan, Cutoff, Resonance, and Pitch settings.
Select this switch to activate the envelope

Open instrument settings

Control target selector
LFO

Envelope

You won’t hear LFO unless amount is set

Right-click along this bar to set the natural pitch (root note)
5. What's an Envelope? An envelope causes a parameter to vary over time. The most common
is the Volume Envelope that changes volume over time. That’s over-the-note-duration not
over-the-whole-song (use Automation for that). You can also set envelopes to affect Pitch,
Cutoff, and Resonance. In terms of a volume envelope (Volume), the Delay sets how much
time passes before the envelope starts, Attack (ATT) is the fade-in time, Hold sets how long
the sound holds at full volume, and Decay (DEC), Sustain (SUS), and Release (REL) control
how the sound fades away. Play with the knobs and watch the graph change above them.
6. What's LFO? LFO stands for Low Frequency Oscillator. It’s like an Envelope but repeats a
waveform pattern over and over while a note is held. Commonly LFO is used to make pitch
oscillate up and down over the duration of the sound (vibrato). The Amount (AMT) sets how
much the effect oscillates, Speed how quickly it oscillates, Delay sets how much time passes
before the LFO oscillation starts, and Attack (ATT) sets how quickly the oscillation ramps up
to its full amount. Play with the knobs and watch the graph change.
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7. How do I Use Them? Use the Target Selector (see diagram above) to choose the target then
turn the knobs on either the Envelope or the LFO. REMEMBER to turn the Envelope on and
off for each effect (click the switch as shown). To turn off the LFO, reset the Amount (AMT)
to the middle so the knob pointing straight up.
8. Why Can't I Hear the Effect? If you're still on the Kick Drum it will be hard to hear any LFO
effect, although the Envelope might make a difference. These effects are more audible on
longer samples or on sustained instrument sounds such as 3OSC.
9. Play with the Misc settings . These functions work by automating note or MIDI data sent
to the plugin on the Channel. The echo for example sends out repeated notes with successively
lower velocity (volume). Cut groups are particularly useful as they can allow you to create
realistic percussion parts, like a closed hi-hat Channel stops an open hi-hat Channel. So one
sound on one Channel can stop another. The ‘By’ number is the one a Channel will listen for
to stop itself. The Cut channel is the signal the Channel itself sends. Notice, Cut itself, sets
both to the same number. When you load a synthesizer plugin the Arpeggiator is a lot of fun.
Click the up-arrow to the left of the Arpeggiator label and hold down any 3 notes and listen to
what it does.
Cut groups can be useful
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When you left-click on a Channel button, the Channel
settings will open along with the plugin interface. You will
find that some of the Channel settings controls may not
have any effect on the sound, this is normal. Generally, for
plugin instruments the Channel settings FX selector is used
to send the audio to a Mixer track. One tab on the Channel
settings that is cool with Plugin Instruments however is the
FUNC (Function) tab. Experiment with the Arpeggiator,
great for playing live with a MIDI keyboard.
Now we're cookin' with gas! …or is your PC on fire?

MIXER TRACK ROUTING
Every Channel in the Channel Rack can be sent to any Mixer track. There’s over 100 to choose
from, so you shouldn’t run out soon. The routing control is under the Channel Settings as shown
below. You can Auto assign a Channel to a Mixer Track by clicking the word TRACK below the
number indicator. Manually assign by click and drag on the indicator or even drag and drop
plugins on a Mixer track from the Browser or Plugin Picker (press F8). More on that later (page 54).

Signal flow from Channels to the Mixer
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STEPSEQUENCER & NOTES
By now you're familiar with some of the ways FL Studio lets you tweak the sound of Sampler
Channel. In this section, we'll show you how some of those effects can be applied to each step or
note separately. Later we'll also show you how to program melodies in the Piano Roll (page 24).
Step vs Piano roll
preview

Right-click to
open the
Piano roll

Select a target to edit

Drag these bars up and down edit

1. Piano roll steps. If you right-click the channel button for the sample, you will get the Piano
roll for that Channel. The Piano roll will show the steps as notes on note C5 aligned with the
grid. Below the note area you can see the vertical lines with circles on top. These show the
value of the target set by the note property selector. Try replicating the Hat pattern above
and notice how much more interesting it sounds when you change the velocity (volume) of the
steps as shown.
2. Target selector. You will see Pan, Velocity (another name for Volume), Release, Filter
cutoff frequency, Filter resonance (Q) and Fine pitch. Though some of these effects were
discussed in the "Tweaking the Channels" section, the difference here is that you can also
tweak the value of these effects for each step separately. Each bar on the Piano roll lower
section sets the value for the single note above it.
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3. Panning the Kick Drum. Try setting the pan effect as shown below. The pan graph centers
in the middle. You can set pan values by clicking above and below the middle of the lower
window. After you have set up the view shown below, you should hear the kick drum flipping
back and forth from one speaker to the other.

4. Play with the Other Effects. Filter Cut and Filter Res can be used to add or subtract values
to the main cutoff and Resonance knobs in the Instrument settings panel of the Channel
settings dialog box. See the "Tweaking the Channels" section. Pitch makes the sample higher
or lower, like the pitch knob in the Channel settings dialog box.
5. Make melodies. Use the Piano Roll (page 24) for composing melodies. This will work best
with Synthesizer plugins, we show you how to load those on page 33. You probably also
noticed you can load both Step and Note data in the same pattern. It’s possible but it’s better
to keep beats (percussion) and notes (melodies) in separate patterns. If you make a mess and
add in too many Channels to the one Pattern, there’s a useful menu option: Split by channel:

23

Super Important Tip. When you want to play repeated longer samples, you often need to set it up
so that each new note cuts off the previous one so they don’t overlap and make a mess. The easiest
way to do this is by right-clicking the Channel Name in the Channel Rack and selecting Cut Itself
from the popup menu.

Remember there are also a Group > Cut and Cut by options (page 20) under the Miscellaneous
channel settings? You can go even further and cut one or more Channels by another. The ‘By’
option decides what Cut group number will cut activity on the selected track.

Big News! You can undo the last tweak from
the Edit Menu or with CTRL Z. There is also an
‘undo history’ in the Browser directory called
‘Current project, History folder. Click up and
down the list to un/re-do changes. Make sure
F10 > General Settings > Undo knob tweaks
is selected.
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THE PIANO ROLL – NOTES, CHORDS & MELODIES
So you have probably already realized that there are some things that the Step Sequencer doesn't
do. You can’t use it to make melodies or to play chords. The Piano roll solves all of these problems!
Open the Piano Roll. Load up NewStuff.flp and select a pattern that shows some green bars as
shown below. Notice that the Channel Rack view is very different. These Channels contain Piano
Roll data instead of normal steps. You can open the Piano Roll for any, Channel either by rightclicking the Channel name or by left-clicking the Mini Piano Roll.

Right Click here
Then click

or Left Click Here (Mini Piano Roll)
1. What You're Looking At (next page). See the Play Indicator Bar, the Edit Mode Buttons,
and the Edit Menu Button? These are important tools. Each horizontal green line shows
where a note starts and ends. The Piano Keyboard on the left shows the pitch of each note
(you can click that too). Remember we looked at ENVELOPES earlier? These are also
important as they interact with note ON (where an envelope starts) and OFF (where the note
release section starts). If you don’t have any envelopes set then the sound will probably start
but not stop when the note stops. Also keep in mind, synthesizers and other instruments will
have envelope sections of their own, and the Channel Settings envelopes won’t have any effect
for these.

Watch where you click! The mini view Piano roll in the
Channel window has a cool feature, that for long Piano roll
scores it will open the Piano roll at the location where you
clicked. Super-duper!
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Menu

Local
Snap

Edit Mode
Buttons

Change
Channel
here

Vertical
Zoom

Mode
Drag here for Horizontal
Drag here for Horizontal Zoom
position
Play Indicator
Drag here for Vertical position

Change lower Piano Roll note
data editor target here

Velocity (volume)

2. What’s with the lower Piano roll window? As we saw earlier, the lower window allows you
to adjust all sorts of per-note parameters such as note velocity, pan and also Channel
automation. If there is any Event automation (see page 66) in the pattern that the Piano roll is
part of, you can select that too and edit it in the lower window, just like in the Event editor. Even
more lazy? You can use the Channel selector to change Piano rolls within the pattern (“Change
Channel here’ above).
3. What Kinds of Channels Can Have Piano Rolls? You can have a Piano Roll for any type of
Instrument. Sustained notes will always work best when you are using Looped Samples &
Synthesizers. Loop points that let the sample play over and over again to create a sustained
sound that lasts as long as the note is held. If you don't have a looped sample, you can still
use the Piano Roll, but remember your notes may not last as long as you wanted them to.
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Man, this thing
just keeps
getting' better!

Using Loop
Points

Red lines are loop start/end points. You can set or edit them
in Edison (right-click the waveform and choose ‘Edit’)
4. Basic Piano Roll Editing
Piano roll Snap - You may find the note snaps to a place you didn't want it to go. If so,
change the Snap setting on the toolbar. Sometimes you just can't get the note length to
snap where you want no matter what you do. In this case, hold the ALT key to override
snap and drag the note.
Draw mode - Click on the note area, where you want it to start then release. Next grab
the middle of the note and drag it up/down. If the project is not playing, you should hear
the note you are entering as you drag it around. The length of the note will match the
length of the last note you placed or clicked. To change the length, grab the right-hand
side of the green bar and drag it. Right-click to delete notes. Modifier keys: (Shift) add
in stretch mode. (Ctrl) to make a selection. (Alt) to add in pencil mode with snap set to
'none'.
Delete - Click or Click-and-drag to delete notes. Right-click and hold on the background
to open the slice tool (F10 > General settings > Click and hold functions on). Modifier
keys: Hold (Ctrl) to make a selection, then press (Delete) Undoing Changes. Like the
Event Editor, there is a limited undo available from the Edit Menu or by pressing Ctrl-Z.
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Select (E) - Click notes or Click and drag to make group selections. Modifier
keys: (Shift) add to or remove notes from the selection.
Zoom to selection (Z) - Left-click and drag to zoom to selection. Left-click on
background to zoom out.
Play / Pause - Left-click to start/pauses playback. Right-click (while playing) to stop
and return to the last set start position. Right-click (while stopped) to return the play
head to the start of the Piano roll. NOTE: There is an option on the Right-click main
transport Stop button ‘Remember seek time’ for the start position to be remembered.
Note Colors. See the colored area beneath the spanner icon? Click it, this let you select the
color of the notes you enter. This may not seem useful now, but color-coding can really help
you out when you're trying to make sense of the notes you entered. Plus, the Edit Menu lets
you Select by color, so you can delete or copy and paste only those notes. Better still, note
colors allow you to control different MIDI Channels (see the main help in FL Studio, press F1).
5. Chords and Harmonies. One of the really nice features of the Piano Roll is that you can have
notes sound on top of each other to create chords and harmonies. Here, we're getting into
stuff that you need a musical ear for, but FL Studio does make life a little easier by giving you
a Chord stamp tool
- Select the type of chord you want, and click it into the Piano roll.

Overlapping
notes/chord

6. Pitch-Bending Notes. This is really cool, but only works for FL Studio native plugins such as
MiniSynth (to pitch bend VST instruments you can automate the pitch knob for the Channel it’s
loaded into, see Event automation, page 63). If you click on the Slide Icon in the top left just
under the Edit Menu Button, you can insert pitch-bending notes (also called Slide Notes). To
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see how this feature works, place a long note on the PR, and then place a slide note above or
below it. Make sure the two notes overlap. The long note will play until it reaches the slide
portion. Then the pitch will rise towards the Slide Note and stay there until it reaches the end
of the original note. The longer the Slide Note, the longer the slide (see example next page).

Slide
switch
Note
Starts
Slides
Up
Slides
Down
Stops

7. Tweaking the Notes. Don’t forget you can individually change Volume, Cutoff, Resonance
and so on for each note in the bottom part of the Piano Roll Editor. Every time you enter a
note, you get a spike in the bottom graph that shows the level of the parameter selected by the
drop-down box on the left (labeled Event Select above). After you enter the notes, you can
change the values of any of the parameters by grabbing the top of the spikes and dragging
them. The horizontal line shows note length. You can set Velocity, Pan, Cutoff, Resonance,
and Pitch. As an added bonus, you can also use this graph as the Event Editor for Channel
Pan, Pitch, and Volume. NOTE: You can also change any note’s properties by double-clicking
it.
8. Importing MIDI Tunes. In the File Menu under MIDI, you'll find two methods of importing MIDI
sound files directly into the Piano Roll Editor. There are tons of MIDI files for various popular
melodies floating around out there. Now you can suck them directly into FL Studio and use
them in your songs. How cool is that?
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THE PLAYLIST - FROM PATTERNS TO SONGS
Now you've seen the basics of what can be done with a single pattern, we'll show you how to
program more than one pattern and link them together into a complete song.
1. The Pattern Selector & Picker Panel. FL Studio lets you create 999 different patterns of any
length. You can access the other patterns by changing the number in the Pattern Number box
or use the Picker Panel located on the left side of the Playlist (see next page). Use your mouse
to drag in the Pattern Selector. You’ll find it on the tool bar at the top of the main FL Studio
window. Right-click the pattern selector to show all patterns with data in them.
Pattern selector

Pattern/Song mode
2. Check out the Playlist (next page). This screen can be opened either using the button under
the hint bar, by hitting F5, or by right-clicking the song/pat button on the main screen (see
above). Try it, and you should get a new window that looks something like the one shown
below. The Playlist sequences (plays) Pattern, Audio and Automation Clips. Unlike most other
sequencers, the Playlist tracks are not bound to a single instrument, audio recording or even
Clip type. You can put any Clip type anywhere and even overlay Clips. Think of Clips as a
little like notes in the Piano roll. When the play-position reaches a Clip, FL Studio plays
whatever the Clip instructs it to do. This also means Playlist Clip tracks are not bound to
Mixer tracks, rather Channel Rack to Mixer routing of instruments decides the Mixer track/s
that are used. Try it - Make sure Song is selected and press Play. You should see the Play
Indicator on the Playlist start to move, and hear the patterns it is playing (use the NewStuff.flp).
When the indicator reaches the end of the Clips, it will jump back to the start of the song or
Song loop point and continue playing. If you switch to Pattern mode, FL Studio will just
repeatedly play the current pattern in the Channel Rack.

The Playlist can hold notes (Pattern Clips), automation or
‘remote control’ (Automation Clips) and audio (Audio Clips).
It’s all about CLIPS! What’s cool is that any track can hold any
Clip type. The Picker Panel holds all these Clip types.
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To add Clips, drag from the ‘Picker Panel’ to an empty area of the Playlist.
3.

What's the Point? Now you can assemble a number of patterns together to make a song.
This lets you alter melodies, change beats, insert fills, and reuse some of the early parts of the
song later. The clip tracks show information about the data patterns & clips contain. The It’s
up to you how you want to work but many composers use separate patterns for drums, bass,
lead, etc. so they can work on them separately at first, and then piece the song together in the
Playlist. A good way to see the Playlist used ‘full-on’ is to see the NewStuff.flp or flp’s in the
‘Cool Stuff’ folder in the browser.

4. Data types: Each Clip track can hold unlimited number of Automation Clips, Pattern Clips and
Audio clips. To add a new instance of a clip select the clip to paste using the ‘Picker Panel’ (at
the left of the Playlist) and then click in an empty place inside the tracks or you can drag-anddrop. Try moving the waves or cutting them with the slice tool. You can find more tutorial
projects explaining how to use them and also plenty of information in the on-line help (focus FL
Studio and press F1). See more info in the chapter Audio Tracks. You can apply automation
envelopes (e.g. to fade the volume in/out on an audio clip) on top of these audio clips.
I get it! The Playlist has a bunch of general purpose ‘Clip tracks’ the controls to the
left of the tracks are for naming and muting. Then the musical notes, sample and
automation data can be laid out in any of the Clip tracks (they are not fussy about
what they contain) easy…I think… what was that again?!
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AUDIO, PATTERNS & AUTOMATION CLIPS - EDITING

FL Studio Producer Edition lets you work with Audio, Pattern and Automation Clips. Fruity
Edition does not include Audio Clips.
To place an audio/automation & Pattern Clips, switch to draw or paint mode and left-click in an
Clip track. You can also drag a sample onto the Playlist and an Audio clip will be automatically
created. Brush mode allows you to draw multiple instances of the audio clip at once (hold the mouse
button and drag).
To erase a clip, click it with your right mouse button or use the left mouse button in erase mode.
To switch a clip instance to play another, open the clip menu (left-click the arrow in the top left
corner of the clip) and from the Select Channel menu, pick a replacement Clip.
To open the Channel Settings of the Channel associated with the clip instance, open the clip
menu and select Channel Settings.
To audition an Audio clip select Preview from the clip menu to listen to the audio clip sample (hit
the Stop button in the Transport panel to stop the preview).
Automation Clips (see page 69) can automate any editable parameter over the complete song
(instead of Event based automation). A common use of these Automation Clips is to make a fadein/out for an audio clip by automating its volume. However, the use of Automation Clips has a much
bigger scope than controlling the clips volume. Feel free to experiment with its use. Use the
appropriate switch to switch between Audio clips, Automation Clips and Pattern Clips handling.
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PERFORMANCE MODE
Performance Mode allows you to trigger Clips from the Playlist. You can use a mouse on the
Playlist, the typing keyboard or a controller to trigger Clips. The purpose is to create new live
performances or remixes of a projects Clip content (Audio, Pattern & Automation).
Performance mode works by treating the area before the Start Marker as a 'Performance Zone'
that allows Clips to be triggered out of sequence between tracks. One Clip can play per track, so if
you need more simultaneous Clips, use more Playlist tracks. Record mode determines whether
performances are recorded and laid out after the Start marker for later rendering.

There are LOTS of keyboard shortcuts and tool modifier keys that make working with
the Playlist really fast. For example, you can hold the Shift key while using the Pencil
or Brush tool and their action will swap with each other. You can also hold the RightShift key and click to slice a Clip OR hover your mouse cursor and press the Insert
key to do the same. The Alt key releases snapping while you hold it. Press F1 and
check the manual for more!
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INSTRUMENTS - FROM SAMPLERS TO SYNTHESIZERS
Until now we've only been playing mainly with Sampler Channels. Useful but fairly basic as far as
sound generation goes. FL Studio also supports Channels that contain sounds made in real time by
software synthesizers like MiniSynth, GMS, 3xOSC, Harmor etc.. To use the proper terminology,
every Channel contains a plugin Instrument, sometimes more broadly called a ‘generator’ as some
generate automation data rather than sound. Instruments can either be a sample (in a Sampler
Channel, FPC etc), a synthesizer plugin, or some other type of instrument in combination with the
effects in the Channel Settings window. The combination of these Instruments with the sample
Channels gives FL Studio unlimited sonic potential.
1. Adding a Synthesizer Channel. There are many ways to do this. You can use the Add menu
or open the Browser > Plugin database > Generators and drag a plugin from there and drop
it on the Channel Rack or Mixer track. You can also download and install many FREE VST
instrument plugins from the web too.

Click the Plugin
Database and
drag-and-drop
Synths on a
Mixer track or
the Channel
Rack.

Click here to load a new
Instrument Channel

2. What to Expect. The new Channel button will appear in the Channel Rack and the Instrument's
graphical user interface (GUI) will appear when you click it.
3. How Do I Use them? It's important to know that most Instruments have their own help.
Pressing F1 in FL Studio will open the help to whatever was last clicked (FL Studio, a window
in FL Studio or a Plugin). If you are new to music production we would suggest starting with:
3xOSC, MiniSynth and GMS (in that order). These can be used to make just about any
professional sounding synth sound you can imagine BUT are simple enough that you won’t be
tearing your hair out. NOTE: Not all instruments are included, some are demos. BUT don’t
worry there are heaps of free ones (in fact most are). If a plugin says DEMO along the top of
the window, then it’s an additional purchase.
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Preset Sounds

4. Preset Sounds. Most synthesizer instruments have preset sounds available. In most cases,
you can get to them from the Preset selector controls by clicking on the little arrows on the
top right of the plugin window (right-click to see a big list) OR if that doesn’t work, use the
Plugin user interface. You may need to look around carefully for something to click, like the
preset selector on MiniSynth (above right). Just look for something that shows the name of the
sound in use (there’s usually arrows to show something can be changed).
5. How can I buy the demo instruments? Go to www.image-line.com > Shop. From there you
can choose plugins to buy.
6. What plugin instruments are available? See below:

My brilliant adlib performance! FL Studio
has a rolling recorder that captures all
keyboard performances. It’s always on, so
never lose that amazing adlib. Check out the
Tools > Dump score log to selected
pattern feature!

35



3xOsc (included) - This is a plain instrument that allows you to mix three Oscillators,
each of which generates a tone. The sounds on their own are not exciting, but they
are good raw material to be combined with INS panel effects and other plugin effects
(explained in a later chapter) and it’s a great place to start if you are new to synthesis.



Autogun (included) - is a universe of sounds waiting to be discovered. Based on the
Ogun synthesizer engine and Soundgoodizer effects processor, Autogun contains
4294967296 presets (Four Billion Two Hundred Ninety Four Million Nine Hundred
Sixty Seven Thousand Two Hundred Ninety Six), most previously unheard by man (or
woman, are there girls here? quick get their phone numbers!).
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BassDrum (included) - is a flexible Bass/Kick drum synthesizer with sample-layer
support. Get ready to rumble...your neighbors!



BeepMap (included) - This is a weird one. Takes a bitmap image file and turns it into
a sound, with strange and wonderful results. This is the same kind of synth that Aphex
Twin used to embed an image of himself in a track that shows up when the track is
put through a spectrum analyzer.



BooBass (included) - A handy little bass instrument from the guy who brought you
SimSynth.
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DirectWave (player version included) - A powerful sampler featuring a fully
programmable synthesis section, with all the usual sampler goodies. DirectWave can
also 'sample' (record sound) when loaded into a Mixer track on an effect slot.



FL Keys (included) - A realistic piano simulator with optimized CPU and memory
usage.
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FL Studio Mobile (included*) – Is a complete music production environment that
works as an App on Android, iOS and Windows platforms plus as an FL Studio *native
plugin. In this way you can work on your mobile projects while on-the-go then continue
in FL Studio and take them to the next level.



FPC (included) - A software plugin similar to the hardware Akai MPC unit, coded &
optimized for the FL Studio platform. FPC is a self-contained multi-layer/velocity drum
machine that makes it easy to create, edit and swap drum kits on the fly. FPC supports
16 multi-layered patches for banks A and B.



Fruit Kick (included) - A kick drum instrument.
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Fruity DrumSynth Live (included) - A Drum Synthesizer plugin that lets you define
drum hits and control them via a keyboard.



Fruity DX10 (included) - An 8-voice polyphonic (that means 8 notes at once) FM
Synthesizer. This one’s designed to give high quality sounds without eating up too
much CPU.
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Fruity Envelope Controller (included) - Allows you to trigger envelopes that may
be linked to parameters in FL Studio. Includes an envelope editor, similar to that
used in Sytrus and FPC.



Fruity Granulizer (included) - This one helps you get cool, choppy and strange
sounds out of your samples.
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Harmless (Signature) - Performs subtractive synthesis using an additive synthesis
engine. All sounds complex but it’s an easy synth to get great sounds out of.



GMS, Groove Machine Synth (Included) - Groove Machine Synth is multitimbral
hybrid synthesizer & FX channel from Groove Machine.
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Harmor - Just like its predecessor Harmless, Harmor is powered by a powerful
additive synthesis engine. Its modules will look familiar to subtractive synthesizer
enthusiasts: oscillators, filters & phasers. These are featured in Harmor but, because
they are performed on additive synthesis data, rather than audio, offer more freedom.



Morphine - A powerful Additive Synthesizer with a logical, flexible architecture that
allows you to create any sound. You can do this directly by adjusting harmonics
manually or by taking any input sample and resynthesizing it into one of 4
independent voices.
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Ogun - can produce exceptionally rich metallic and shimmering timbres, although it's
not limited to this genre. Ogun’s distinctive synthesis engine can generate more than
32,000 harmonics, modulated by high-level ‘harmonic mapping’ functions, that hand
tonal control directly to the user.



Toxic Biohazard - Features a hybrid synthesis engine, combining the best of FM
and Subtractive synthesis. With warm, analog-modeled filters and set of built-in
effects, Toxic Biohazard is convenience, simplicity, and superb sound quality.
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Fruity Keyboard Controller (included) - An automation control which makes no
sound of its own, but can be used to control knob and sliders within FL Studio, by
mapping note pitch and velocity from the Piano roll or Channel Rack to any
automatable parameter or third-party plugin.



Fruity Slicer (included) - This one lets you slice up a beat and then play back
individual drum hits using the keyboard. You can make cool breaks really quickly
with this tool.
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Poizone - A subtractive software synthesizer designed to bring you professional
quality results, without a learning curve that hinders your creativity. The concept
behind PoiZone was to design a synthesizer that had the smallest number of controls
while providing the maximum flexibility and features



Plucked! (included) - A synthesizer that produces specialized stringed instrument
sounds like guitars, harps, mandolins, etc.
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Sawer - is a vintage modeling synthesizer that can cut through a mix with precisely
articulated and punchy sounds.



SimSynth Live (included) - A fully functional digital synthesizer. Use this baby to
create phat-sounding analog sounds for your dance and trance tracks.
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Slicex (Producer) - Uses advanced beat detection algorithms to slice
song/percussion samples into pieces and make them independently playable from the
Piano roll or controller. If the wave file contains slice/region data, this will be
automatically used instead of the beat-detection algorithm. Slicex offers playback,
reordering of slices and time-stretching capabilities optimized for drum loops.
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Sytrus (included) - Sytrus is one of the most versatile synthesizers in the FL Studio
armory, combining Frequency Modulation (FM), Ring Modulation (RM), plucked
string modeling and subtracting synthesis, and featuring a powerful envelope editor.
The synth includes a powerful editable unison mode and a comprehensive effects
section.



Transistor Bass - A subtractive synthesizer in the style of the legendary Roland
TB303™ Bassline synthesizer.
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WaveTraveller (included) - Create realistic scratches with a full control over the
smallest details!



MIDI Out (included) - This one isn’t an instrument either. It lets you send a MIDI
controller signal to an external (or internal) MIDI device.



Speech Synthesizer (included) - This is a wizard to add synthesized speech lines to
your song (see page 53).



Others - There are a few other instruments, see the FL Studio Help (F1).
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7. Installing VST plugins – You can download even more synths and effects. Generally you can
use the default installation folder OR you can set a custom Options > File settings > VST
plugins extra search folder. VST installers usually ask you to select the install location during
the process. However, if you need to set custom VST search folders, use the Options > File
settings > Manage plugins dialog:

7.1. Scan for installed plugins - After installing the VST plugin/s, we recommend the
'Options > Files > Manage plugins > Start scan + Verify plugins' option as this correctly
sorts plugins into their Installed > Effects or Generators (Instruments) category. This is
important as this ensures only the correct plugin types are shown at the various 'add
plugin' locations in FL Studio. E.g. the Channel Rack > Menu > Add one option,
Channel Rack + button and Main menu > Add option, FX slot menu etc. For example,
'Verify plugins' avoids effects showing as load-options in the Channel Rack and
synthesizers showing as load-options in the Mixer FX slots. You can categorize them
with the 'Favorite' process as shown below.
Browser Menu
Plugin Database
Pattern/Song
mode plugins’
Right-click
to ‘Manage

Your plugins

Newly found VSTs folder
Newly found VST

7.2. Making favorites - To categorize a plugin (generator/effect) and make it a 'favorite',
available in the Plugin database, Plugin picker & Plugin list menus, open the Browser
> Plugin database to the category and folder where you would like it to be placed and
select 'Add to plugin database (flag as favorite)' from the plugin wrapper menu, shown
below. NOTE: The plugin database is a standard folder on your disk, so feel free to
reorganize and or create/delete categories using any file manager. Just right-click the
browser Plugin database item in the Browser and select ‘Open’.
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8. The VST wrapper. When you are using a VST plugin there are some extra controls under the
VST wrapper settings (6, below). 1 = Wrapper menu. 2 = Channel Settings, 3 = Preset selector,
4 = Close/Minimize interface, 5 = Plugin user interface, 6 = Wrapper settings (useful to set
multiple outputs or whip misbehaving plugins into shape). 7 = Channel Misc Settings.
Unfortunately, there is just no way for FL Studio to tell the difference between FX and Synth
plugins, so you’ll just have to remember which is which. If you try to open a VST Plugin and
all you get is an error message and the empty wrapper, then it was probably an FX plugin.

9. Why do I see demo plugins? We fund the lifetime free updates program partially by selling
additional plugins to our loyal customers, so yes, we like to show them off in the default FL
Studio installation. By purchasing additional plugins, you support not only Image Line Software
but the whole FL Studio community. Go to http://flstudio.image-line.com for more information
on where to send your hard-earned cash.
You can check if any plugin is a demo by looking at the top of the window holding it. If it is,
there will be (demo) after the plugin name. You can also press F1 and look at the manual entry.
Demo plugins have a large D after the title. NOTE: You can save projects with demo plugins,
after seeing the demo warning, so these can be opened later after you purchase the plugin/s,
so nothing you do with a demo plugin need be lost.
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10. Where Can I Get More? There are literally thousands of synth & effect plugins out there to
download. Some of them are free, and some you have to buy. Search the web and
http://www.image-line.com for deals.
A place you should definitely bookmark is
http://www.kvraudio.com they have a huge site with details about every VST plugin you could
possibly want.
Don't deny yourself, dude! You need all the Instruments. Save up your
squeegee money and buy them ASAP. Probably the one that will make the
most difference to your tracks is Sytrus and while we are on the topic,
don’t forget Maximus effect, this Maximizer plugin rocks!

11. Speech! Yep, you read that right. You can have a conversation with FL Studio using the builtin support for speech synthesis. The easiest way to access this feature is to look under
“speech” in the Browser, and drag one of the files there onto the Channel Rack. You’ll get a
dialog that looks like the one below. All you have to do is replace the text, choose a personality,
style, rate (speed), and pitch. Click the speaker button after the sentence to hear what it sounds
like. When done, click Accept and a sampler Channel will be added. You can also drag a
speech file into a Granulizer, Fruity Scratcher, or Fruity Slicer Channel. Have fun!

You might have to spell some words strangely to make it sound ok.
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MIXING & EFFECTS
One great feature of FL Studio is the Mixer. From here you can mix Channel Rack instruments and
make any arbitrary link between Mixer tracks to create complex mixing chains. Take a deep breath!
One of the best features of the Mixer is that you can add effects to the sounds coming from the
Channel Rack instruments. Effects can range from a simple volume changes to more advanced
effects such as compression, chorus, reverb, phaser, delay, flange, and EQ, among others (you
can also add notebooks, controllers, monitors and all kinds of other goodies!).
Open the Mixer Window. Bring up the Mixer screen by pressing F9 or by going to View > Mixer.
You'll get a window like the one below…

What are you looking at? All audio in FL Studio passes through the Mixer. Unless specifically redirected, newly added Instrument Channels are routed to the Master Mixer track. There are
125 Insert tracks for receiving input from plugins and external audio inputs, 1 x Current track for
hosting tools like Edison (page 71) and Wave Candy and a Master track for master effects
processing. The Mixer has three docks for tracks (left, middle and right) and can be stretched
horizontally or vertically by clicking the edges and dragging. In combination with the layout
options (on the Mixer layout menu), the controls visible will change to suit the Mixers size. To see
tracks outside the current view, use the Track Scroll Bar below the 'Send' switches OR roll your
mouse wheel over the track names. Select a track by Left-clicking the pan or fader controls. Select
multiple tracks by holding (Ctrl+Alt). Selected tracks are highlighted with green faders (track 1
above is selected).
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The Track Inspector panel shows the properties and effects for the selected track. Controls
include a 3 band parametric equalizer, audio Inputs and Outputs (from and to your soundcard) and
Plugin Delay Compensation Controls (PDC).
Turn Plugins On and Off / Mixing Wet and Dry. Click on the green LED to the right of each
plugin slot to turn it on and off. Try this with the loop running to hear the difference. You can also
tweak the knob next to the LED to mix a “dry” (without effect) and “wet” (with the effect) sound.

Select Plugins. To load an effect plugin, choose a free slot and open the effect slot menu on that
slot and select a plugin from the Favorites list. At the top of the menu there are also options
to Open the plugin picker (FX are on the right), Browse plugin database etc, if you need to
access plugins not yet set as Favorites. NOTE: Once an effect is loaded on any slot in a mixer
track the FX icon will light orange on that track to let you know effects are loaded (clicking on the
FX icon will disable all effects in the track).
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Tweak the Plugins. Left-click on the plugin name to open and close its Plugin Settings screen.
Some plugins have a generic interface like the Fruity Reverb 2. Others have more complicated
looking controls (like Fruity Limiter). Most plugins come with their own help, so we won't go into
how to use the controls here. Why not play with them all to see what they do?
Sending Sound to the Mixer. The box in the top right of the plugin window under the Channel
Settings icon, is a Mixer track ‘send’. Any effects placed in the Master Mixer Track will be applied
to all the sounds in the song. But effects in Mixer Tracks 1-103 will only be applied to the Samples
and Synths, which have selected that Mixer Track in their Track Send control.

What are all those wires and knobs at the bottom of the selected track? You can send audio
from one Mixer track to any of the others. Select a track, then click the ‘Open send’ switch on any
destination tracks you want to use and adjust the knob to change the audio send level. Sidechain
sends happen when you turn the audio to minimum. These are useful for some FX that can use
sidechains like Fruity Limiter.

Changing Plugin Order. The order in which you add effects plugins decided in what order the FX
are applied to the signal. Think of it this way – the signal enters the top of the FX stack and leaves
the bottom. So, Delay above a reverb would mean the delay sits in a wash of reverb. Reverb above
delay means the reverb tail is chopped up and delayed. To make it easier to experiment with effects
order, FL Studio has a simple function to move an effect up or down in the effects chain. A quick
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way is to place your mouse cursor over the FX slot and scroll your mouse wheel. No wheel?
Click the menu arrow at the start and choose ‘Move up/down’.

Place your mouse
pointer over the FX
name and scroll the
wheel.

A sidechain means a sound from one mixer track can be passed directly to a specific effect
on another, a direct connection. Normally sound goes from slot 1 to 10. For VST plugins the
sidechain input shows on the VST Wrapper Setting > Processing tab.
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What do the Effects plugins do? As mentioned, you can get on-line help for all of the FL Studio
Plugins, but here's a quick rundown on what they all do sorted by category –

Automation
Automation effects generate control data in response to audio or time/tempo input. You can use
these to automatically move knobs and sliders on your synths and effects. A helping hand!
Fruity Formula Controller (included) - Define your own controller functions using mathematical
formula.
Fruity Peak Controller (included) - Generate controller data based on audio input and LFO
settings.
Fruity X-Y Controller (included) - Control two parameters simultaneously with your mouse.

Compression
Compressors & Limiters reduce the difference in level from the quietest to loudest sounds. Usually
they can be used to make tracks louder, punchier, bass fatter or to make a vocal more clearly
audible over the music.
Fruity Compressor - Control volume peaks and fatten sounds.
Fruity Limiter - Single(included) - band maximizer, compressor and limiter.
Maximus Multiband Maximizer - Heavy weaponry for the loudness war.
Fruity Multiband Compressor - Control volume peaks and fatten sounds in three independent
frequency bands.
Fruity Soft Clipper - Easy(included) - to(included) - use volume limiter.
Soundgoodizer - It's shiny, it's good!
Transient Processor - Control attack and release dynamics.

Delay/Echo
Delays and echoes are particularly effective when they are tempo synced. That is, the echoes fall
in time with the beat. Most of these plugins have ‘tempo sync’ options.
Fruity Delay - Create echoes.
Fruity Delay 2 - Create echoes with echo filtering options.
Fruity Delay Bank - Create complex echoes and filtering.
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Distortion
The classic electric guitar sound is heavily based on distortion effects. These add a fuzzy raspy
tone to any input. You can even use them to make your voice sound like a guitar. Just hum or
‘Oooo’ into a strong distortion setting on the effect.
Fruity Blood Overdrive - Create distorted guitar effects.
Fruity Fast Dist - Easy-to-use distortion plugin.
Fruity Squeeze - A Bit-reduction and sample skipping plugin.
Fruity WaveShaper - Define your own distortion curves.

Equalization (EQ)
The classic Bass and Treble controls found on most Hi-fi gear is an example of EQ. FL Studio
comes with a range of very sophisticated EQ effects that allow you to sculpt the tone of sounds
right down to specific frequencies. TIP: Try not to boost too much, rather cut what you don’t want.
For example, rather than turn up the bass, you can turn down the treble.
Edison Equalize Function - Envelope-based EQ
Fruity Convolver - Phase linear EQ (activate from presets)
EQUO - Graphic EQ
Fruity 7 Band EQ - Seven 'tone controls' at fixed frequencies.
Fruity Bass Boost - Specialized bass EQ plugin.
Fruity Parametric EQ - Control bandwidth and target frequency of EQ bands.
Fruity Parametric EQ2 - Control bandwidth and target frequency of EQ bands in style!

Filtering
Filtering is a special case of EQ but generally these are designed to be automated or create
sweeping effects.
Fruity Delay Bank - Filter delays and echoes.
Fruity Fast LP - Easy-to-use low pass filter which cuts high frequencies.
Fruity Filter - Easy-to-use filter.
Fruity Free Filter - Easy-to-use variable state filter.
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Fruity Love Philter - Advanced filter plugin.
Fruity Vocoder - Sound like a robot or make a synth 'talk'.
Vocodex - The last word in vocoding.

Phasing/Flanging/Chorus
Like filtering these effects provide automated sweeping changes to the sound, but affect only
narrow frequency bands. You will instantly recognize all of these effects as they are some of the
most popular in music.
Fruity Chorus - Create multiple detuned copies of the original sound, adding depth and weight.
Fruity Phaser - Make sounds like a jet passing at high altitude (phase cancelling).
Fruity Flanger - A more intense version of Fruity Phaser.
Fruity Flangus - Advanced flanger effect.

Reverberation
Reverberation or ‘reverb’ for short, simulates the sound of spaces. Put your music in a cavern or
bathroom, it’s up to you. To create a spacious sound, don’t just drown the music in long-decaying
reverb. Use a delay with some short echoes. Big spaces like stadiums and canyons make echotype sounds (your brain thinks THIS IS BIG) not cave type sounds (I AM TRAPPED!).
Fruity Convolver - 'Borrow' rare and exotic recording locations and use their sound as your
own.
Fruity Reeverb - Simulate acoustic spaces such as a concert hall or bathroom.
Fruity Reeverb 2 - An even better way to simulate acoustic spaces.
Edison Convolution Reverb - Apply real-space acoustic fingerprints to audio (non-realtime).

Tools
This is a collection of effects that perform specific tasks as described. These generally don’t make
sounds but process them in some way.
Edison - Wave editor.
Fruity Balance - Position sounds in the stereo field.
Fruity Big Clock - Show the bar/beat/time of the song.
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Fruity Center - Remove DC offset from waves/plugins.
Patcher - Chain instruments & effects and use them again in new projects.
Fruity dB Meter - Show volume in a nerdy way.
Fruity HTML NoteBook - Add HTML synced to the playback position.
Fruity LSD - Access the synthesizer built into your soundcard.
Fruity Mute 2 - Turn noises off.
Newtone - Pitch editor and correction.
Fruity NoteBook - Make notes in your project synced to the playback position.
Fruity PanOMatic - Move sounds in the stereo field automatically.
Fruity Phase Inverter - Invert the direction of a wave relative to the original.
Pitcher - Pitch correction and harmonization.
Fruity Scratcher - Simulate turntables.
Fruity Send - Siphon a sound from any point in the FX chain to a 'send' track.
Fruity Spectroman - See what your sounds look like (sonograph).
Fruity Stereo Enhancer - Simulate or enhance stereo effects.
Fruity Stereo Shaper - Mid/Side stereo enhancer.
Fruity Wrapper - Integrate 3rd party FX with FL Studio.
Gross Beat - Play with time (scratching, stuttering, glitch, gating, etc).

Visual
ZGameEditor Visualizer - Visualization effect with movie render capability. You can automate
any of the existing presets or even program your own.
Wave Candy - A flexible audio analysis and Visualization tool. Put it in the Current (C) mixer
track.
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Preset Effects. If a plugin has built in presets you can access them through the presets section of
the effects menu as seen above, or by using the little arrows (top right corner of the plugin window)
as with the synthesizer plugins. You can create your own presets by clicking save preset. When
you do this, FL Studio saves the positions of all the plugin controls so that you can get that exact
effect sound back again later. If you save your presets in the directory FL Studio suggests, then it
will appear on the menu under presets.
Getting New Plugins. FL Studio has a great selection of FX Plugins but people are always creating
new ones, and you can find many of them on the web. Some are free and some cost money. Surf
the web (kvraudio.com is a great place to start) and see what you can find! The on-line reference
(press F1 in FL Studio) contains in-depth step-by-step guides on how to install and use such third
party plugins.
CPU Considerations. "Woh! I can use as many plugins as I want?!?" Actually, no you can’t. Each
plugin you use takes up a certain amount of your computers power. Some take more power than
others. The number of plugins you can use before your computer starts grinding and running out
of breath depends directly on your CPU speed. There is no formula for how many plugins you can
use, but if the sound starts breaking up after you add a plugin, it’s a good sign that you’ve gone a
few plugins too far. Don’t forget that adjusting the Buffer Length (F10 Audio settings) can often
solve your CPU problems (see the “First Run” section page 8).

Just as with Synthesizers, there are lots of FREE VST plugin effects on the web. BUT FL
Studio has so many to choose from, why not start with all the included effects with FL Studio.
One of the most useful for getting a loud commercial sounding mix is Fruity Limiter.
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RECORDING KNOB MOVEMENTS - AUTOMATION
Did you know you can record any movements you make to any knob? It’s called ‘Automation’ and
it's the key to making your songs come alive. So, let’s record some automation. Let’s automate the
PAN knob for one of the Sampler Channels.

Watch the pan
move!

1. Choose an Automation Pattern. OK, this is important. Automation is easily misplaced so it
can be a good idea to name a Pattern ‘Automation’ and place it at the top of the Playlist. You
will be able to see the automation in the Pattern Clip as a background shading. As you learn
more about what you are doing, you can break out of this mold, but you need to start simply.

Right-click the record button and
check Automation recording is ON!
It doesn’t matter if the others are
also ticked.

2. Record Some Live Tweaking. The easiest thing to do is create a new flp (File > New), lay
down some drum loops and practice playing with the Channel PAN and VOL knobs of the snare
(for example). When you think you've got something groovy, make sure you've selected the
Main Automation pattern and have selected Automation recording in the right-click menu
on the record button, then press the Record Switch shown below. You may hear a three-tick
countdown first, depending on whether the 3.2. countdown switch is on. Then start the song
and work your magic. The song will play once and then stop. Turn recording off and press
Play in Playlist mode, with your pattern in the Playlist. You've just done your first Live
Recording session!
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Intro count in (useful)
Switch to Song mode to
play from the Playlist
Record Switch ON

3. Important Note. When you've got the Recording Switch on and the loop is playing, moving a
knob will erase over all the previously recorded tweaks from that point in the song until the end.
This can be frustrating, so often it's best to get the recording approximately the way you want
it and then make further changes in the Event Editor described in the next section.
4. What can be Recorded? Most knobs and sliders are recordable, including those that control
Plugins. But some controls aren't recordable. The quickest way to tell what's recordable is to
mouse over a control and look for the red recording icon in the Hint Bar. If these steps appear,
then you can record that control.

Hint bar description

Red Dot

5. Where is my data? All automation is recorded into the currently selected pattern (see page
15). To see it, in context, place the Pattern Clip in the Playlist track area, the display will show
a mini-graph.

Plugins. You can record live tweaking (moving) of knobs on
most Plugins, but not all knobs. Experiment to find out. Check
the live manual (press F1 in FL Studio) section on Recording
Audio, Notes & Automation.
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LemonBoy's Live Tweaking Recording Advice…
1. Always, always, always check the pattern selector before you start
recording. Automation will be recorded into the selected pattern.
2. Right-click on the record button to check Automation, Score (notes)
and or Audio is ticked. Depending on what you want to record.
3. Get your song laid out the way you want it before you start live
recording. This makes it much easier than trying to align automation to
song structure. It’s better to record automation on an existing song.
4. Always save a backup copy of your project before you start any live
recording. That way if you mess things up or change your mind, you can
go back to the clean copy.
5. Save your project frequently during live recording. Press Ctrl+N to quicksave a ‘new’ copy of your project. This adds a _1, _2, _3 etc each time you
do it to your project file. If you accidentally tweak something and erase
some events, you can always go back to any previous version.
6. Get yourself an External Hardware controller to make your life easier.
Check the Google/Apple app stores for Image-Line Remote (See the
section on External Controllers for more info!)
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RECORDING & EDITING AUTOMATION
Unless you're a real pro, you'll probably find that the live knob tweaking doesn’t always sound
perfect. That's where the event editor comes in. Each time you move a knob during a recording
session, the new setting is stored as an "event" for that knob at that moment in the pattern. With
the event editor, you have complete control over how the sound is tweaked during playback.
NOTE: You will find an option under the Edit Menu to convert Event data to Automation Clips. This
allows you to export the automation to a format that can be directly tweaked in the Playlist rather
than in the editor.
1. Record Some Live Tweaking on a Particular Knob. The PAN on the Snare sample, for
instance. Let's assume you already did that in the previous section.
2. Stop FL Studio and Open the Event Editor. Right-click on the knob you automated, and
select Edit Events from the pop-up menu. This graph controls the level of a single knob or
slider at a particular point in the song. Remember how we told you to keep all your live
recording in a single pattern (Pattern 2) and place this pattern once at the beginning of a song?
If you do that, then the bars in the Event Editor will match the bars in the Playlist. If you don't
do that, you're on your own! The other main difference is that this graph is used to set Events
(bright vertical lines corresponding to the value of the knob you are setting) that persist until
the next event.
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3. Event Editor Modes. The event editor has several modes, explained below:
Main Menu - Includes: File, Edit, Tools, View, Snap, Zoom, Target and Smoothing
options.
Tools Menu - Includes: Scale Levels and LFO tools.

Snap - Controls the time resolution (horizontal). E.g. a setting of '(none)' will allow the
finest resolution while 'Beat' will only allow value changes on every beat.
Draw tool - Left-click and drag to draw curves. Right-click and drag to draw straight
lines OR to edit in interpolate mode. Modifier keys: (Shift) - Lock vertical position. (Ctrl) Select time-line. (Alt) - Bypass snap.
Brush tool - Bypasses the snap value. Right-click and drag to draw straight lines OR to
edit in interpolate mode. Modifier keys: (Shift) - Lock vertical position. (Ctrl) - Select timeline.
Erase tool - Resets data to the value at the start of the selected range. Modifier
keys: (Ctrl) - Select time-line.
Interpolate - Redraw and connect data with straight lines.

Select tool - Make a time-line selection.

Zoom tool - Zoom the time-line. Right-click to zoom out.

4. Miscellaneous Facts. Here's some stuff you should know about the Event Editor.
a. Undo. There is a limited form of undo available for the Event Editor. Use CTRL-Z to undo
the last action.
b. Setting the Initial Event. You will notice that after live recording, the knob you recorded
sometimes doesn't start in a sensible place when you play back the loop. This can be fixed
by turning the knob to a good start position, and then right clicking the knob and selecting
Init Events With This Position. This sets the very first event so that the knob will always
start where you want it.
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c.

Getting a Feel for It. It takes some practice to master the event editor, and to be able to
get a song to sound exactly the way you want it, but it's definitely worth it. Keep practicing
until you get it right!

d. Live Recording Defeats Static Tweaking. If a knob has some events recorded on it, you
can no longer just set it anywhere you want and expect it to stay there. You have to go
through the Event Editor or start a new live recording session to change it.
5. Introducing the Event LFO tool. Sometimes you want basic oscillation of a parameter, but
it’s hard to control exactly how this oscillation is going to fit with the song. That problem is
solved with the Event LFO, which lets you simulate the perfect oscillation inside the event
editor and align the peaks/troughs against the tempo grid.

6. Using the Event LFO. Open . the event editor for some control. Make sure you're on the right
pattern in the Pattern Selector or Picker Panel. Now select an area to oscillate using Select
Mode or by right-clicking on the Play Indicator Bar. Now hit ctrl-l or select LFO from the Tools
Menu. This will pop up the LFO Settings window and immediately apply the LFO to the
selected area. See above.
7. Play with the Main LFO Settings. Notice the dialog has three sections. If you play with the
controls in the Start and Shape sections, you should be able to create all kinds of cool effects.
In the Start section, you can alter the value (height), range (depth), and speed (length) of the
waves. In the Shape section you can alter the shape of the wave (sine wave, saw-tooth, or
square) and the phase (basically moves the waves left and right.)
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AUTOMATION CLIPS
Automation Clips are probably the best way to EDIT and DRAW automation. Automation
Clips move (automate) linked controls on the FL Studio interface or plugins. They are closely
related to Event automation. But unlike event data they are not bound to a specific Pattern Clip
and exist as a special type of Generator, loaded into the Channel Rack. Automation Clip data
can be displayed in the Playlist window as a line-graph, as shown below.

There are several ways to create an Automation Clip:


FL Studio controls - Controls on the FL Studio interface and Image-Line plugins, can be
Right-clicked to show a popup menu. Select 'Create automation clip'. An Automation Clip
will be added to the Playlist Clip-Track area (as shown above). See Notes below.



VST plugin controls - Move (tweak) the target control on the VST using your mouse, then,
use the Add menu > Automation from last tweaked parameter.



Convert from Event Data - All recorded automation is saved as Event Data. Convert
Event Data to an Automation Clip from the 'Edit > Turn into automation clip' command
in the Event Editor menu.

NOTE: Time range - If you pre-select a time-range in the Playlist (hold Ctrl + drag along the
time-ruler at the top) the Automation Clip will be restricted to the selected range. If no range is
selected then the Automation Clip will span the entire song length.
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AUDIO RECORDING
What about Audio recording? You will need FL Studio Producer Edition or higher plus an ASIO
soundcard driver selected from the Audio Options (Press F10 on your keyboard to open them).
It’s a huge but rewarding area that is carefully covered in the main manual. Press F1 in FL Studio
and click on the Contents section ‘Recording Audio, Notes & Automation’, then the ‘Audio
Recording’ page. However we will tell you now that external audio inputs come into FL Studio
through the Mixer Input menus. There is one on each track, so get that sorted and you are on your
way!

External audio inputs are selected from the FL Studio
mixer INPUT menu. The input menu shows a drop-down list
of the available soundcard inputs (mic, line etc). The
screenshot above shows (Mic 1) selected yet (each mixer
track has its own external input options menu). Input options
will only be visible if an ASIO soundcard driver is active.
Note: The input names shown in the drop-down menu are
provided by the soundcard driver and are often given
strange names, so experimentation may be required to find
the correct input. Time to go buy some MICROPHONES!!!!!!
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EDISON WAVE EDITOR / RECORDER
IMPORTANT: This guide is a general Getting Started guide for all existing FL Studio Editions.
Some features however, are not available in some editions. The FL Studio Fruity Edition doesn’t
have Audio Track or the Integrated Wave Editor capabilities. Please check our site
http://flstudio.image-line.com for upgrade conditions.
Edison is a fully integrated audio editor and Mixer-track recorder. Edison loads into an effect slot
(in any Mixer track) and will then record or play audio from that position. You may load as many
instances of Edison as you require in any number of Mixer Tracks or Effects slots. To open Edison,
press Ctrl+E in a Sampler Channel, or load from the effects menu into Mixer track/s.
Many powerful tool are available within Edison.
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Select ‘ON PLAY’ and make sure the FOR duration is long enough

1. Load Edison - Load Edison in an FX slot in the Mixer track that you want to record. Don't
use the Master track (all audio from all tracks is routed there). TIP: Select the Mixer track
and press (Shift+E) to auto-load Edison in the first empty FX slot on the track ready to
record.
2. Input selection - Select an external input (see Audio Recording, page 70).
3. Effects - Place Edison before any effects loaded in the same Mixer track for a 'dry'
recording. It is recommended to record all external audio dry as you can always add effects
later on.
4. Record using Edison – Select ‘On play’ as shown above, so recording starts when
playback is started from the main FL Studio transport controls. 'On play' mode will also
place accurate song start markers when Play starts/stops or the Playlist loops back to the
start of the song. This is useful for recording multiple takes so that you can easily select
the region/s you wish to export to wave files and include in your song. Click the Record
button in Edison then press Play on FL Studio. Press Stop on FL Studio when you are
done.
5. Exporting recorded audio - There are three main ways to export audio from Edison into
FL Studio:
A.

Send to Playlist button, Left or Right-click to: Left-click: Send to Playlist
as Audio Clip (Shift+C) - Dumps the selection to the Playlist as an Audio Clip.

B.

Drag / copy sample / move selection - Left-click on the button and drag to
the desired location (e.g. Playlist Clip-track). The selected region in the Sample
Edit Window (or whole sample if no selection is made) will be copied and moved
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to any compatible location in FL Studio.
C.

Save and load - Save the audio/selection to a file and re-import it through
the Browser.

Apart from recording audio, Edison is really about EDITING and has some very cool tools:
Convolution Reverb
Reverb impulse files are created by recording short, sharp sounds in real spaces or through a
reverb/effects unit. The recorded reverb is an acoustic ‘fingerprint’ of the real space. This technique
is equivalent to sampling an acoustic instrument and allows us to 'borrow' impulses from very
expensive hardware or real spaces that we would never have the chance to record in. Naturally,
the internet is brimming with free impulses for your downloading pleasure.

The Edison Blur Tool works in a similar way to the Convolution Reverb, by multiplying an impulse
sound (in this case, noise), against the waveform. The result is to smear or 'blur' the sound. The
multiplier function is determined by a user-selectable envelope. To preserve more of the original
qualities of the sound, use narrower shaped envelopes. Whatever it sounds amazing when added
to any sound.
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The Equalize Tool boosts or cuts frequencies according to a user defined EQ envelope. The
example below shows the effect of the selected EQ curve on a white noise sample. Frequency is
displayed on the horizontal axis, time on the vertical axis (sample start is at the top, sample end is
at the bottom) while intensity/saturation of color represents frequency amplitude.
To open the tool you can either left-click on the EQ Tool button
use the Tools > Spectral > EQ option.
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, press Ctrl+E inside Edison, or

The Time Stretch / Pitch Shift tool allows you to alter the duration, pitch and formant of a sample
independently. Edison and, more generally the Sampler Channels & Slicer tool, use algorithms to
deliver advanced time stretching / pitch shifting that meets the standards of professional production
and broadcast applications.

To open the tool you can either left-click on the Time Tool button
use the Tools > Time > Time stretch / Pitch shift option.

Cool! Hit me with your rhythm stick! I live for beats.
Fast beats, slow beats, big beats…
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, press Alt+T inside Edison, or

EXPORTING AUDIO AND SHARING YOUR WORK
So now you’re done with your song – you probably want to get it out of FL Studio so you can put
it on a CD, post it on the Internet, or edit it in another program. The Export function exists for this
purpose. Here's how to use it.
1. Export to Wav, Ogg. or MP3. This option is available from the Main File menu. Whether you
choose Wav, Ogg or MP3, you will be asked to specify the name of the file and then the dialog
below will appear. There's a lot to choose from here, and we don’t have space to go into detail.
If you want an explanation of every button, go to the on-line help F1, it's all there. ..

Are you in SONG mode
dude?

2. Should I Use Wav, Ogg or Mp3? Wav is the highest quality (un-compressed) sound file
format. Expect to use about 10 MB per minute depending on Bit Depth. 44.1 kHz, 16 bit Wav
files are for burning onto CD. MP3/Ogg are compressed formats with smaller files, but sound
quality may be compromised, expect to use about 1 MB per minute depending on Bit Rate. If
you want to share files on the Internet, MP3 is perfect.
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3. Should I Use "Background Rendering?" Rendering can take a long time and hogs the CPU,
especially if you choose the higher-quality options in the Quality section of the window above.
But if you click on Background Rendering, FL Studio will minimize and continue to render
unobtrusively in the background. It takes longer…but the internet has plenty to see while you
wait.
4. Exporting to a Zipped Loop Package. This feature is useful if you want to transmit your FL
Studio project over the web. It takes your FL Studio file, plus all the samples used in that files,
and puts them into one zip file. Note that it does not save the plugin Instruments you used, just
the samples.
5. Project Bones and Project Data Files. These options let you save a lot of the information
about your track. The Project Bones option saves a file with all your presets, automation
information, and so on to be loaded later. Project Data Files saves all the samples and other
raw data you used to a single location on your hard drive.
6. Where Can I Put My Songs? There are a number of places on the web where artists can
place their music in MP3 format for free. http://www.soundcloud.com is probably the bestknown site, but it's easy for an amateur looper to get buried there in all the high-profile
commercial stuff. Image-Line (that’s us) has a Song Exchange forum (http://forum.imageline.com/index.php) if you are more interested in feedback from other musicians who use FL
Studio. It's a great way to get feedback from fellow Floopers (that’s you). If you don't like either
of these options, you can always create your own site using one of the many free hosting
services out there. Did you know we also make our own website building tool? It’s called
EZGenerator, check it out here - www.ezgenerator.com Too EZ!
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EXTERNAL & INTERNAL CONTROLLERS
Did you know that you already have at least two ‘external controllers’ attached to your PC? One is
your typing-keyboard and the other is your mouse. Obviously these don’t make sounds, but send
control signals to your PC so you can type and move your mouse. Similarly, external USB/MIDI
controllers are just devices to send control signals to your PC, however in this case they are
designed to play like a piano keyboard, move like a Mixer desk, turntable deck or any other piece
of hardware that is used to make/mix music. With a controller attached you can move the knobs
and switches in FL Studio, or play a plugin instrument like a synthesizer. The only catch is that as
the controller isn’t hard-wired to particular functions, you have to tell FL Studio ahead of time what
you want each knob on the controller to do (this is just the same as assigning your typing-keyboard
control-keys in a game for example, a minor inconvenience for the luxury of changing both cutoff
and resonance at the same time!) Each knob on the controller can be linked to a different knob or
slider on FL Studio. If you have a controller, this section will tell you how to make it work with FL
Studio. If you don't have one, get one, if you aren’t sure where to start consider a small 2 octave
MIDI keyboard with some knobs, you won’t regret it! First we'll introduce a few of the more popular
controllers, and then we'll tell you how to set them up.
1. A Few Examples of Controllers:
Korg NANOKEY, NANOKONTROL, NANOPAD (inexpensive and portable) – These are
tiny-tiny controllers (with a tiny price to match), great for people on the move with a laptop. The
one with the knobs has 9 assignable knobs and 9 sliders that can be linked to knobs and sliders
in FL, has transport controls to start/stop FL Studio and is connected to your PC over USB.
Easy! There are a range of small MIDI keyboard controllers out there, time to hit Google and
check them out!

Wow these are small like squirrels. Squirrels
make me nervous man…stay AWAY FROM ME
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Other Controllers (advanced use) - If you are serious then the sky is the limit, the best type
is something like the nectar Panorama P4 & P6 which has more control action than you are
ever likely to need (Keys, pads, knobs and sliders). Similarly if you already have other MIDI
hardware, like the Novation Launchpad (shown below) then that can be used to control FL
Studio too (the Launchpad is the perfect match for our FPC plugin!).

Launchpad Mini + FPC = Bliss!

2. Setting Up Your Controller.
a. Connect your controller to your PC (USB or MIDI). Most MIDI controllers use a USB
cable, but if you have older MIDI equipment it will have MIDI specific cables (large round 5
pin connectors). You will need to buy a MIDI to USB interface for your PC. Note: MIDI is
not an audio connection - MIDI connections transfer note data, knob movements and
program changes so that your controller can play software instruments and or FL Studio
can play connected MIDI hardware. To use sounds from an external synthesizer (while
it is played by FL Studio) you will need to make MIDI and audio connections to your
soundcard inputs so that FL Studio can record the sound/s that it triggers from the external
MIDI hardware using a MIDI Out. Check the manual (F1 key) for more details.
b. Turn on the Controller (wait for it to be detected) and THEN Start Up FL Studio. Press
F10 to open the system settings. Just select ‘Generic Controller’ in the controller type for
now, although if your controller’s name shows in the drop-down menu then definitely
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select that. Try turning the knobs on your controller. If everything is ok, you should see
a green Data indicator show in the Hint Bar of FL Studio every time you turn a knob or hit
a key. If that works, great! You can skip steps c to e. If not, read on…
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Data input
indicator

c.

Check the Options menu to see if there is a check mark beside Enable MIDI Remote
Control. If not, click on it and see if you get the light now. If not, read on.

Master FLooper: Yo, check it out. I need a
keyboard controller for FL Studio.
Computer Store Guy: QWERTY or AZERTY?

Master FLooper
d. Set Your MIDI Input Device. If the light is still not coming on when you turn knobs on your
controller, go into MIDI Settings (from the Options menu or by hitting F10). Check out
the Remote Control Input box. If you see the word "none" there, then you've got to select
an input. Typically, you will be presented with a number of choices, and you'll just have to
try them all to figure out which one is right.
Hey did you know you can use MORE than one
controller with FL Studio at the same time? Just
set each of your controllers to transmit on a
separate MIDI Channel (check the manuals that
come with your gear) and you can control multiple
Instrument Channels or the Playlist jump-to
markers…COOL!

e. Troubleshooting Checklist. If the red light is still not coming on when you turn the knobs
on your controller, here's a list of things you should check.
* Did you select the correct controller type in step b?
* Did you enable "Enable MIDI Remote Control" in step c?
* Did you select the correct MIDI input in step d?
* Is your USB controller detected OR are your MIDI In and Out cables reversed?
* Did you plug the controller into a power outlet?
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The fun part - Linking a knob to Your Controller:
a. Right-click on the Control You Want to Link to the hardware controller. In this case,
we're trying the main pan control on a sampler Channel. Now right-click on the knob and
select Link to controller, to pop up the Remote controlling settings window.

b. Move a Knob or slider on Your Controller. You should see the Remote controlling
settings window disappear and the Channel Volume knob should now move in response
to your hardware knob movements. You're in business!
3. Which Controls Can I Link? Pretty much all of them, actually. For reference, though, it's the
same set of controls that can be changed in Live Recording. Again, if you want to know
whether a control can be linked externally and live recorded, mouse over it and look for the red
dot in the Hint Bar.
4. What About Internal Controllers? Finally, we can tell you about the Internal Controller Plugins
listed in the Effects section (the Formula Controller, Peak Controller, and X-Y Controller). These
are plugins with controllers, which can move other controls. Did you follow that? Let’s take the
Fruity Peak Controller as an example. Open the Mixer window (F9) and put a Fruity Peak
Controller on Mixer track 1.
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Turn OFF Mute
a. The Peak Controller allows you to control any target in response to audio signals in the
mixer track it’s loaded on. We’ve put it on the Mixer track the Kick is using. We are going
to use it to dip the volume of another track when the kick hits.
b. Next right-click Mixer track 2s fader and select Link to controller. Choose ‘Peak ctrl –
Peak’ from the menu shown below. Peak controller now shows as an option anywhere in
FL Studio you link to something. Below that is a ‘Mapping formula’ menu. From that choose
‘Inverted’. Then click ‘Accept’.

Choose ‘Peak ctrl –
Peak’ from this
menu.

c.

Now Mixer track 2’s fader will dip down every time the Kick hits. This can be really useful
for creating ‘pumping’ effects on sustained chord sounds. Have a play with the controls on
Peak Controller and see what you can make it do!
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Well, that’s it. Have fun! Don’t forget
there’s more help available inside
FLStudio (F1) and on line at
http://flstudio.image-line.com.
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Chorus, 54
Compressor, 54
Computer considerations, 62
Cool features, 7
Copyright, 2
Countdown, 63
CPU load, 62
Cut itself, 24
Cutoff & resonance, 19, 22, 23, 29, 66, 78, 83

3
321 countdown, 63
3xOSC, 34, 36

A
Additive synth, 44
Additive Synth, 43
Additive synthesis, 43
Amount (AMT), 19, 20
Aphex Twin, 37
Arpeggiator, 19
Attack (ATT), 19
Audio editor, 71
Audio saving, 76
Audio Settings, 8
Audio Tracks, 31
Autogun, 34, 36
Automation, 63
Knobs, 82
Automation clips, 31

D
Decay (DEC), 19
Delay (DEL), 19
Delay (echo), 19, 54
Demo plugins, 52
DirectSound streaming buffer, 9
Discussion forum, 11

E
Echo (delay), 19, 54
Edison, 71
Effect plugin order, 56
Effects, 15, 52
Effects plugins, 58
Effects tracks, 56
Envelope, 19, 20
Equalizer, 54
Event editor, 29, 64, 66, 67, 68
Event LFO, 68
Events (initial), 67
Export, 76, 77
Export audio, 76

B
Background rendering, 77
Bass, 37
Bass arranging, 31
BassDrum, 37
BeatSlicer, 45, 53
BeepMap, 34, 37
Bit depth, 76
Bit rate, 76
BooBass, 34, 37
Browser, 16, 53
Buffer length, 9, 62

F
FAQ, 5, 6
Feed, 19
Filters, 22, 23
FL Studio Mobile, 39
Flanger, 54
Flooper, 81
flstudio.com, 11, 52, 53
FM synth, 49
Fruit Kick, 34, 39
Fruity DrumSynth Live, 34, 40

C
Channel selector light, 16
Channel settings, 17, 18, 23, 34
instrument panel, 19, 23, 36
Channels, 13
Chop up samples, 48
Chop up sound, 41, 45
Chords, 28
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Fruity DX10, 34, 40
Fruity Granulizer, 41, 53
Fruity Scratcher, 53
Fruity Slicer, 45, 53
Fruity X-Y Controller, 82, 83
FruityLoops.com, 2
FX plugins, 58

Menu bar, 11
Metallic synth, 44
MIDI
controllers, 50, 78, 81, 82
drivers, 8
files, 29
MIDI Out channel, 50
settings, 81
Mixer tracks, 56
Morphine, 43
MP3, 76, 77

G
GMS, 42
Graph editor, 22, 23
Groove Machine Synth, 42

N
NewStuff.flp, 11
Note cut off, 24

H
Harmor, 43
Hint bar, 11, 30, 64, 82
MIDI, 80
MIDI indicator, 82
Hold, 19

O
OGG, 76
Ogun, 44
On-line help, 11, 18
Options & settings, 8
Oscillator (OSC), 36

I
Import MIDI, 29
Initial event, 67
Installing FL Studio, 5
Installing FL Studio Offline, 6
Internal controllers, 82
introduction, 7

P
Pan, 15, 19, 22, 23, 29
Pat/song mode, 30
Pattern selector, 30
PC considerations, 62
Performance Mode, 33
Phaser, 54
Piano plugin, 38
Piano roll, 25, 26, 28
Editing, 27
Lower panel, 26
Picker Panel, 30
Ping pong delay, 19
Pitch, 19, 22, 23, 29, 53
Piano roll, 25
Pitch bend (slide), 28
Pitch bending, 28
Play indicator, 25, 30
Play switch, 11, 14
Playlist, 30, 31, 63
Plucked!, 34, 46
Plugin, 16, 34, 52, 53, 55, 56, 62
Plugin instruments, 35
PoiZone, 46
Power considerations, 62

K
Keyboard controller, 79
kick drum, 17
Knowledge base, 5, 6
kvraudio.com, 53

L
Lemon Boy, 12, 16, 53, 64, 78, 85
LFO, 19, 20, 68
depth, 68
Lifetime free updates, 7
Live recording, 66, 68
Loop point, 26, 30

M
Main window, 11
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Speech Synthesizer, 53
Speed (SPD), 19
Step, 15
Step sequencer, 16, 24, 25, 30, 34, 53
Steps, 13, 14, 22, 25
Subtractive synth, 49
Sustain (SUS), 19

Presets, 35, 62
Project bones, 77
Project data files, 77

R
Recording
automation, 68
Recording countdown, 63
Recording hint icon, 64
Release (REL), 19
Remote control input, 81
Resonance & cutoff, 19, 22, 23, 66, 78, 83
Reverb, 54
RM Synth, 49

T
Technical support, 5, 6
Tick beat, 63
Tool bar, 27, 30
Toxic Biohazard, 44
Troubleshooting, 81
TS-404, 34, 63

S

U

Sample browser, 16, 17, 53
Sample editor, 71
Sample slicer, 45
Sampler, 18
Samples, 16, 17, 19, 20, 23, 24, 34, 53, 56
Samples granular, 41
Save
16bit, 76
24bit, 76
32bit, 76
Audio, 76
MP3, 76
Samples, 77
Sawer, 47
Scratching effect, 50
Setup Wizard, 12
Shift, 22
Shortcuts, 11
SimSynth
Live, 34, 47
Slicex, 48
Slide (pitch bend), 28
Song/pat mode, 30
Soundcard Driver, 8
SoundCloud.com, 77
Spectrum analyzer, 37

Undo
Event editor, 67
Piano roll, 27

V
Velocity (volume), 22, 29
Volume, 15, 19, 22, 54, 82
VST Plugin, 52, 53

W
Wasp, 34
Wave
Editor, 71
Export, 76

Z
Zipped loop packages, 77
Zipped project, 77
Zoom Event Editor, 66
Zoom Piano roll, 26
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