SYSTEM SETTINGS

System Settings - Files

To open the File Settings choose 'Options > File settings' from the main menu or press the F10 function key on your keyboard. The File Settings page allows you to link additional folders into the Browser, along with a location where your VST/VSTi plugins are saved. You can then directly access these files from the FL Studio Browser. To open: Press F10 and select the File icon. The first time you open this page, the folder slots will be empty, each row represents one 'custom' folder that you can add to the Browser. Folders set here also be searched (and all sub-folders) for samples and sounds when you load a project. It is unwise to select the root of your C: drive for example as FL Studio will search all the folders on your hard-drive when it is looking for a file.

NOTE: At any time you can open a standard Windows Browser (Right-click on the Windows 'Start' button and select 'Explore') and then drag compatible files from the Windows Browser into FL Studio (FL Studio will behave in the same way as noted in step 1 below).

We have a series of video tutorials on using the Browser & extra search folders here.

NOTE: You can drag-and-drop folders from the Windows browser on the 'Browser extra search folders' area and they will be added.

Backup (Autosave)

The Autosave function will create backup copies of the current project (and/or any overwritten files including .flp, .fst, .zip etc) to the Browser > Backup folder. This folder is located in FL Studio's installation directory ..:\Program Files (x86)\Image-Line\FL Studio\Data\Backup. If you want to recover the last autosave then use the option 'Revert to last autosave' from the File Menu OR select a project from the Browser > Backup folder. Autosaves are made according to the following settings and rules:

NOTE: Only the last 20 saves & or auto saves for all projects that you have been working on are retained. The purpose of this system is for emergency recovery of crashed, damaged or incorrectly edited projects. For permanent sequential backups use the (Ctrl + N) save shortcut or select File > Save new version.

Plugins (VST)

Virtual Studio Technology (VST) is a software interface standard that allows you to load 3rd party software synthesizer and effect 'plugins' in FL Studio. VST is in addition to the FL Studio 'native' plugin format. See the section on installing VST plugins for more details on VST plugins and how to use them.

Browser extra search folders (add your own folders to the Browser)

30+ custom Browser folders can be set (note the scroll-bar down the right side of the window).

How to set a Browser extra search folder:

  1. Left-click on the folder icon at the start of a row as indicated above and browse to the folder location and then click 'OK'. Alternatively, double-click the text fields to enter paths manually.
  2. Optionally, Left-click in the Name column and enter a custom name, this sets the name shown in the Browser. If the name field is left blank then the name of the target folder will be shown in the Browser.
  3. OR drag-and-drop folders - From any Windows file explorer onto the Browser. This will set a custom folder to match.

What do they do? The folders set here will appear in the FL Studio Browser. Here are four good reasons to use them:

  1. You can drag sounds/samples/patches from the Browser onto the desired location in FL Studio and they will be loaded automatically (channel sampler, slicer, projects [drag onto the desktop], etc).
  2. External folders keep your data independent from the FL Studio installation.
  3. The extra search folders are (as the name suggests) included in automatic search and load operations.
  4. The Browser contains some useful manual search functions ('Find' and 'Smart find') so you can quickly locate your files.

External Tools

The External Tools dialog lets you set up external applications (wave editors, sample browsers, etc.) for use as tools in FL Studio.

  • File Location - Enter the full path to the external application to be used as a tool. Alternatively, click the file icon on the left to browse for an application.
  • Name - Displays the program name displayed in the Tools menu.
  • Options - Select the tool in the file list then choose options: